Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,480 Members 44,907 Now Online
XDA Developers Android and Mobile Development Forum

LG LGL75C (Optimus Zip)

Tip us?
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jul 2012
Location: Aberdeen
Question LG LGL75C (Optimus Zip)

Hello everyone.

  • Originally, I was going to flash my Droid X2's MEID to my LG OpZip's MEID and use the X2, but found out when I got home, it had to be unactivated, and I was already activated, so that plan went down the drain. I've spent the last, oh, 2 or 3 days trying to root, install a custom rom, and expand my internal storage to no avail. After doing alot of research on the issue in regards to rooting it, I found (on another site I think) that my sw version is not the same as the other OpZip's that have been rooted, and to all of my research, I cannot seem to find anything that matches my model and sw version.

Phone Information
  • Phone: LG Optimus Zip
  • Model: LGL75C
  • SW Version: LGL75CV1
  • Android Version: 2.3.4
  • Provider: Straight Talk (Verizon towers)

Things I've Tried
  • Super One Click
  • ADB
  • LG Optimus Zip One Click (different sw version)

Alright, now for the part I need assistance with... Does anyone know a root method for this phone? Are there any custom ROM's that are compatible, or am I overthinking it, and should assume most are compatible?

I look forward to any and all responses, and thanks in advance.

Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jul 2012
Location: Aberdeen
Bump. Don't generally like doing that, but I'm desperate to find an answer.
mesiahthegreat's Avatar
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Thumbs up Bump x2

Originally Posted by Orito View Post
Bump. Don't generally like doing that, but I'm desperate to find an answer.
I'll second that bump. The model of this phone is VS700 - But many report that root attempts are unsuccessful because of the SW version.

Interestingly enough, when trying to use LG update software on my PC, it says the LGL75CV1 is indeed on the supported device list for updates, however when the LG software tries to read the SW Version from my phone, it says ERROR. I call up LG, they say all updates should be done through Tracphone.

Is there something different about the file system? are developers somehow locked out of this? Any update would be great. The phone has potential, alot of potential. Lets get it rooted guys!
beltsnspoons's Avatar
Senior Member
Thanks Meter 80
Posts: 477
Join Date: Jul 2011
Location: Dayton, Ohio

a friend of mine has this phone with this sw version (lgl75cv1) and is chomping at the bit for me to get it rooted for him. if anyone, anyone at all, has any info please speak up.

thanks guys
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2013
I was able to root this phone today easily using this thread referred by a user at another forum.

I can't post a link but the instructions are at androidforums under a thread called "Finally rooted M865c for Straight Talk"

It works fine for the LG Zip LGL75C 2.3.4

It was a very simple process. I am now looking for a way to install a clockworkmod recovery on the phone to make a backup. Anyone have any insight on how to install the correct CWM please advise.
Junior Member
Thanks Meter 0
Posts: 3
Join Date: May 2011
Question LGL75c Optimus Zip

Everywhere i look it says this phone cannot be rooted because it has a locked bootloader. I even went as far as paying root android for the software which they assured me would root this phone. It failed miserably.

I am looking for anything that will help me root this phone as I want to tether the 3g to my nexus 7 tablet, to have internet wherever I go with my tablet.
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Apr 2013
Thumbs up How to root LGL75C

I just managed to root my LGL75C (provided by Straight Talk).
Download 2 files:
Poot .apk: sharesend. com/qe9jl6ij
Ministroll .apk: sharesend. com/8orgvw4r
EDIT: Since I'm a new user, this forums board won't let me link to the apk files. Sorry :\

Step 1:
Download the Poot-debug.apk and Minstro-ii.apk and place the 2 files in the root of Your SDCARD.
Or put both files somewhere on /sdcard and open the files via file manager/explorer.

Step 3:
Install both the Poot-debug.apk and ministro-ii.apk. (You will need to make sure that you have enabled "Unknown Sources" under the application settings menu of your phone before you will be able to install these apks.)

Step 4:
After both apks are installed open Poot. It will open up ministro-ii and download quite a few libraries that are necessary for the Poot to work. Once it has completed click the button that says, "Press here to poot", and hope for the best.

Step 5:
Pay attention the the messages displayed on the screen. Most messages should start with a
, but you should see a couple of [-].
As long as the only warning messages you receive are the following, you should have successfully rooted.
Select Code
[-]current && current != last + 1: 0000ffff 0000ffff
[-]Haxx has run its coarse. Reboot the device to play again
A demon materialized while pooting. Error code: 64
You will receive these messages because Poot does not recognize the M865c kernel and is unable to clean things up without rebooting.
Again, the three warnings listed above are nothing to worry about.

Step 6:
Reboot your phone to save changes and allow the exploit to take effect.

Step 7:
Open Poot and click on the button that says Built-in rootcheck to verify that your phone is rooted. As long as Poot is able to find 'su,' and it will display its path along with a corresponding message stating success.

Step 8:
You'll probably want to download/install a Superuser app from the App Store/Google Play store, so you can give other apps su privs.
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Mar 2014
Question Tried to root LGL75C -- got "didn't find symbols" message

Originally Posted by lokicode View Post
I just managed to root my LGL75C (provided by Straight Talk).
Help! I have NO experience with this stuff. I used this method, but after I pressed "Press here to poot" I go the messages "[-] didn't find symbols" and "A demon materialzed while pooting. Error code: 20 su binary was not written." Huh? I tried rebooting and then pressing "Build-in rootcheck," but the message I got back was:
Path is:
no su was found in $PATH
Any idea what this means? I'm so clueless.
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default lcl75c recovery custom roms ?

I have rooted my lgl75c and got recovery to work by a method for lgl55c but I can't find any custom roms. Has there been any made?
(Last edited by Mayhem96; 7th April 2014 at 12:21 AM.)
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Apr 2014
Location: Ennis Texas
Default idk

i rooted my lg optimus zip and i want to wireless tether it but none of the apps work. what do i need to do to share a hotspot? i am rooted successfully and have android 2.3.4. please help? if you have answers please email me

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Control Your Toast Notifications with SlicedToasts

Toasts are delicious, even in their Android flavor. In Android, toast doesn’t lead … more

Rotation Lets You Take Full Control of Your Device’s Orientation Settings

To be brutally honest, the native options for screen … more

Change the Alarm Icon in the Status Bar with Xposed

It’s hard to find a more hated object than your alarm clock. They wake us up nearly … more

Return to Outer Space Outer Space with Ship Up Game

Since the release of Flappy Birds, we’ve had the “fortune” to see … more