Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,761 Members 41,865 Now Online
XDA Developers Android and Mobile Development Forum

[DEV] CM10 on ArchosG9

Tip us?
 
Quallenauge
Old
#1  
Senior Member - OP
Thanks Meter 437
Posts: 226
Join Date: May 2012
Default [DEV] CM10 on ArchosG9

If someone like to want try out basic running JellyBeans on his archos g9 device you can use my build.
Many things like camera, or accelerated video decoding/encoding doesn't work, also the sdcard access is not working (using vold binary from stock rom was not successful)!
(= Not for endusers, but for devs who are interested )

Working is:
* Wifi
* Audio
* GPS
* Graphics ( )

File-Image:
http://www.4shared.com/file/168Z262u...updatetar.html

Needed kernel zImage:
http://www.4shared.com/file/_yBZF1D_/zImage.html

Many thanks to JackpotClavin for your porting guide on CM9
(which was very helpful to start understanding how customized building works),
trevd for setup a CM10 repo which I used to start from and for developing 3G support on 4.0.4 and 4.1.1,
omegaRED7 for his support on 3G,
and last but not least: surdu_petru for his excellent work on modding and developing cool images for the archos device!!!

If you want to start hacking on this, use the following interesting repos as start:
Trevd's developer repo for the 3G stick:
https://github.com/trevd/huaweigeneric-ril

My CM10 config files:
https://github.com/Quallenauge/cm10-archos-g9

A note for the kernel:
Customized kernel is needed, because it provides the IPV6 mangle support, which is needed by netd service.

For me, the video acceleration is the most important thing, but due closed drivers and only a little understanding of the topic, I feel that I'm not able to solve this problem.
The Following 24 Users Say Thank You to Quallenauge For This Useful Post: [ Click to Expand ]
 
surdu_petru
Old
#2  
surdu_petru's Avatar
Recognized Contributor
Thanks Meter 7468
Posts: 3,356
Join Date: Feb 2010
Location: Paris

 
DONATE TO ME
Hi !

Very cool ! You started a great job....I hope that with our dear developers you will be able to successfully finish !
THANKS ! & Good luck !!!
*****
Huawei Ascend P6 | Quad Core 1.5GHz | 8GB | 2GB RAM ( Omni ROM 4.4.4 ! )
*****
Motorola RAZR XT910 | Dual Core 1.2GHz | 16GB | 1GB RAM ( Pac - MAN 4.4.2 ! )
*****
HTC One M8 | Qualcomm MSM8974AB Snapdragon 801 2.3GHz | 16GB | 2GB RAM ( Stock 4.4.2 )

If you find my work useful, feel free to hit the THANKS button below !
The Following 5 Users Say Thank You to surdu_petru For This Useful Post: [ Click to Expand ]
 
trevd
Old
#3  
Recognized Developer
Thanks Meter 1154
Posts: 863
Join Date: Jul 2011
Location: Hull

 
DONATE TO ME
Hi.

I was about to start looking into the sdcard issue..... Then my sdcard slot decided to fail, I think the spring has gone, I'll "Jaff" it in with some Rilza Card later on. I'll take heart that at least my device is failing one component at a time and not all at once..

With regards hardware, have you had a look around at the open source stuff at OmapMedia.org, I'm just cloning their android repo now and also linaro have done a lot of work in open sourcing and optimizing some of the TI Omap stuff..... They're next on my repo sync

I also think Scholberts' hardware thread may help as a good reference.

There's other stuff, lots of other stuff but I think having a go at the hardware seems lib a good starter for ten.

Hack On!
Don't forget to click Thanks If this post has helped. It gives me a little warm feeling inside

I WILL NOT RESPOND TO PM'S REQUESTING TECHNICAL SUPPORT


Development Work: Git Hub (https://github.com/trevd) | Huawei Dongle Support : Archos G9 , Asus Nexus 7 | adb extended version ( adbx ) [Always WIP] | The No Script, No Cygwin Standalone Boot Image Utility [WIP]
Other Work : Custom framework-res.apk resources.arsc using vendor overlays | [GUIDE][HACK]Cross Compiling for OSX on Linux with AOSP

A bug report without logs is just trivia!

Code:
adb shell dmesg ; adb logcat -b system -b radio -b events -b main
The Following User Says Thank You to trevd For This Useful Post: [ Click to Expand ]
 
Quallenauge
Old
#4  
Senior Member - OP
Thanks Meter 437
Posts: 226
Join Date: May 2012
Quote:
Originally Posted by trevd View Post
Hi.
With regards hardware, have you had a look around at the open source stuff at OmapMedia.org, I'm just cloning their android repo now and also linaro have done a lot of work in open sourcing and optimizing some of the TI Omap stuff..... They're next on my repo sync
With some luck, we can use the following:
http://git.omapzoom.org/?p=platform/...cs-mr1-release

Maybe we must patch the archos kernel for that....
 
Mavamaarten
Old
#5  
Member
Thanks Meter 28
Posts: 49
Join Date: Mar 2011
Awesome work! Instead of everyone working on his own rom (we have AOKP, CM9, Ubuntu, ...) everyone should team up and make a good Jelly Bean rom.
Just out of curiosity, how is this rom's performance?
The Following 4 Users Say Thank You to Mavamaarten For This Useful Post: [ Click to Expand ]
 
::Blocks::
Old
#6  
Junior Member
Thanks Meter 1
Posts: 17
Join Date: May 2012
Cool thing! Can you post some photos pls?!
Thanks!!
 
Quinny899
Old
#7  
Quinny899's Avatar
Recognized Contributor
Thanks Meter 3825
Posts: 6,213
Join Date: Jan 2011
Location: Bolton le Sands, Near Lancaster, UK

 
DONATE TO ME
I've been trying to get this to boot today, I'm using the multiboot initramfs and your zImage, but I'm stuck at a black screen. Should I be using the latest stock one?

---------- Post added at 11:19 AM ---------- Previous post was at 11:09 AM ----------

Stock 4.0.7 initramfs is stuck at ARCHOS splash screen, not looping (as in there being no ext4 file) but just stuck

 
Devices:
Nexus 5
Galaxy Nexus
Nexus 7 FHD
Archos 80 G9
LG GT540
 
cajl
Old
#8  
cajl's Avatar
Senior Member
Thanks Meter 167
Posts: 838
Join Date: May 2008
Location: near PARIS (94)

 
DONATE TO ME
have you the initramfs.cpio.lzo ?
The old man of Archos
All Archos from JUKEBOX 6000 to GEN XX
see that
http://www.jbmm.fr/2010/10/23/ma-folie-archosienne/
THANKS for your THANKS
 
Quinny899
Old
#9  
Quinny899's Avatar
Recognized Contributor
Thanks Meter 3825
Posts: 6,213
Join Date: Jan 2011
Location: Bolton le Sands, Near Lancaster, UK

 
DONATE TO ME
Quote:
Originally Posted by cajl View Post
have you the initramfs.cpio.lzo ?
Don't worry, it works now. A combination of bad files and silly mistakes were the issue

Sent from my ARCHOS 80G9 using Tapatalk 2

 
Devices:
Nexus 5
Galaxy Nexus
Nexus 7 FHD
Archos 80 G9
LG GT540
 
cajl
Old
(Last edited by cajl; 28th August 2012 at 04:15 PM.)
#10  
cajl's Avatar
Senior Member
Thanks Meter 167
Posts: 838
Join Date: May 2008
Location: near PARIS (94)

 
DONATE TO ME
i use the initramfs.cpio.lzo of surdru

when i lauch the SDE, i view the CM9 animation

How long does the animation the first time ?

I use the official SDE not the multiboot
The old man of Archos
All Archos from JUKEBOX 6000 to GEN XX
see that
http://www.jbmm.fr/2010/10/23/ma-folie-archosienne/
THANKS for your THANKS

Tags
archos g9, jelly bean
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes