Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,311 Members 48,420 Now Online
XDA Developers Android and Mobile Development Forum

[HowTo] Disable home button screen wake

Tip us?
 
arctic84
Old
(Last edited by arctic84; 19th August 2012 at 09:52 AM.) Reason: just an update
#1  
arctic84's Avatar
Senior Member - OP
Thanks Meter 70
Posts: 203
Join Date: Jan 2008
Lightbulb [HowTo] Disable home button screen wake

*** I AM NOT TAKING ANY CREDIT FOR THIS, I JUST HAPPENED TO GOOGLE IT AND FOUND IT USEFUL AND WANT TO SHARE***
I found it on another forum posted by a guy name ERIC.

**Update (8/19)** THIS MOD SHOULD WORK FOR ALL ROMS! I did it both on AOKP and stock. Gonna look into what else can be edited and post results

If you're having trouble with your phone waking due to the home button, this is the mod for you.
I work in a restaurant and i keep finding that my phone gets quite warm in my pocket because
the screen comes on (it also likes taking screen shots, and sometimes even opens the camera).

Hope this is helpful for you guys.



HERE WE GO!

ONLY MODIFY THE FILE SPECIFIED!
OR PLAY AROUND AT YOUR OWN RISK AS NOTHING OTHER THAN MENTIONED FILE IS TESTED....

  1. open root explorer
  2. navigate to : system/usr/keylayout
  3. now press the mount r/w button near the top of screen to enable read and write permissions
  4. scroll down to: sec_keys.kl
  5. press and hold until menu pops up, select: Open in Text Editor
  6. locate line: key 172 HOME WAKE
  7. tap behind the word WAKE and delete it so you see: key 172 HOME
  8. press menu and select: Save and Exit
  9. now press the button at the top of the screen to disable read and write permissions: Mount R/O
  10. (once pressed should now read : Mount R/W again.
  11. Exit root explorer
  12. Reboot your phone

WALA, no more warm pocket and random screenshots
Please hit the THANKS button if you like what I'm sharing!

(╯□)╯︵ ┻━┻
LG G2 Resurrection Remix

LG G2 - Samsung GNote 2- HTC Sensation - Mytouch 3G slide - Samsung Galaxy S III - HTC ONE - Samsung Galaxy Nexus (I9250) - Samsung Galaxy s2 (Hercules) - T-mobile G2x - HTC HD2 - Titan 2 - Touch Diamond 2 - T-mobile Dash
The Following 33 Users Say Thank You to arctic84 For This Useful Post: [ Click to Expand ]
 
thiagomme
Old
#2  
Senior Member
Thanks Meter 33
Posts: 155
Join Date: Sep 2008
How about to add screen off in addition to screen wake while in the lockscreen? Thank you.

Sent from my SGH-T999 using Tapatalk 2
 
DroidRC1
Old
#3  
DroidRC1's Avatar
Senior Member
Thanks Meter 227
Posts: 969
Join Date: May 2009
Location: Fort Wayne, Indiana
Thx! Its worked I've never liked that option...

Sent from my SGH-T999 using xda premium
TWITTER: @DROIDRC1
 
darren.wlsn1
Old
#4  
darren.wlsn1's Avatar
Senior Member
Thanks Meter 849
Posts: 2,532
Join Date: Jul 2008
Location: Hershey PA
thanx given, always bugged me.
 
mormoney
Old
(Last edited by mormoney; 17th August 2012 at 02:51 AM.)
#5  
mormoney's Avatar
Member
Thanks Meter 16
Posts: 83
Join Date: May 2012
Thx man. Appreciate the share.



Sent from my SGH-T999 using Tapatalk 2
The Following User Says Thank You to mormoney For This Useful Post: [ Click to Expand ]
 
jason4962
Old
(Last edited by jason4962; 17th August 2012 at 04:26 AM.)
#6  
Senior Member
Thanks Meter 136
Posts: 833
Join Date: Dec 2011
Location: NEW JERSEY
Thanks for this. By the way does anyone know how to volume button wake?

Edit.

Search the file and found 115 114 for volume wake in there but it.does.not work

Sent from my SGH-T999 using xda app-developers app
 
philliman
Old
#7  
philliman's Avatar
Senior Member
Thanks Meter 195
Posts: 968
Join Date: Nov 2007
Location: Philly
The mod worked great, but I miss using the home button to unlock. My Otterbox Defender case prevents the pocket push so I un did it lol. Thx for the find!

Sent from my SGH-T999 using Tapatalk 2
__________________
T-Mobile Galaxy S4
Rooted
4.3 Fully Functional Knox Free
 
AdhiTj
Old
#8  
AdhiTj's Avatar
Member
Thanks Meter 10
Posts: 61
Join Date: Sep 2012
I don't found it,,
 
as_usual150
Old
#9  
Member
Thanks Meter 4
Posts: 48
Join Date: Dec 2007
I am using Jelly Bean rom right now and I missed the home button just turns on screen. I think in JB whenever I Push home button it directly goes to home. I mean if you gave a break when reading something when You push home button the app you working on is not active anymore but it goes to home instead. Do you guys have a fix for that?
 
rtwhtever
Old
(Last edited by rtwhtever; 9th October 2012 at 10:17 PM.)
#10  
Member
Thanks Meter 5
Posts: 43
Join Date: Oct 2007
Quote:
Originally Posted by thiagomme View Post
How about to add screen off in addition to screen wake while in the lockscreen? Thank you.

Sent from my SGH-T999 using Tapatalk 2
I'd like to have that too. I had it on my previous phone and liked it.

Edit: Interesting, this is the contents of my whole file, and yet only the home and power buttons do wake up the phone.
key 115 VOLUME_UP WAKE
key 114 VOLUME_DOWN WAKE
key 172 HOME WAKE
key 116 POWER WAKE

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


[APK] Google News and Weather Gets Material Design Makeover, Minor Maps Updates

Although Google has somewhat gotten out of the habit of their … more

Software Build Automation with Jenkins – XDA Developer TV

Many members of the XDA community come to learn and begin in the exciting … more

Add Bits and Pieces of Honami to Your Current ROM

In the last few months, we’ve talked about quite a few Sony Honami-related projects. … more

Always Enter the Correct Password with HideNoPasswords

If you’ve ever entered apassword on your mobile device, you’ve surely … more