Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Galaxy S Relay 4G Development Thread

OP Joe333x

23rd February 2013, 06:41 PM   |  #1061  
HippoMan's Avatar
Senior Member
Thanks Meter: 76
 
428 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by TheDigitalBug

Try flashing the ma2 radio that was posted earlier and check if you still can't make calls.

Yep. That was the problem, after all. Not the SIM.
Thanks.
It's fixed now.
.
23rd February 2013, 09:49 PM   |  #1062  
Junior Member
Thanks Meter: 4
 
10 posts
Join Date:Joined: Aug 2009
More
Question Does the Relay support USB Host Mode?
Does anyone know if the non-stock ROMs support USB host mode? I'm running 100% stock (haven't rooted or anything), got a S3 USB OTG cable, and have tried it with both a usb card reader and a Fiio E7 USB amp/dac with USB Audio Recorder Pro app, with no luck .
23rd February 2013, 11:05 PM   |  #1063  
dillalade's Avatar
Senior Member
Flag Richmond
Thanks Meter: 194
 
1,054 posts
Join Date:Joined: Sep 2009
Re: Galaxy S Relay 4G Development Thread
Can anyone share there experience with MHL with cm10.1

I tried but gave no output and eventually force rebooted the phone.

Cheers
Well done again teamApexQ.
Props :thumbup:

Sent from my SGH-T699 using xda app-developers app
24th February 2013, 01:44 AM   |  #1064  
Jax184's Avatar
Senior Member
Flag Vancouver
Thanks Meter: 158
 
284 posts
Join Date:Joined: Nov 2007
More
Quote:
Originally Posted by COZ'N'EFX

Does anyone know if the non-stock ROMs support USB host mode? I'm running 100% stock (haven't rooted or anything), got a S3 USB OTG cable, and have tried it with both a usb card reader and a Fiio E7 USB amp/dac with USB Audio Recorder Pro app, with no luck .

No idea, but our Qualcomm MSM8260A supports it. So in theory it should be there if the software is set up right.
24th February 2013, 06:32 PM   |  #1065  
Member
Thanks Meter: 14
 
88 posts
Join Date:Joined: Jun 2008
I was actually looking for this very solution. I picked up a cheap OTG cable and no joy either. Running stock rooted.

-Erik
25th February 2013, 01:52 AM   |  #1066  
HippoMan's Avatar
Senior Member
Thanks Meter: 76
 
428 posts
Join Date:Joined: May 2009
Issues/questions about nardholio's CM 10.1 rom
I've been using nardholio's excellent CM10.1 rom for a while, and I'm quite happy with it. It works plenty well enough for me to keep using it on my device.

However, there are a few relatively minor issues and questions that have come up for me which I want to discuss ...

1. When using this rom, I notice that WiFi sometimes turns on automatically if I am out of range of a cell signal. This occurs even though I always explicitly set WiFi to "Off". I can't reliably reproduce this yet. It seems to occur maybe 25 percent of the time that I lose the cell signal but am in range of a WiFi hotspot that I have used before. I'm not sure about the following, but it also seems that sometimes, the device boots up with WiFi on, even though I'm almost positive that I explicitly turned it off before restart. Are these behaviors bugs or features? If it's the latter, does anyone know how set WiFi so that it always stays irrevocably turned off until I explicitly turn it on?

2. In the rooted MA2 rom that I was previously using, I got WiFi tethering to work by installing nardholio's Relay_tetheringfix_MA2.zip. However, with the CM10.1 rom, WiFi tethering doesn't work, as described later in this paragraph. I can't get WiFi tethering to work with PdaNet+FoxFi, either. If I install Relay_tetheringfix_MA2.zip over the CM10.1 rom, my device never boots: it hangs forever at the CyanogenMod boot animation. The WiFi-not-working symptom in CM10.1 is this: when turning on WiFi tethering, the access point comes up and it shows up in the connecting machine's WiFi access point list. However, when selecting this tethered access point, I get a "Connecting..." message for maybe 10-15 seconds, but then the connection drops and the connection process repeats in a seemingly infinite loop. This takes place even though I've double- and triple-checked that the password is correct. Perhaps a proper IP address is not being generated, or something ... I don't understand the internal mechanics of WiFi enough to know for sure. Has anyone gotten WiFi tethering to work under this CM10.1 rom?

3. I notice that in CM10.1, many apps are now listing their default storage location to be /storage/emulated/0. I assume that this is the same as /mnt/sdcard. Is there any way to tell my system to set the default storage location to /mnt/extSdCard (presumably /storage/sdcard1 or something similar)?

Thanks in advance for any insights you might be able to offer concerning these questions/issues.
.
Last edited by HippoMan; 25th February 2013 at 02:11 AM.
25th February 2013, 03:54 AM   |  #1067  
gee one's Avatar
Senior Member
Flag linux command line
Thanks Meter: 569
 
1,568 posts
Join Date:Joined: Jul 2010
More
Re: Galaxy S Relay 4G Development Thread
Regarding #2, the tethering fix is for the stock rom and replaces framework-res.apk. It will not work with cm10 or 9 because they use a different framework.

sent while running with scissors
The Following User Says Thank You to gee one For This Useful Post: [ View ]
25th February 2013, 05:26 PM   |  #1068  
Nocturin's Avatar
Senior Member
Thanks Meter: 62
 
180 posts
Join Date:Joined: Oct 2012
Sigh... only 22hrs before 8%. Oh battery life, whatever happened too you? The yellow dip was the phone laying on the table in my living room not being used.

Anyone know of an application I'd be able to use to monitor which one's are requesting data access?

Last edited by Nocturin; 25th February 2013 at 05:28 PM.
25th February 2013, 11:10 PM   |  #1069  
HippoMan's Avatar
Senior Member
Thanks Meter: 76
 
428 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by gee one

Regarding #2, the tethering fix is for the stock rom and replaces framework-res.apk. It will not work with cm10 or 9 because they use a different framework.

Thank you.

So ... has anyone managed to get WiFi tethering working with this 10.1 rom? As I mentioned, it fails consistently with PdaNet+FoxFi as well as with the default WiFi tethering utility.
.
25th February 2013, 11:40 PM   |  #1070  
gtmaster303's Avatar
Senior Member
Thanks Meter: 407
 
1,450 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Re: Galaxy S Relay 4G Development Thread
Quote:
Originally Posted by Nocturin

Sigh... only 22hrs before 8%. Oh battery life, whatever happened too you? The yellow dip was the phone laying on the table in my living room not being used.

Anyone know of an application I'd be able to use to monitor which one's are requesting data access?

"Only" 22 hours huh? That's a pipe dream compared to other phones

Sent from my SGH-I927 using Tapatalk 2
Last edited by gtmaster303; 25th February 2013 at 11:43 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes