Post Reply

Fixing Logcat / Catlog on Jelly Beans [JB] ROMS

OP rtk217

22nd August 2012, 05:28 PM   |  #1  
OP Member
Thanks Meter: 57
 
66 posts
Join Date:Joined: Dec 2011
More
so as you may noticed catlog /logcat/ alogcat and such are not working properly or at all.
that is because google added a new permission request from apps which they don't usually request.

but alas, there is fix, if you're working with one of the latest versions of JB (quarx or epsylon3 it doesn't matter) you can fix it by simply by following the next steps:
1. make sure your'e phone is rooted and has superuser or any other permission manager app (superuser zip flashable can be downloaded here)

2. enter the app drawer and enter the "terminal emulator"

3. gain root permissions by typing :
$su

wait for the notification about permission allow/deny, and allow it.

4. now you give permission to the program you want by writing the following line:
pm grant [programs name] android.permission.READ_LOGS

(the upper case /lower case is important)

I.E for catlog you should type:
Code:
su
pm grant com.nolanlawson.logcat android.permission.READ_LOGS

now your logging app should work fine, enjoy!
Last edited by rtk217; 18th September 2012 at 03:18 PM.
The Following 29 Users Say Thank You to rtk217 For This Useful Post: [ View ]
22nd August 2012, 09:18 PM   |  #2  
Redhotero's Avatar
Member
Thanks Meter: 7
 
58 posts
Join Date:Joined: Apr 2012
Thanks! ill try it, i need logcat a lot
24th August 2012, 01:54 PM   |  #3  
ksrao_iete's Avatar
Member
Thanks Meter: 29
 
94 posts
Join Date:Joined: Nov 2011
Great It works for me im on JB Quarx 22Aug12
24th August 2012, 03:58 PM   |  #4  
OP Member
Thanks Meter: 57
 
66 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by ksrao_iete

Great It works for me im on JB Quarx 22Aug12

Good. if i helped please press the thank you button.
also moderators if you can see this, you'd might want to add this to the wiki or something.
Last edited by rtk217; 24th August 2012 at 06:51 PM.
The Following 2 Users Say Thank You to rtk217 For This Useful Post: [ View ]
13th September 2012, 02:23 AM   |  #5  
Senior Member
Thanks Meter: 29
 
452 posts
Join Date:Joined: Jun 2010
Works on CM10 for S3.
13th September 2012, 02:36 AM   |  #6  
Senior Member
Thanks Meter: 539
 
2,500 posts
Join Date:Joined: Oct 2010
More
Hrm.

Sent from my SCH-I535 using Tapatalk 2
The Following User Says Thank You to neyenlives For This Useful Post: [ View ]
18th September 2012, 05:24 PM   |  #7  
Junior Member
Thanks Meter: 3
 
3 posts
Join Date:Joined: Mar 2011
It worked! Thanks a lot. For alogcat it's
Code:
su
pm grant org.jtb.alogcat android.permission.READ_LOGS
Last edited by alienhead13; 18th September 2012 at 05:36 PM.
The Following 3 Users Say Thank You to alienhead13 For This Useful Post: [ View ]
18th September 2012, 11:42 PM   |  #8  
shag_on_e's Avatar
Senior Member
Thanks Meter: 187
 
663 posts
Join Date:Joined: Sep 2011
More
Here's a way to make all log reader apps work instead of going one by one:

su: "chmod 04755 /system/bin/logcat"

or open root explorer, navigate /system/bin/logcat, long press logcat and select "permissions", then check the box "Set UID".

Both ways require a reboot after!


Hope this helps, thanks to ChainsDD for this!
The Following 6 Users Say Thank You to shag_on_e For This Useful Post: [ View ]
19th September 2012, 01:08 AM   |  #9  
MrBC's Avatar
Senior Member
Flag Lisburn
Thanks Meter: 151
 
508 posts
Join Date:Joined: Nov 2011
More
Working on LC's Ice Cold Jelly on the One X.

Thanks so much for this

Sent from my HTC One X using xda premium
19th September 2012, 01:21 AM   |  #10  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2012
Thumbs up
Thanks, really thanks.

I use aLogcat and the code that I used was
Code:
pm grant org.jtb.alogcat android.permission.READ_LOGS
You can find your logger program accessing with any root explorer the folder "data>data" and look for the name of the folder that contains the name of your app within. I looked for it because I'm not using the same app that you used, so I opened the "Root Explorer>Search" and searched for "logcat". So I found the folder "Data>data" and tried using the name of the folder that was "org.jtb.alogcat" and worked.

Thanks very much, nice job.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes