FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

Fixing Logcat / Catlog on Jelly Beans [JB] ROMS

66 posts
Thanks Meter: 57
 
By rtk217, Member on 22nd August 2012, 05:28 PM
Post Reply Subscribe to Thread Email Thread
so as you may noticed catlog /logcat/ alogcat and such are not working properly or at all.
that is because google added a new permission request from apps which they don't usually request.

but alas, there is fix, if you're working with one of the latest versions of JB (quarx or epsylon3 it doesn't matter) you can fix it by simply by following the next steps:
1. make sure your'e phone is rooted and has superuser or any other permission manager app (superuser zip flashable can be downloaded here)

2. enter the app drawer and enter the "terminal emulator"

3. gain root permissions by typing :
$su

wait for the notification about permission allow/deny, and allow it.

4. now you give permission to the program you want by writing the following line:
pm grant [programs name] android.permission.READ_LOGS

(the upper case /lower case is important)

I.E for catlog you should type:
Code:
su
pm grant com.nolanlawson.logcat android.permission.READ_LOGS

now your logging app should work fine, enjoy!
Last edited by rtk217; 18th September 2012 at 03:18 PM.
The Following 29 Users Say Thank You to rtk217 For This Useful Post: [ View ]
 
 
22nd August 2012, 09:18 PM |#2  
Redhotero's Avatar
Member
Thanks Meter: 8
 
More
Thanks! ill try it, i need logcat a lot
24th August 2012, 01:54 PM |#3  
Senior Member
Thanks Meter: 35
 
More
Great It works for me im on JB Quarx 22Aug12
24th August 2012, 03:58 PM |#4  
OP Member
Thanks Meter: 57
 
More
Quote:
Originally Posted by ksrao_iete

Great It works for me im on JB Quarx 22Aug12

Good. if i helped please press the thank you button.
also moderators if you can see this, you'd might want to add this to the wiki or something.
Last edited by rtk217; 24th August 2012 at 06:51 PM.
The Following 2 Users Say Thank You to rtk217 For This Useful Post: [ View ]
13th September 2012, 02:23 AM |#5  
Senior Member
Thanks Meter: 46
 
More
Works on CM10 for S3.
13th September 2012, 02:36 AM |#6  
Senior Member
Thanks Meter: 738
 
More
Hrm.

Sent from my SCH-I535 using Tapatalk 2
The Following User Says Thank You to neyenlives For This Useful Post: [ View ]
18th September 2012, 05:24 PM |#7  
Junior Member
Thanks Meter: 3
 
More
It worked! Thanks a lot. For alogcat it's
Code:
su
pm grant org.jtb.alogcat android.permission.READ_LOGS
Last edited by alienhead13; 18th September 2012 at 05:36 PM.
The Following 3 Users Say Thank You to alienhead13 For This Useful Post: [ View ]
18th September 2012, 11:42 PM |#8  
shag_on_e's Avatar
Senior Member
Thanks Meter: 193
 
More
Here's a way to make all log reader apps work instead of going one by one:

su: "chmod 04755 /system/bin/logcat"

or open root explorer, navigate /system/bin/logcat, long press logcat and select "permissions", then check the box "Set UID".

Both ways require a reboot after!


Hope this helps, thanks to ChainsDD for this!
The Following 6 Users Say Thank You to shag_on_e For This Useful Post: [ View ]
19th September 2012, 01:08 AM |#9  
MrBC's Avatar
Senior Member
Flag Lisburn
Thanks Meter: 151
 
More
Working on LC's Ice Cold Jelly on the One X.

Thanks so much for this

Sent from my HTC One X using xda premium
19th September 2012, 01:21 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
Thanks, really thanks.

I use aLogcat and the code that I used was
Code:
pm grant org.jtb.alogcat android.permission.READ_LOGS
You can find your logger program accessing with any root explorer the folder "data>data" and look for the name of the folder that contains the name of your app within. I looked for it because I'm not using the same app that you used, so I opened the "Root Explorer>Search" and searched for "logcat". So I found the folder "Data>data" and tried using the name of the folder that was "org.jtb.alogcat" and worked.

Thanks very much, nice job.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes