Post Reply

[DEV/WIP] MIUI V4.1 Jellybean for GT P7510

OP GazaIan

25th August 2012, 12:38 AM   |  #1  
GazaIan's Avatar
OP Senior Member
Flag Your basement
Thanks Meter: 414
 
1,530 posts
Join Date:Joined: Dec 2010
Donate to Me
More
It's been a long time since I've even tried to port a ROM. Android surely has changed a lot and now I get to meet new errors that I have never seen and have no idea to get past.

Mainly posting this because I only actually have an hour or less every day to work on this, and if I couldn't get it working quickly enough then I'd just leave it up to the community. Used MapleSyrup's AOSP 4.1.1 ROM and Galaxy Nexus's MIUI.US ROM. Whoever can fix this error will win 100 internetz, and maybe a small donation if it's fully booting/working. As I said I really have little time to work on this.
The error;

Code:
W/Zygote  (  105): Class not found for preloading: android.media.AudioManager$2
E/JNIHelp (  105): Native registration unable to find class 'android/media/videoeditor/VideoEditorProfile', aborting
F/libc    (  105): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 105 (zygote)
MIUI boots to the bootanimation. The animation doesn't loop but the system is looping at that. Want to try an fix it? Here ya go;

By clicking the download link, you fully acknowledge that this ROM is still under development, and not all, if any, features may be available to the user. You also acknowledge that you are fully accountable for any damages, explosions, sword fights, or other unexpected activity that may occur to your device.

http://goo.gl/4zzzl

Btw I see no rules as to whether non-fully-booting ROMs can be placed here so if not... Oops.
Last edited by GazaIan; 25th August 2012 at 12:41 AM.
The Following 2 Users Say Thank You to GazaIan For This Useful Post: [ View ]
1st September 2012, 08:07 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2008
More
Quote:
Originally Posted by GazaIan

Code:
W/Zygote  (  105): Class not found for preloading: android.media.AudioManager$2
E/JNIHelp (  105): Native registration unable to find class 'android/media/videoeditor/VideoEditorProfile', aborting
F/libc    (  105): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 105 (zygote)

Wild assed guess, here... but it looks like you are missing JNI library. I can't post a link, but I found the following in the source code for com.android.media.videoeditor.VideoEditorProfile.j ava.You'll notice a promising bit in the constructor...

Code:
static {
         System.loadLibrary("media_jni");
         native_init();
}
You might want to see if your ROM has that lib available.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy Tab 10.1 Android Development by ThreadRank