Post Reply

Rooting Sony Xperia S - The Missing File

OP arielhezi

21st September 2012, 03:57 PM   |  #1  
arielhezi's Avatar
OP Junior Member
Flag Tel-Aviv TLV
Thanks Meter: 22
 
5 posts
Join Date:Joined: Apr 2010
Donate to Me
More
Well I tried to use Bin4ry thread and his script to root my device but no luck

http://forum.xda-developers.com/show....php?t=1886460

since it's asking u ..on the very first step to open Sony's app - backup and restore -which is unlike found there when u install clean custom rom.

So - I'm not saying his way isn't good -it's just furstrating that i coudlnt find this app anyway on web so went back to original room rooted -
also with other thread - http://forum.xda-developers.com/show....php?t=1742992 - Thanks to Sharaz22
and extrackted the file for you all -to have better ,faster and easier way to root with Bin4ry post.

thanks to him and all others that helps up on this great website-
i wanted to add this file as a comment on his thread -but the website think i'm dumb enough to even commnet.
so I hope - Bin4ry if u see it -plz add it to your thread.

So there it is for u.. ( u can send it to your mobile by using bluetooth\gmail\usb cable-gmail would be to easiest way for noobies i think to find it and install it through there..)

I'll soon to be posting here noobies guide for easy rooting your Xperia S in 30min - if u would want that.
i'm gratefull to xda developers i think it's about time that i'll share from all i've learned during all this years.
Attached Files
File Type: apk sony ics backup_and_restore.apk - [Click for QR Code] (670.0 KB, 21571 views)
The Following 22 Users Say Thank You to arielhezi For This Useful Post: [ View ]
2nd October 2012, 12:02 PM   |  #2  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2012
no luck here unfortunately.
Here's the message I get whenever I click to run the app on my Tipo Dual:
Unfortunately, Backup & restore has stopped.

I'm sure others have had better luck rooting their phones.
2nd October 2012, 07:53 PM   |  #3  
Member
Flag La Habana
Thanks Meter: 1
 
38 posts
Join Date:Joined: Mar 2010
hey any chance that if i install this app in a Galaxy S III it works???
3rd October 2012, 02:08 PM   |  #4  
Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Oct 2012
Shucks Im stuck as well!, anyone had any luck?
4th October 2012, 10:37 AM   |  #5  
Member
Thanks Meter: 7
 
44 posts
Join Date:Joined: May 2011
try this file in sony because the file you uploaded is not work with me
Attached Files
File Type: apk Backup-Restore ICS.apk - [Click for QR Code] (683.8 KB, 6501 views)
Last edited by mhammadleo; 4th October 2012 at 10:44 AM. Reason: forget to attachments
The Following 4 Users Say Thank You to mhammadleo For This Useful Post: [ View ]
4th October 2012, 10:53 AM   |  #6  
Ben36's Avatar
Senior Member
Thanks Meter: 1,715
 
6,133 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by lqtdc

hey any chance that if i install this app in a Galaxy S III it works???

Doesn't the S3 already have a non Sony backup and restore app?

Sent from my LT26i using Tapatalk 2
12th October 2012, 02:39 PM   |  #7  
louis0815's Avatar
Senior Member
Thanks Meter: 78
 
218 posts
Join Date:Joined: May 2009
More
Quote:
Originally Posted by s.davis

Unfortunately, Backup & restore has stopped.

Same on my LT15i - seems there's something missing. Both versions of the APK give the same result, it just doesn't work.
12th October 2012, 02:55 PM   |  #8  
DrSt01eR's Avatar
Junior Member
Thanks Meter: 0
 
27 posts
Join Date:Joined: Apr 2011
i had no issues
i had no issues on using this app after running the programme i had a back up and restore file in my xps that was not their before told me to run the root file did it all works perfect i used the normal mode in the run me file from bin4ry... option 1 i think..... even for a locked bootloader it worked as after doing my own xps that has unlocked bootloader i did same steps on my gfs xps and she has a locked/b/l worked first time no worries
12th October 2012, 09:23 PM   |  #9  
louis0815's Avatar
Senior Member
Thanks Meter: 78
 
218 posts
Join Date:Joined: May 2009
More
on the Xperia S I had no issues as well - but the S has backup&restore on board. The Xperia arc doesn't have a backup&restore app in the ICS upgrade - and apparently there's a reason why (copying the respective apk from the LT26 doesn't work either)
14th October 2012, 02:52 PM   |  #10  
Junior Member
Thanks Meter: 2
 
7 posts
Join Date:Joined: Oct 2012
I have Xperia U st25i running GB I've tried this method and it didn't work

The Following User Says Thank You to abo_mariam For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes