An Android Enthusiast’s Apple iPhone 6 Challenge – XDA TV

The media has gone batty again over Apple “revolutionizing” … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more
Post Reply

[HOW TO and why] Change fonts in Windows Phone 7.8

21st September 2012, 11:58 PM   |  #1  
Budniu's Avatar
OP Senior Member
Flag Warsaw
Thanks Meter: 299
 
1,072 posts
Join Date:Joined: Sep 2008
More
If anybody have problem with wrong displaying the fonts in ROMs (I had after installing the Polish language into the WP 7.8) you need to know that the fonts in leaked 7.8 ROMs is wrongs. See below.
This is for Polish preview and Polish description (two on the top are from the Windows Phone 7.8 and two at the bottom are downloaded from the XDA Thread this post).


If you want to display them properly we need to copy the downloaded fonts to the Windows folder on the device overwriting the old ones and spftreset device. Fonts, whose we need call:
SegoeWP.ttf
SegoeWP-Black.ttf
SegoeWP-Bold.ttf
SegoeWP-Light.ttf
SegoeWP-Semibold.ttf
SegoeWP-Semilight.ttf
(below: left - before, right - after)
Last edited by Budniu; 22nd September 2012 at 12:07 AM.
The Following 4 Users Say Thank You to Budniu For This Useful Post: [ View ]
22nd September 2012, 03:23 PM   |  #2  
jessenic's Avatar
Senior Member
Thanks Meter: 280
 
445 posts
Join Date:Joined: Sep 2010
Donate to Me
More
WARNING: Do NOT replace the SegoeWP fonts with random fonts downloaded from the net, will most likely break everything :P But if you did do that and file browser apps still do work and you find out you can't delete the custom fonts because they're in use, just rename them to something else then reboot. That should work.
22nd September 2012, 03:40 PM   |  #3  
Budniu's Avatar
OP Senior Member
Flag Warsaw
Thanks Meter: 299
 
1,072 posts
Join Date:Joined: Sep 2008
More
Hmm but I wrote about replace to original fonts - I checked the first and it's works.
23rd September 2012, 02:16 PM   |  #4  
Dinchy87's Avatar
Senior Member
Flag Živinice
Thanks Meter: 46
 
318 posts
Join Date:Joined: Aug 2011
Donate to Me
More
yeah cool, but how can i drop the files in the folder if wp device manager dont work few days ago it worked but now it won't start at all... any chance to pack this to a xap and install to a folder via provxml?
23rd September 2012, 02:58 PM   |  #5  
Budniu's Avatar
OP Senior Member
Flag Warsaw
Thanks Meter: 299
 
1,072 posts
Join Date:Joined: Sep 2008
More
I using RootWebserver: http://forum.xda-developers.com/show....php?t=1459235 to copy files to the device and File browser: http://depositfiles.com/files/schkgx8mh to copy files to Windows folder.
23rd September 2012, 09:26 PM   |  #6  
Dinchy87's Avatar
Senior Member
Flag Živinice
Thanks Meter: 46
 
318 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by Budniu

I using RootWebserver: http://forum.xda-developers.com/show....php?t=1459235 to copy files to the device and File browser: http://depositfiles.com/files/schkgx8mh to copy files to Windows folder.

i managed to copy them via wp device manager now, but the bug is still there... why?
Last edited by Dinchy87; 23rd September 2012 at 10:47 PM.
23rd September 2012, 10:33 PM   |  #7  
Budniu's Avatar
OP Senior Member
Flag Warsaw
Thanks Meter: 299
 
1,072 posts
Join Date:Joined: Sep 2008
More
File browser - only install xap file on device
WebRootServer:
1. install on device
2. turn on wifi (the same router with your PC)
3. launch app on device - in first and second lines you see login and pass - entering yours (anything)
4. below you see three lines with IP adresses (for you is last)
5. IP from third line entering in address bar in your web browser on PC
6. you see in window (on PC) login and pass - entering the same (point 3)
7. in window (on PC) you see few lines with tekst - for you "File system" - open it.
8. Tada - you see your phone in catalogs structure
The Following User Says Thank You to Budniu For This Useful Post: [ View ]
23rd September 2012, 11:15 PM   |  #8  
Dinchy87's Avatar
Senior Member
Flag Živinice
Thanks Meter: 46
 
318 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by Budniu

File browser - only install xap file on device
WebRootServer:
1. install on device
2. turn on wifi (the same router with your PC)
3. launch app on device - in first and second lines you see login and pass - entering yours (anything)
4. below you see three lines with IP adresses (for you is last)
5. IP from third line entering in address bar in your web browser on PC
6. you see in window (on PC) login and pass - entering the same (point 3)
7. in window (on PC) you see few lines with tekst - for you "File system" - open it.
8. Tada - you see your phone in catalogs structure


that is cool. wireless access i have copied now the 6 fonts but i think the seguisym.ttf is also corupt. if you write a sms and type in the letter "J" and after it some other letter it displays it "J a" instead of "Ja" if you open the font on your pc you will see it. is there a substitute font for that because on my wp 7.5 i dont had this problems... i feel like this font is lighter then it should be. if you type in a URL in IE on wp7.8 the font is to thin i think. it is thicker on wp7.5. i found a substitute for this font and it is thicker and like 7.5 it is called the same, and is it digitally signed and only the numbers are a little bit "not" segoe but the rest of the font is like it should be on 7.5

here is the link to the seguisym font http://www.2shared.com/file/OJy1qz_t/seguisym.html

if somebody has the orginal 7.5 from mango or tango i think it would be even better. but this fixes all other bugs. the bug was in email where you edit your email setting, and the name of the email service was to thin, now it is ok. the bug was also on tiping an sms, in IE on the URL tiping and on other places in the system.

forget the link above if you have an original 7.5 rom, dump it and find the hidden folder where the stock segoe fonts are. all fonts in this folder are correct now.
Last edited by Dinchy87; 24th September 2012 at 01:01 AM.
24th September 2012, 09:09 AM   |  #9  
Budniu's Avatar
OP Senior Member
Flag Warsaw
Thanks Meter: 299
 
1,072 posts
Join Date:Joined: Sep 2008
More
.... and thank you Budniu
The Following User Says Thank You to Budniu For This Useful Post: [ View ]
8th October 2012, 11:55 PM   |  #10  
Senior Member
Thanks Meter: 9
 
463 posts
Join Date:Joined: Oct 2008
When I try to copy the fonts, if I cut > paste I can see that only some of the fonts are copied to the fonts folder. The following fonts will not copy, presumably because they are in use? I've tried the local File Explorer and Touch Xplorer.

SergoeWP.ttf
SergoeWP-Black.ttf
SergoeWP-Bold.ttf
SergoeWP-Light.ttf
SergoeWPSemibold.ttf
SergoeWPSemilight.ttf

When I type the text is all patchy. Has anyone any other suggestions? I'm running the Omnia 7.8 ROM from here.

Thanks

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes