Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLVED] Japanese font / glyph on Jelly Bean (Nexus 7)

OP Trynium

23rd September 2012, 05:51 PM   |  #1  
OP Junior Member
Flag Kawasaki City
Thanks Meter: 4
 
16 posts
Join Date:Joined: Sep 2008
Hi !

Android 4.1 has a better glyph support for Japanese users (renders Japanese-specific versions of glyphs WHEN system language is set to Japanese).
I use a lot Japanese (reading / writing) and what see when system language is NOT set to Japanese is the Chinese glyphs characters instead of Japanese ones. Often those are the same as the Japanese glyph but in some cases they are not.
But if I set the system language to Japanese the glyphs are the good ones. So, it's not so convenient to set system language to Japanese every time I need to read or write in Japanese !

Quote:

It looks to be done with a fallback fonts list that gets switched with the UI locale. Inside of /system/etc/ there are two XML files: fallback_fonts and fallback_fonts-ja. In the ja one the order of MTLmr3m.ttf font is placed before DroidSansFallback.ttf. The MTLmr3m.ttf file is the Motoya Japanese font and the DroidSansFallback.ttf is the fallback font that has the simplified Chinese glyphs.

The fix to allow Japanese instead of Simplified Chinese with a non-Japanese UI would be to copy the fallback_fonts-ja file to fallback_fonts. Before doing that it would be a good idea to copy fallback_fonts to something else like fallback_fonts.backup so that you could restore it later. However, before doing any of this you would also need to root your device since the /system directory can't be edited otherwise.

This is what I found (here => http://forum.koohii.com/viewtopic.ph...181580#p181580 ) and what I done.
I even tried to edit the fallback_fonts file to put MTLmr3m.ttf font before DroidSansFallback.ttf. But in any case, once I reboot my Nexus 7, the Japanese font are not read anymore (juste leaving blank).

Does anyone have a solution to use the MTLmr3m.ttf file (Japanese font) instead of DroidSansFallback.ttf without setting the system language to Japanese ?

Thank you !
Last edited by Trynium; 23rd September 2012 at 09:27 PM.
23rd September 2012, 08:18 PM   |  #2  
Ultramanoid's Avatar
Senior Member
Flag 日本国
Thanks Meter: 1,209
 
1,189 posts
Join Date:Joined: Apr 2011
I use Android in English but also need full Japanese support, to read and type. To achieve that, I replace Android's ( rather poor ) DroidSansJapanese.ttf with IPAPGothic and doing so I get a good proper font. Easy, just renaming IPAPGothic as DroidSansJapanese.ttf and putting it in :

/system/fonts/DroidSansJapanese.ttf

Then to avoid Android using the font DroidSansFallback.ttf, I replace as you mention the following file defining fonts with my own :

/system/etc/fallback_fonts.xml

I don't touch anything else and it works for me on 4.1 and 4.1.1. Android uses IPAPGothic for Japanese in my devices and DroidSansFallback.ttf for other languages needing glyphs. I also replace DroidSansFallback.ttf with a better font that supports full Traditional Chinese and Korean, by the way.

Here's the fallback_fonts.xml file I use in case you want to check it or use it directly. ( If so, rename .txt to .xml and also remember to make sure permissions for the files you put in system/ are rw-r--r-- )

Hope it helps.

Edit : this is a bit of a hack to preserve naming from Android 2.2 and 2.3 ( DroidSansJapanese.ttf as it is called in those versions ) and don't erase the MTLmr3m.ttf font in Android 4 in case I need it for anything or Google changes something later on, but again, it works for me, so maybe worth a try.
Attached Files
File Type: txt fallback_fonts.txt - [Click for QR Code] (2.7 KB, 964 views)
Last edited by Ultramanoid; 23rd September 2012 at 08:25 PM.
The Following 4 Users Say Thank You to Ultramanoid For This Useful Post: [ View ]
23rd September 2012, 09:23 PM   |  #3  
OP Junior Member
Flag Kawasaki City
Thanks Meter: 4
 
16 posts
Join Date:Joined: Sep 2008
When I took a look at your fallback_fonts.xml, I saw that you put the DroidSansJapanese.ttf at the top of the "list".
And when I tried the solution I explained in my first post, I put it just before DroidSansFallback.ttf at the end of the list.

So I thought I could try to put MTLmr3m.ttf at the top and let DroidSansFallback.ttf at the end of the list. (yes, I wanted to use MTLmr3m.ttf, because it was done for Japanese people... so it's sound good for me^^).

A reboot later and the right Japanese font / glyph (not the Chinese one) was used by the system in every apps !!

Thank you Ultramanoid, you really helped me !
Last edited by Trynium; 23rd September 2012 at 09:30 PM.
The Following 4 Users Say Thank You to Trynium For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
4.1, font, japanese, jelly bean, nexus 7
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes