Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,569 Members 44,206 Now Online
XDA Developers Android and Mobile Development Forum

[MOD][AOSP/CM10]Bluetooth Phone Audio Fix - Patch with Source

Tip us?
 
buffal0b1ll
Old
#21  
buffal0b1ll's Avatar
Senior Member
Thanks Meter 178
Posts: 465
Join Date: Sep 2012
Location: Baltimore
Quote:
Originally Posted by krarvind View Post
Ok. BT phone audio finally seems to be fixed. I have done some testing on i717 using my jabra BT earpiece and my car built in BT audio system. Seems to work flawlessly. Moose0704 tested it on Liquid/C&C as well. So here is patch, flash in recovery. Here is the source for it, its more than the CM10's patch as that was the same fix i put in yesterday and didn't work on my car built in BT. Test and leave your feedback here.

NOTE: Only for AOSP/CM10 based roms. Flash at your own RISK. Don't blame me if something goes wrong. This patch has been tested by a few and has worked for all. If the patch doesn't work, get your rom devs/compilers to compile with the patch put in.
Link to patch is broken.
 
thznutz87
Old
#22  
thznutz87's Avatar
Senior Member
Thanks Meter 91
Posts: 382
Join Date: Feb 2011
Mirror anyone?.

Sent from my SPH-L710 using Tapatalk 2
 
joedoe
Old
#23  
joedoe's Avatar
Senior Member
Thanks Meter 45
Posts: 630
Join Date: Mar 2005
It's already fixed in the source tree ages ago!

KK 4.4.2 SlimKat latest

KK 4.4.2 Omni nightly

KK 4.4.2 Omni nightly
 
buffal0b1ll
Old
#24  
buffal0b1ll's Avatar
Senior Member
Thanks Meter 178
Posts: 465
Join Date: Sep 2012
Location: Baltimore
Saw that it was added to source, but 3 devices i have running cm10 have BT issues and i wanted to give this patch a try if anyone's got it.

Sent from my Xoom using Tapatalk 2
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

Current Devices: d800, grouper, wingray
Retired Device: d2vzw
 
tryo0004
Old
#25  
Member
Thanks Meter 5
Posts: 33
Join Date: Aug 2011
Quote:
Originally Posted by buffal0b1ll View Post
Saw that it was added to source, but 3 devices i have running cm10 have BT issues and i wanted to give this patch a try if anyone's got it.

Sent from my Xoom using Tapatalk 2
Would love to see a mirror.. I want to try this on a CM10 build that I'm running on my Incredible 2, which is not playing nicely with my Audi bluetooth system. Many thanks in advance if anyone has a mirror.
 
006fazer
Old
#26  
Senior Member
Thanks Meter 26
Posts: 226
Join Date: May 2006
Hi,

Same problem for me with my Galaxy nexus on CM10.1

Seem the patch is not include into CM10.1 sources....
 
tryo0004
Old
#27  
Member
Thanks Meter 5
Posts: 33
Join Date: Aug 2011
Quote:
Originally Posted by 006fazer View Post
Hi,

Same problem for me with my Galaxy nexus on CM10.1

Seem the patch is not include into CM10.1 sources....
huh! ironically, my incredible 2 broke so i bought a galaxy nexus. i'm running jb 4.2.1 build of AOKP with no bt problems at all. haven't tried the vanilla cm10.1, but will see if i have any bluetooth issues with the current build.
 
Woody
Old
#28  
Woody's Avatar
Moderator & RC/RT Committees - Particle Physics Gives me a Hadron
Thanks Meter 8773
Posts: 6,632
Join Date: Nov 2010
Location: Immersed in Dark Matter
Seems that this is no longer an issue for the Note I.

@ 006fazer and tryo0004, please take you discussion to your respective devices.

As per requested, this thread is now a stale development and closed.
<a href=http://www.whiskey103.nl/x/sigs/Woody6_15fps.gif target=_blank rel=nofollow >http://www.whiskey103.nl/x/sigs/Woody6_15fps.gif</a>
ZFFZ

I GPL I

"The work of men of genius, however wrongly directed, hardly ever fails to open the eyes of men to new possibilities."
- Dr. Victor Frankenstein (Mary Shelley)

THREAD CLOSED
Subscribe
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes