HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

How to Root the kindle Fire 2

18 posts
Thanks Meter: 46
By Dassen, Junior Member on 6th October 2012, 01:57 AM
Post Reply Subscribe to Thread Email Thread
Alright, so I've seen alot of posts asking about a root for the kindle fire 2
We've had multiple members use this method and it seems to work absolutley fine.

Follow the steps in this thread to gain root,

I was able to gain root while running ver 10.1.3 and I've seen many other members also able to do the same.

To use a launcher download the apk of the launcher you want to use, after installing move the apk file to your "app" folder found in the "system" file and change permissions for that apk to user - rw ; group - r ; other - r. Once those steps are done simply reboot your kindle and a prompt will appear asking which launcher to use.

Credits to the respective thread starters and to bodi524 for sharing the info with me.
[ list of recommended launchers ]
-Go launcher ( EX or HD )
-chameleon launcher
-lightning launcher
-nova launcher

there are a ton more to check out, just look around.
Last edited by Dassen; 8th October 2012 at 06:19 AM. Reason: Additonal info; Original thread closed.
The Following User Says Thank You to Dassen For This Useful Post: [ View ]
6th October 2012, 04:02 AM |#2  
chrisliphart's Avatar
Senior Member
Flag Atlanta, GA
Thanks Meter: 112
Originally Posted by Dassen

Alright, so I've seen alot of posts asking about a root for the kindle fire 2
We've had multiple members use this method and it seems to work absolutley fine.

Fopllow the steps in this thread to gain root,

I was able to gain root while running ver 10.1.3 and I've seen many other members also able to do the same.

Huh. I can't get the .bat to recognize the device, despite installing the drivers and enabling ADB on the Kindle. However, when I do install the drivers, the installer looks like they install properly, yet I get a dialog that says "Drivers not installed successfully. Install manually." Or something to that effect. Thoughts?
6th October 2012, 07:01 AM |#3  
OP Junior Member
Flag Nanuet
Thanks Meter: 46
Got the same error , I just tried re installing the drivers a couple of times and it worked, I actually got an error message while installing the drivers once that read drivers installed unsuccessfully then tried to run the bat for the luls and that's when the root worked. xD

I dont really know what the deal is with the drivers but it seems like they arent that important... try re-installing them a couple times see if that helps.
Last edited by Dassen; 6th October 2012 at 04:41 PM.
10th October 2012, 07:22 PM |#4  
Junior Member
Thanks Meter: 0
Spent too much time on it. Reverted back by the end!!
17th October 2012, 08:10 AM |#5  
Junior Member
Thanks Meter: 0
Unhappy Help Me Please. I root KindleFire 2 gen
i root my Kindle Fire (2nd Generation) Software Version 10.1.3 by How to root tool Qemu

but i can't copy file .apk to folder /system/app and program Root Explorer show detail /dev/block/platform/omap/omap_hsmmc.1/by-name/System (r/o) and don't have Remount as R/W button

help me please.
24th November 2012, 04:58 AM |#6  
Senior Member
Flag Milton
Thanks Meter: 8
Can any one give a more detailed guide on how to move the .apk and change the settings to get it to work??

Would be greatly appreciated thanks!

Sent from my KF2 using xda app-developers app
24th November 2012, 09:37 PM |#7  
Thanks Meter: 17
Now that's ****ing great.

I tried rooting it a couple times without success. It always came down to the 5073 port error and after too many restarts it is increadibly slow plus the kindle fire logo is flickering on the screen every few seconds...


OK after painfully managing to finally get to the "reset factory settings" it is working again. But I think this root method might not be working for me with Version 10.2.1
Last edited by 433Mhz; 24th November 2012 at 09:42 PM.
24th November 2012, 09:51 PM |#8  
Junior Member
Thanks Meter: 0
Root Kindle Fire 2 v10.2.1
Hi, I tried using [ROOT][TOOL]Qemu automated root [09/18/2012] Got the drivers installed succesfully and then ran the bat file but does not seem to work. My kindle fire 2 version is v10.2.1 anyone had success with this one yet?

Never mind I tried with a Samsung USB cable and it worked.
Last edited by m1416; 24th November 2012 at 10:23 PM.
25th November 2012, 01:34 AM |#9  
Senior Member
Flag Milton
Thanks Meter: 8
I have mine rooted on 10.2.1 and running go luncher ex

Sent from my KF2 using xda app-developers app
25th November 2012, 09:54 AM |#10  
Thanks Meter: 17
Is it possible, that Windows 8 64bit might be an issue? Installing the drivers was only possible after renaming the signed drivers by deleting the "signed_" part. the bat installer only recognizes the device after repluging it a couple times. Then I get a cmd line saying "root or "shell" but putting in the stuff from the video doesn't work.
27th November 2012, 01:07 PM |#11  
wmccombs's Avatar
Junior Member
Flag Pittsburgh
Thanks Meter: 4
Rooted Kindle Fire 2 fine....but
The root process went perfectly clean and it rebooted fine. Then I couldn't find instructions to install the Play Store. I finally found some that said to copy GoogleServicesFramework.apk to the Kindle and install, I did that cleanly. Then to copy vending.apk to /system/app/ and I did that and was able to change permissions to 664. I then rebooted the Kindle. It goes straight to the triangle. If you push the power button 5 times it reboots to the same thing. I did not try to flash TWRP to it because I saw some having problems with it. I have 10.2.1 on it. I have the proper drivers installed and each time the Kindle rebooted during boot the computer beeped that it recognized it. Since the triangle the PC no longer recognizes it, it does not show up in Device manager and it does not show up in explorer as connected. I think it is hard bricked but wanted to run it by everyone.

Sparkym3's root process went flawlessly on my Fire2, It only took a couple minutes to root and be booted to a working Kindle. I just screwed up the market process somehow.

Let me know your thoughts. Being that everything went so clean with rooting I have a hard time thinking it can be the drivers, cable, usb port.
I've rooted a phone and 2 tablets multiple times but never had this happen. Any help is greatly appreciated.

This is an exact description of the problem:
I get the Kindle Fire logo, sits there several seconds, reboots and the power light goes out and back on, then the logo comes up again, it flashes a couple of times then I get an orange triangle with an exclamation point inside Below that is a message stating "Your Kindle device cannot boot".
Below that is You can reset device to Factory defaults to fix this issue (all data will be deleted from the device"
<Menu options>
To reboot your device, press and hold the power button for 4 seconds and release.
To reset to Factory Defaults, press the power button 5 times in succession.

Well the 4 second thing does not work at all, more like 20 seconds. The pressing 5 times just reboots to the same problem and warning triangle. I tried fastboot commands but nothing.and my laptop no longer recognizes the Kindle and nothing is in Device Manager about the Kindle now. The fastboot command just says waiting for device. As I said above the root process went flawlessly and the Fire reboot 3-4 times and the laptop beeped each time that it saw it.

Any help is greatly appreciated

So, I'm totally lost. Maybe a frisbee at this point.
Last edited by wmccombs; 28th November 2012 at 02:17 AM. Reason: Better and full explanation

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes