Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM][OFFICIAL] CyanogenMod 10 (JellyBean) Nightly Builds for SGH-T769

OP dr4stic

6th October 2012, 05:28 AM   |  #1  
OP Senior Member
Thanks Meter: 732
 
380 posts
Join Date:Joined: Oct 2009
Donate to Me
CyanogenMod 10 is a free, community built distribution of Android 4.1 (Jelly Bean) which greatly extends the capabilities of your phone.

Code:
#include <std_disclaimer.h>
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */
This phone isn't my daily driver, so I only tested a few things, and only slightly:

Known Bugs:
  • Screen of Death: This is a CM10 bug, many other devices are afflicted, not just the blaze. Many people are working hard to fix this.
  • UI action sounds may not work at first. Adjust the volume with the volume buttons, the sounds will then work fine. This is a known CM10 bug
  • BLN is wonky. Working on getting us merged with the stable version native to CM10.
  • Fixed 20121103+ : WiFi generates a random MAC address with each boot.
  • Camera: Flash can't be disabled
  • Camera: Storage location cannot be changed. This isn't really a bug, however if the interest is great enough, I might try and figure out a way to change the system default storage location.
  • Other things maybe? Discuss in the thread...

How to get it:
Download: http://get.cm/?device=t769 (ChangeLog)
Or download it directly through ROM Manager or CM Updater.

Google Apps:
Make sure to download and install the JellyBean GApps
http://goo.im/gapps/gapps-jb-20121011-signed.zip


PLEASE MAKE SURE TO DO A FACTORY/DATA RESET BEFORE USING THIS. This isn't up for debate. A reset of the dalvik cache helps too. If you do a dirty flash, please make sure to do a dalvik cache wipe. If you have searched this forum for a problem and haven't found it, please do a nandroid backup, then a full factory/data reset and check to see if you still have the problem. If it still persists AFTER the factory/data reset, then report it here.


Thank You!
CyanogenMod Team (all of you, seriously, you guys are awesome)
SGH-T989 Devs (all of you, cuz I basically stole all your configs)
ShabbyPenguin & PlayfulGod for encouraging me when times looked grim.
UberPinguin and others on #jb-dev-e4gt for helping me get all of this work into CM proper
Oreo, my dog, for licking me whenever I needed it.


Older Versions (don't use if you can help it).
For older/legacy/test/unofficial versions of my work, you can find them (for a while at least) here: My Funhouse. Please take care and all necessary steps to verify MD5 sums before installing any zips.
Last edited by dr4stic; 5th November 2012 at 05:27 PM. Reason: updating to latest gapps
The Following 78 Users Say Thank You to dr4stic For This Useful Post: [ View ]
6th October 2012, 05:32 AM   |  #2  
Bulletblitz27's Avatar
Senior Member
NYC
Thanks Meter: 73
 
377 posts
Join Date:Joined: May 2012
Yay! I love you people! Lol

Sent from my SAMSUNG-SGH-T769 using xda premium
6th October 2012, 05:36 AM   |  #3  
Senior Member
Thanks Meter: 26
 
192 posts
Join Date:Joined: May 2011
This is just awesome....i can't believe my eyes!!
6th October 2012, 05:45 AM   |  #4  
Bulletblitz27's Avatar
Senior Member
NYC
Thanks Meter: 73
 
377 posts
Join Date:Joined: May 2012
Is the buttons the only issue? I wouldn't mind testing it out :P

Sent from my SAMSUNG-SGH-T769 using xda premium
6th October 2012, 05:49 AM   |  #5  
OP Senior Member
Thanks Meter: 732
 
380 posts
Join Date:Joined: Oct 2009
Donate to Me
Quote:
Originally Posted by Bulletblitz27

Is the buttons the only issue? I wouldn't mind testing it out :P

Sent from my SAMSUNG-SGH-T769 using xda premium

The buttons is a fairly big issue... Figuring out how to get back home is troublesome to say the least. Plus, my zip doesn't have the right drivers baked in... I may re-package and include a link to a zip to enable the soft keys (like on a galaxy nexus), just to get some navigation....

I can't really test calls since this isn't my regular phone. I know the external speaker works because I get sound effects... lemme see about re-packaging. Maybe I'll upload something more tonight.

Otherwise, the front and rear cams work, the rotation is proper.. there are things in the log cat about the compass not working, I'll figure that out soon enough...
The Following 2 Users Say Thank You to dr4stic For This Useful Post: [ View ]
6th October 2012, 05:52 AM   |  #6  
Bulletblitz27's Avatar
Senior Member
NYC
Thanks Meter: 73
 
377 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by dr4stic

The buttons is a fairly big issue... Figuring out how to get back home is troublesome to say the least. Plus, my zip doesn't have the right drivers baked in... I may re-package and include a link to a zip to enable the soft keys (like on a galaxy nexus), just to get some navigation....

I can't really test calls since this isn't my regular phone. I know the external speaker works because I get sound effects... lemme see about re-packaging. Maybe I'll upload something more tonight.

Otherwise, the front and rear cams work, the rotation is proper.. there are things in the log cat about the compass not working, I'll figure that out soon enough...

Sounds good! I'm willing to wait till it's more stable like everyone else, so no rush

Sent from my SAMSUNG-SGH-T769 using xda premium
6th October 2012, 06:20 AM   |  #7  
Senior Member
Flag Gladewater, TX
Thanks Meter: 192
 
532 posts
Join Date:Joined: Apr 2011
Donate to Me
Did you try to update touch key fw?
*#*#2663#*#* on the dial pad and press update touch key fw button on bottom.
Last edited by j3r3goss; 6th October 2012 at 06:22 AM.
The Following User Says Thank You to j3r3goss For This Useful Post: [ View ]
6th October 2012, 07:29 AM   |  #8  
tmack23's Avatar
Member
Thanks Meter: 5
 
50 posts
Join Date:Joined: Jul 2009
I can't believe we have got all this in one day. I never thought this phone would get attention. I used to develop roms for the g1 pm me if you guys want some help.
The Following 2 Users Say Thank You to tmack23 For This Useful Post: [ View ]
6th October 2012, 03:31 PM   |  #9  
Senior Member
Baltimore
Thanks Meter: 192
 
350 posts
Join Date:Joined: Jun 2012
More
in gingerbread settings.db helped me bring back the soft buttons working in some of the ports maybe we can use ics settings.db to replace this?
6th October 2012, 04:20 PM   |  #10  
OP Senior Member
Thanks Meter: 732
 
380 posts
Join Date:Joined: Oct 2009
Donate to Me
Quote:
Originally Posted by theprogram1

in gingerbread settings.db helped me bring back the soft buttons working in some of the ports maybe we can use ics settings.db to replace this?

No... I'm fairly sure I borked the driver.

Part of the thing I did was to actually forward port the T769 (and I577, need to let those guys know...) changes from the Samsung source releases into the CM kernel proper.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes