5,606,588 Members 35,106 Now Online
XDA Developers Android and Mobile Development Forum

[Bandaid Fix] Boot looping due to power button

Tip us?
 
evilmika
Old
#1  
Junior Member - OP
Thanks Meter 11
Posts: 18
Join Date: Jan 2009
Default [Bandaid Fix] Boot looping due to power button

First and foremost, you attempt this at your own risk and I am not responsible for what happens to your device. This saved me from buying a new phone when I had an unidentifiable and persistent black screen/boot loop

Symptoms you are boot looping due to your power button sticking:
1. Black screen with intermittent vibrating
2. Phone restarts during boot animation
3. Unable to enter recovery before phone restarts
4. Unable to enter download mode before restart
5. USB JIG forces phone into download mode and restart occurs
6. Phone turns on when battery is inserted

This fix will only work if the button is STUCK and not defective. Remove back cover and battery. Remove the 6 screws on the back of the phone and gently pry the housing off.



http://www.ifixit.com/Guide/Disassem...)+Phone/8179/1

After that, find the power button. Using a small flat head screwdriver gently push the button cover away from the mechanical button and try to press the mechanical button in to see if you can still feel it "click". After that, reassembled and test. Hope it works for you too.
The Following 10 Users Say Thank You to evilmika For This Useful Post: [ Click to Expand ]
 
Mr_creeper_98
Old
#2  
Mr_creeper_98's Avatar
Senior Member
Thanks Meter 7
Posts: 106
Join Date: Sep 2009
Location: H-Town
Hey buddy, I want to thank you for your guide.
I followed it every step, but unfortunately I was not able to fix my phone.
It still loops every time I press on the power button.
It might be a hardware failure.

Not sure what else to do.
Help!!!!
 
superlantern
Old
#3  
Senior Member
Thanks Meter 11
Posts: 299
Join Date: Jun 2010
If this didn't work, get the button replaced. I got mine fixed by mobiletechvideos for 35 plus shipping
The Following User Says Thank You to superlantern For This Useful Post: [ Click to Expand ]
 
andych888
Old
#4  
Junior Member
Thanks Meter 0
Posts: 16
Join Date: Jan 2011
save this for furture use thanks
 
XeoNoX
Old
#5  
XeoNoX's Avatar
Senior Member
Thanks Meter 208
Posts: 576
Join Date: Oct 2010
my buttons were sticking ( power button and volume down ) to on my phone , it got to the point where the power button was no longer working and my phone was out of warranty. I just decided to take phone apart and disassemble it and then i located the power button and used some " CRC QD Electronic Cleaner " and just sprayed it (using the straw that CRC comes with) directly into the power button (when i say "spray" i mean i pushed the spray button for about 1 second). After spraying it i pressed the button like 20 times, then i sprayed some more and while spraying (spray for 1 second) i was pushing the button about another 20-30 times. I repeated the spray and push cycle about 10 times (which means i probably pressed the power button over 300 times ), I waited about 5 mins to make sure it was "dry" and then i put the battery back in and test it and It seemed to have cleaned it out and now my power button worked. Then i put everything back together.

Note: I tried to spray and press it with the phone with the enclosure/case/body on but the button cover blocks the actual button and i was forced to actually disassemble the case, its not to hard just looks intimidating. whole process took me about 45 mins first time.

Note 2: CRC QD Electronic Cleaner can also be found at most local auto parts stores BE SURE TO GET THAT BRAND as it is non-conductive, i repeat GET THAT EXACT BRAND/MODEL Cleaner, cheaper brands might be conductive despite it saying it is safe or does not dry as fast and who knows what might happen, CRC is a known well brand and has a good rep)

original thread there http://forum.xda-developers.com/show...php?p=20910029

...Hey where did that "thanks" button go!!...



keywords: power volume up down rocker button push stuck stick sticky unstick clogged jam jammed dirty dirt auto automatically
The Following 11 Users Say Thank You to XeoNoX For This Useful Post: [ Click to Expand ]
 
Colombia81er
Old
#6  
Colombia81er's Avatar
Senior Member
Thanks Meter 23
Posts: 439
Join Date: Feb 2010
Location: Pereira, Colombia
my boys phone did that... I just started to bang the power button with a eraser !! that did the trick
The Following 3 Users Say Thank You to Colombia81er For This Useful Post: [ Click to Expand ]
 
jrbeato
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2012
Quote:
Originally Posted by Colombia81er View Post
my boys phone did that... I just started to bang the power button with a eraser !! that did the trick

this trick was the one that worked!
 
Wareazy
Old
#8  
Wareazy's Avatar
Senior Member
Thanks Meter 11
Posts: 153
Join Date: Nov 2011
Location: NYC
so after giggling and wiggling ... spraying and pushing ... (none of which worked)
I went back to the Nintendo standby .. blow at the port ... go figure ... i guess something got stuck in the USB port kept making my phone reboot lol

Thanks for the help all!!!!
If my post sounds like a noob ... its only because I am one. AND PROUD OF IT!
 
ipeench
Old
#9  
ipeench's Avatar
Senior Member
Thanks Meter 34
Posts: 452
Join Date: Jun 2010
Location: Chicago
Ugh..any other suggestions?? I can't believer they are considering this ISER damage! This is my third one. First one had powerbutton issue, replacement had a screen issue where it look like water was on the screen... Two months later is one has power button issue.. This is some bs.

Phone: Galaxy S4 (SHG-M919)
Current Rom: stock
=============
Phone: Nook Color
Current Rom: CM10betas
=============
R.I.P
G1,G2 ,Galaxy s2, Vibrant, Razr Maxx
=============
I fell off the face off the programing world.
=============

Don't be scared to ask questions, sometimes its the only way to learn.
BUT ALWAYS SEARCH FIRST!
 
sllxxiii
Old
#10  
Junior Member
Thanks Meter 5
Posts: 23
Join Date: Nov 2012
Location: NYC
OMG!! You just saved my phone (and my wallet!!) Thank You so much!!

Tags
boot loop, fix, power button
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes