Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,779,301 Members 50,195 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Android SDK manager not starting on Windows 8

Tip us?
 
kevdliu
Old
#1  
kevdliu's Avatar
Recognized Developer - OP
Thanks Meter 1459
Posts: 1,055
Join Date: Apr 2011

 
DONATE TO ME
Default [Q] Android SDK manager not starting on Windows 8

Hello,

I can't get Android SDK manager to run on Windows 8 x64. Every time I run the executable a command prompt window flashes briefly and then nothing happens. I have tried installing both 32 and 64 bit version of JDK 1.6 and running SDK manager with admin permissions and in compatibility mode.

Any help would be appreciated


If you like my work please Donate to me. Thanks

My Projects / Applications:
Picture Password Lockscreen for Android
Status Bar Volume Panel Plus for ICS+ devices
TaskUI Tasks Control Overlay for HC+ devices
 
Theonew
Old
#2  
Theonew's Avatar
Recognized Contributor
Thanks Meter 1055
Posts: 3,530
Join Date: Dec 2010
Location: Wherever I am
Quote:
Originally Posted by kevdliu View Post
Hello,

I can't get Android SDK manager to run on Windows 8 x64. Every time I run the executable a command prompt window flashes briefly and then nothing happens. I have tried installing both 32 and 64 bit version of JDK 1.6 and running SDK manager with admin permissions and in compatibility mode.

Any help would be appreciated
It runs fine for me on Windows 8 Pro x64. The command propt window does flash, but the manager comes up soon after. I have JDK 1.7 though.
The Following 3 Users Say Thank You to Theonew For This Useful Post: [ Click to Expand ]
 
kevdliu
Old
#3  
kevdliu's Avatar
Recognized Developer - OP
Thanks Meter 1459
Posts: 1,055
Join Date: Apr 2011

 
DONATE TO ME
Quote:
Originally Posted by Theonew View Post
It runs fine for me on Windows 8 Pro x64. The command propt window does flash, but the manager comes up soon after. I have JDK 1.7 though.
Thanks so much for the info I tried again with JDK 1.7 and it works now


If you like my work please Donate to me. Thanks

My Projects / Applications:
Picture Password Lockscreen for Android
Status Bar Volume Panel Plus for ICS+ devices
TaskUI Tasks Control Overlay for HC+ devices
The Following 2 Users Say Thank You to kevdliu For This Useful Post: [ Click to Expand ]
 
NikolayBar
Old
#4  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Nov 2012
Quote:
Originally Posted by kevdliu View Post
Hello,

I can't get Android SDK manager to run on Windows 8 x64. Every time I run the executable a command prompt window flashes briefly and then nothing happens. I have tried installing both 32 and 64 bit version of JDK 1.6 and running SDK manager with admin permissions and in compatibility mode.

Any help would be appreciated

The same was in Windows7 64-bit for some SDK version (dont remember version number).
It was solved by switching off some windows security checking. May be this is not best solution, but works.
 
o0rebelious0o
Old
#5  
Member
Thanks Meter 18
Posts: 72
Join Date: Nov 2010
Location: London
Thumbs up Got a fix

I was having this problem too. It's caused by the PATH variables to java.exe being set incorrectly. You can modify the environment to have java_exe pointing to wherever it is C:\Windows\System32\java.exe for me or modify android.bat in tools to change set java_exe= call lib\find_java.bat if not defined java_exe goto :EOF
to this: set java_exe="D:\Program Files\Java\jdk1.7.0_07\bin\java.exe" where the path is the path to your java exe
you can then run android.bat and it works. The reason (re)installing java works is because it adds the path variables for you. They must have gotten changed/moved when I upgraded to windows 8
The Following 4 Users Say Thank You to o0rebelious0o For This Useful Post: [ Click to Expand ]
 
9xnine
Old
(Last edited by 9xnine; 27th January 2013 at 04:19 AM.)
#6  
Senior Member
Thanks Meter 31
Posts: 182
Join Date: Aug 2010
Location: Bellingham, WA
I'm having the same issue. Installed JDK 1.7 but still the same issue.

I have a fresh Install of W8 and am just now trying to install JDK and SDK.
.
 
thetheory
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2013
Default I also cannot launch SDK Manager

Quote:
Originally Posted by o0rebelious0o View Post
I was having this problem too. It's caused by the PATH variables to java.exe being set incorrectly. You can modify the environment to have java_exe pointing to wherever it is C:\Windows\System32\java.exe for me or modify android.bat in tools to change set java_exe= call lib\find_java.bat if not defined java_exe goto :EOF
to this: set java_exe="D:\Program Files\Java\jdk1.7.0_07\bin\java.exe" where the path is the path to your java exe
you can then run android.bat and it works. The reason (re)installing java works is because it adds the path variables for you. They must have gotten changed/moved when I upgraded to windows 8
I am having the identical problem. I try to launch SDK Manager and get a quick cmd flash and then nothing. I am on Win8 Pro with jdk 1.7.0_21.
I added c:\Windows\System32\java.exe to the path (correct on my system) but no obvious change in result. Then edited set java_exe in android.bat to "C:\Program Files\Java\jdk1.7.0_21\bin\java.exe" and ran the batch file, and still I just get a quick flash of the command window. My java sdk was just installed today prior to setting up the ADT Bundle for Windows. Eclipse loads with ADT, but the SDK Manager is still a no go. Thanks in advance for any ideas.
 
mrtoots
Old
#8  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Aug 2011
Default Solved my Windows 8 problem

Hi,

I have been having similar problems with Android SDK manager not starting in Windows 8. Tried altering Java paths and messing with Android.bat etc. etc. but am now convinced the problem is with the UAC of Windows 8. Why?

1) Originally installed Eclipse in a sub dir of Program Files and found that I could not edit any sub dir there (like Android.bat) because of User Access Controls (UAC)... got me thinking...

2) So re-installed Eclipse in a sub dir under my user, and bingo... SDK manager works fine now.

It is possible to disable all UAC in Win 8 Pro using secpol.msc, but I don't have Pro version and it's not in bog standard version... However, you can still edit the registry to give all apps admin privileges but seems a bit drastic to have to do this...
 
aleks3008
Old
#9  
Junior Member
Thanks Meter 3
Posts: 11
Join Date: Dec 2009
http://developer.android.com/sdk/installing/bundle.html

Install the SDK and Eclipse IDE
1.Unpack the ZIP file (named adt-bundle-<os_platform>.zip) and save it to an appropriate location, such as a "Development" directory in your home directory.

try c:\Development\
The Following 2 Users Say Thank You to aleks3008 For This Useful Post: [ Click to Expand ]
 
WandererTJ
Old
#10  
Member
Thanks Meter 3
Posts: 47
Join Date: Dec 2010
Location: Oklahoma
Quote:
Originally Posted by aleks3008 View Post
http://developer.android.com/sdk/installing/bundle.html

Install the SDK and Eclipse IDE
1.Unpack the ZIP file (named adt-bundle-<os_platform>.zip) and save it to an appropriate location, such as a "Development" directory in your home directory.

try c:\Development\
This is what worked for me. Thanks!!!
I originally had it in User\Documents\
Current Phone:
Samsung Galaxy S III SGH-I747 (Red)
Build Number: JRO03L.I747UCDLK3 (v4.1.1); Kernel version: 3.0.31-274808
Rooted

Original Android:
Samsung Captivate SGH-I897; Build Model: 1010
Build Number: FROYO.UCKB1; Kernel version: 2.6.32.9
Rooted: SuperOneClickv1.7-ShortFuse
Flashed: Froyo, From Leaked to Official 2.2 (link to my thread)
- Tethering/Hotspot Enabled, Bloat Removed, 3e Recovery fixed, No Notification Bar mods...yet
Home Replacement App: GO Launcher EX

Tags
android, manager, sdk, windows 8
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes