5,606,588 Members 35,557 Now Online
XDA Developers Android and Mobile Development Forum

HTC One X stuck in airplane mode and no imei.....

Tip us?
 
bakert12
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2012
Default HTC One X stuck in airplane mode and no imei.....

My friend gave his one x to fix it for him. The problem is that the phone is stuck in airplane mode but in status bar it doesnt show an airplane.... It shows empty signal bar with an x as if theres no service......and when i try turn it off it says it stucks at turning off , leave it for hours and it will still be the same..... I tried rebooting the phone, factory reset, installed custom rom, RUU and i did all kinds of wipe and format in cwm and still the same. I have searched a lot about this i found some people with the same situation but i didnt find any solution installing other roms and kernels does not fix the problem...... I want to know if this is a hardware issue or software issue which i think it is..... And if theres a solution for it.....

Thank You.

Sent from my HTC One S using xda app-developers app
 
atrako1973
Old
#2  
atrako1973's Avatar
Senior Member
Thanks Meter 398
Posts: 1,272
Join Date: Feb 2010
Location: dublin
Try to push power button for 6 seconds
 
doc_j
Old
#3  
doc_j's Avatar
Junior Member
Thanks Meter 2
Posts: 13
Join Date: May 2012
Location: Sofia
I got the same problem, after flashing hboot 1.31 for JB Custom ROM. Now my phone can't turn on wifi and airplane mode always stays on "turning off". No way to go back to hboot 1.12 or 1.28 reflashing 1.31 two and three times and same situation. Tried 2 different custom roms different kernels... Done some google search and forum search. Any solution?
 
s1977
Old
#4  
Senior Member
Thanks Meter 32
Posts: 227
Join Date: Feb 2009
Location: Liverpuuuuuuuuuul :)
Quote:
Originally Posted by bakert12 View Post
My friend gave his one x to fix it for him. The problem is that the phone is stuck in airplane mode but in status bar it doesnt show an airplane.... It shows empty signal bar with an x as if theres no service......and when i try turn it off it says it stucks at turning off , leave it for hours and it will still be the same..... I tried rebooting the phone, factory reset, installed custom rom, RUU and i did all kinds of wipe and format in cwm and still the same. I have searched a lot about this i found some people with the same situation but i didnt find any solution installing other roms and kernels does not fix the problem...... I want to know if this is a hardware issue or software issue which i think it is..... And if theres a solution for it.....

Thank You.

Sent from my HTC One S using xda app-developers app
Switch the power off and hold the power and volume down button for a few seconds until the soft touch keys (bottom three) flash a few times. I had this once and couldn't get it to work until i simulated a 'battery pull', which the above action imitates.

Hope it fixes this issue.
 
doc_j
Old
#5  
doc_j's Avatar
Junior Member
Thanks Meter 2
Posts: 13
Join Date: May 2012
Location: Sofia
Quote:
Originally Posted by s1977 View Post
Switch the power off and hold the power and volume down button for a few seconds until the soft touch keys (bottom three) flash a few times. I had this once and couldn't get it to work until i simulated a 'battery pull', which the above action imitates.

Hope it fixes this issue.
No, it doesn't help. If reboot helped it'd be stupid treat, but it's not. I can't send my phone for warranty repair, because hboot 1.31, even it's relocked. If I wait for RUU that matches the hboot and CID HTC_032 may be it will solve my problem or at least my warranty will not be void.
 
bakert12
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2012
Doc_j is right rebooting doesnt help..... But my situation is a little diferrent i did not install any hboot . The phone was untouched when it got stuck in airplane mode.... Everything was stock i tried factory reset b4 changing anything but it didnt work. Doc_j did u try a stock kernel ? Or RUU ? Anyway if u find a solution plz let me know.... GL

Sent from my HTC One S using xda app-developers app
 
dragonesdenano
Old
#7  
dragonesdenano's Avatar
Senior Member
Thanks Meter 9769
Posts: 8,904
Join Date: Jan 2011
Location: Lanus, Buenos Aires

 
DONATE TO ME
Smell trolls,
New accounts, ota day, nothing new

SkyDragon Sense, Dsensed, SeMistock & Stock Roms. Next Targe ~ ~ ~ > JB
 
pastynko
Old
#8  
Senior Member
Thanks Meter 17
Posts: 151
Join Date: Dec 2009
Location: Bratislava
Never heard about this on HTC... Samsung got these problems - there it is related to corrupted EFS folder.

Sent from my HTC One X using xda premium
Galaxy S3
The Following User Says Thank You to pastynko For This Useful Post: [ Click to Expand ]
 
doc_j
Old
#9  
doc_j's Avatar
Junior Member
Thanks Meter 2
Posts: 13
Join Date: May 2012
Location: Sofia
Solved! My problem was the boot.img I flashed boot.img for ARHD 13 before and that was the reason. So after flashing boot.img for 15.0 all is OK.

Sent from my EndeavorU using xda app-developers app

---------- Post added at 07:18 PM ---------- Previous post was at 07:14 PM ----------

Bakert12, try flashing hboot 1.31, unlock your bootloader, flash clockworkmod recovery, install previously downloaded and copyed to the SD card Android revolution HD 15.0 zip file from the recovery and finally flash boot.img for ARHD15.0 via fastboot. I think you have my problem, no matter how it happend

Sent from my EndeavorU using xda app-developers app
The Following 2 Users Say Thank You to doc_j For This Useful Post: [ Click to Expand ]
 
bakert12
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2012
Ok thanks ill try that later....

Sent from my HTC One S using xda app-developers app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes