Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,027 Members 47,770 Now Online
XDA Developers Android and Mobile Development Forum

KFHD System.img Recovery Tool

Tip us?
 
timnan
Old
(Last edited by timnan; 6th December 2012 at 10:55 PM.)
#11  
Member
Thanks Meter 7
Posts: 76
Join Date: Aug 2008
Is this one version 8.1.2 or 8.1.3?
Need a rootable.
 
onemeila
Old
#12  
onemeila's Avatar
Senior Member - OP
Thanks Meter 237
Posts: 296
Join Date: Jan 2012
Location: Winchester

 
DONATE TO ME
Quote:
Originally Posted by timnan View Post
Is this one version 8.1.2 or 8.1.3?
Need a rootable.
The backup was done right out of the box after root, so it would be as close to factory as possible. It should be 8.1.2, but 8.1.3 is rootable also. I lost root after the update and was still able to root.
The Following 2 Users Say Thank You to onemeila For This Useful Post: [ Click to Expand ]
 
F@@dog
Old
#13  
F@@dog's Avatar
Member
Thanks Meter 21
Posts: 76
Join Date: May 2012
Location: Dallas TX
Default Bricked over a dpi change!

[QUOTE=onemeila;34571114]THIS IS NOT A CUSTOM RECOVERY!!!
KINDLE FIRE HD 8.9 ONLY!!! USE AT YOUR OWN RISK!!


About an hour ago I ran a tool to change dpi on my Kindle 8.9 and was greeted with the unpleasant notice that my 8.9 could not boot. System goes to the screen that asks if I want to do a factory restore. That of course fails. Downloading your recovery prog, will try it in the morning, anything need to do other than follow your bouncing ball?

Thanks

F@@dog

---------- Post added at 02:45 AM ---------- Previous post was at 02:36 AM ----------

Quote:
Originally Posted by onemeila View Post
THIS IS NOT A CUSTOM RECOVERY!!!
KINDLE FIRE HD 8.9 ONLY!!! USE AT YOUR OWN RISK!!




To come in next version:
Install of GoogleServicesFramework.apk after erase of cache and userdata, thought about adding this after writing this post.
If anyone wants see other options included let me know.

.


Have you added Install of GoogleServicesFramework.apk yet?
 
onemeila
Old
#14  
onemeila's Avatar
Senior Member - OP
Thanks Meter 237
Posts: 296
Join Date: Jan 2012
Location: Winchester

 
DONATE TO ME
[QUOTE/]
Have you added Install of GoogleServicesFramework.apk yet?[/QUOTE]

Posting link now
 
F@@dog
Old
#15  
F@@dog's Avatar
Member
Thanks Meter 21
Posts: 76
Join Date: May 2012
Location: Dallas TX
Default Works as Advertised Thank you Onemeila!

Quote:
Originally Posted by onemeila View Post
[QUOTE/]
Have you added Install of GoogleServicesFramework.apk yet?
Posting link now[/QUOTE]

Started to use KFHD_SRT v 1.3 When I woke up this morning, had to look for GSFa before starting, then spotted your answer to me, still on my laptop! Sooo I went with KFHD_SRT v2.0 instead. Didn't even finish my first cup of coffee and you had me back up. Needless to say, I think I will stay away from the dpi tool that caused this to begin with. One question, (not sure if I ever used option 5). is it included in Option 3??

I think I owe you something, will take care of it before the weekend.
 
onemeila
Old
#16  
onemeila's Avatar
Senior Member - OP
Thanks Meter 237
Posts: 296
Join Date: Jan 2012
Location: Winchester

 
DONATE TO ME
Quote:
Originally Posted by F@@dog View Post
Posting link now
One question, (not sure if I ever used option 5). is it included in Option 3?? [/QUOTE]

No it is not. I prefer not to install apps as system apps unless it is necessary. There is no sense in potentially causing more problems. Also the more you install as system, the more you will lose and have to redo if you get an update.
 
sullytrny
Old
#17  
sullytrny's Avatar
Senior Member
Thanks Meter 29
Posts: 358
Join Date: Dec 2006
I bricked this device playing with permissions to get app store installed. This tool really saved me.

I used option 4 then 3 and all is well.

Installed Google resources manually as the tool lost the device. Every thing except Gmail that I have in the screenshot works.

Thanks a bunch

Click image for larger version

Name:	uploadfromtaptalk1355794008954.jpg
Views:	403
Size:	39.0 KB
ID:	1572094

Sent from my KFJWI using Tapatalk 2
HTC ONE - XT912 - GT3113 - COLBY 3048 - KFHD 8.9 all rooted
 
drr00t
Old
(Last edited by drr00t; 20th December 2012 at 03:47 AM.) Reason: solved
#18  
Member
Thanks Meter 0
Posts: 44
Join Date: Jul 2010
Location: Brasília - DF
Question Is it work with 8.1.4?

Hi,

I trying root my kindle 8.9, but is not working, my system version is 8.1.4 is this the problem? I follow steps, but SR Tool, is not detecting my kindle it just stay on <waiting for device>. I tried option 1, to start adb and i got message that adb is outdated, after that i tried option 3 and stay on waiting for device.

I now my kindle show up in adb devices list, after install right drivers, but recovery continue waiting for device.

edited 1: any help very appreciated.

edited 2: finaly all works fine.

thanks.
 
onemeila
Old
#19  
onemeila's Avatar
Senior Member - OP
Thanks Meter 237
Posts: 296
Join Date: Jan 2012
Location: Winchester

 
DONATE TO ME
Quote:
Originally Posted by drr00t View Post
Hi,

I trying root my kindle 8.9, but is not working, my system version is 8.1.4 is this the problem? I follow steps, but SR Tool, is not detecting my kindle it just stay on <waiting for device>. I tried option 1, to start adb and i got message that adb is outdated, after that i tried option 3 and stay on waiting for device.

I now my kindle show up in adb devices list, after install right drivers, but recovery continue waiting for device.

edited 1: any help very appreciated.

edited 2: finaly all works fine.

thanks.
Thats good you got it to work but if you were just trying to root this was not the tool to use. This tool is used to unbrick your device. It will give you root access but at the moment it is for v8.1.3. So as soon as you have wifi connected it is going to upgrade again to 8.1.4 and you will lose root.
The Following User Says Thank You to onemeila For This Useful Post: [ Click to Expand ]
 
onemeila
Old
#20  
onemeila's Avatar
Senior Member - OP
Thanks Meter 237
Posts: 296
Join Date: Jan 2012
Location: Winchester

 
DONATE TO ME
Confirmed- downgrading from 8.1.4 to 8.1.3 is possible with this tool without having to flash other partitions.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes