Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Guide] How to fix 4.2 lag

OP fishingfon

25th November 2012, 01:32 PM   |  #1  
fishingfon's Avatar
OP Senior Member
Flag Brisbane, QLD, Australia
Thanks Meter: 253
 
713 posts
Join Date:Joined: Feb 2012
More
Hi all,
I recently upgraded to 4.2q on my Nexus 7, and I experienced a lot of lag on it. I was browsing the Internet, and I found this on the internet which has worked well for me, and now I have no lag. I don't know if this has already been posted here.
This is what I found on the internet:


"If you’re one of the poor users experiencing major lag on your Nexus 7 after the Android 4.2 update, here’s what you can do to remedy the situation:

Open your app drawer
Open Google Currents
Click the three dots in the top right corner of the app
Tap “Settings”
Uncheck “Enable Background Sync”
Reboot your Nexus 7

That’s it. You shouldn’t experience anymore lag and you probably won’t even need to reboot. For me the difference was night and day. I went an extra step and disabled the app completely just in case. If you want to disable Google Currents for good measure, you can do so by going into your main Settings menu, clicking Apps, swiping to the All category, clicking Google Currents, and then clicking Disable. (If you do this you won’t be able to use Google Currents anymore, but at least your Nexus 7 will be back to normal."


Hope this helps.

Cheers
Corey

Sent from my Nexus 7 using Tapatalk 2
Last edited by fishingfon; 27th November 2012 at 12:25 PM.
The Following 63 Users Say Thank You to fishingfon For This Useful Post: [ View ]
25th November 2012, 04:27 PM   |  #2  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jul 2012
This fixed the lag issues instantly. Thanks so much!

Sent from my Nexus 7 using xda app-developers app
25th November 2012, 04:31 PM   |  #3  
chismay's Avatar
Senior Member
Flag LONDON
Thanks Meter: 153
 
963 posts
Join Date:Joined: May 2011
More
WOW

really? google currents is what is lagging everyone on 4.2?

thats weird , totally weird to be that reason and....totally weird easy solution, think your gonna get many thanks for this well done for the find!
still on 4.1 here cos heard of laggy issues , when i do update ill remember this though

ps. might be good to let the guys in "androidforums" know too
25th November 2012, 08:29 PM   |  #4  
GldRush98's Avatar
Senior Member
Flag Taylorville, IL.
Thanks Meter: 278
 
2,212 posts
Join Date:Joined: Jun 2006
More
Could be why I have never seen the lag. I always have Currents sync unchecked in my Google account since I don't use it.
25th November 2012, 08:52 PM   |  #5  
Member
Flag Oulu
Thanks Meter: 12
 
85 posts
Join Date:Joined: Aug 2010
More
If this really works, it is the most representative of the issue I have with Android. How is a normal user going to monitor all apps and deduce what app or setting is causing the issue. So... does this really work or is it just imagination?
The Following User Says Thank You to Cmmts For This Useful Post: [ View ]
25th November 2012, 09:18 PM   |  #6  
big_lilo's Avatar
Member
Thanks Meter: 7
 
31 posts
Join Date:Joined: Jul 2008
read that this morning on Drippler ... Can't believe thats the fix! haha Thats awesome
The Following 2 Users Say Thank You to big_lilo For This Useful Post: [ View ]
26th November 2012, 12:30 AM   |  #7  
Senior Member
Thanks Meter: 6
 
190 posts
Join Date:Joined: Apr 2008
I read this on Drippler too, disabled currents background sync, and have noticed the significant improvement. Im surprised there arnt task managers to identify such a promlem. I thought these rooters and flashers could run terminal commands. No one ran ps?

Sent from my Nexus 7 using XDA Premium HD app
The Following User Says Thank You to Flanimal For This Useful Post: [ View ]
26th November 2012, 12:37 AM   |  #8  
portage's Avatar
Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Nov 2012
thx it works
26th November 2012, 12:38 AM   |  #9  
Senior Member
Flag Cardiff
Thanks Meter: 54
 
133 posts
Join Date:Joined: Jul 2012
This doesn't cure lag across the board, I suspect my continuing lag issues are due to having added a user.
Added account for my GF so she could see how nice jelly bean is and that iOS doesn't rule the world, and the more she's used it more laggy my use of n7 has become.
Ok I can fix by deleting it but its quite a serious issue so hope Google fix quick.
Sent from my Nexu
The Following User Says Thank You to bkmaracas For This Useful Post: [ View ]
26th November 2012, 01:13 AM   |  #10  
phonic's Avatar
Senior Member
Flag Florida
Thanks Meter: 412
 
1,130 posts
Join Date:Joined: May 2008
Donate to Me
More
Quote:
Originally Posted by bkmaracas

This doesn't cure lag across the board, I suspect my continuing lag issues are due to having added a user.
Added account for my GF so she could see how nice jelly bean is and that iOS doesn't rule the world, and the more she's used it more laggy my use of n7 has become.
Ok I can fix by deleting it but its quite a serious issue so hope Google fix quick.
Sent from my Nexu

Wow, you were so lagged that you couldn't even get the "s" in 'Nexus' to register in time for your post.

The Following User Says Thank You to phonic For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes