FORUMS

Analysis & Opinion

Top Forum Discussions

[Guide][Help] Play Store error -24: What is it and how to solve it

6,403 posts
Thanks Meter: 4,153
 
Post Reply Subscribe to Thread Email Thread
This is a common error that occurs with the Play Store sometimes after flashing ROMs without wiping data, or with an incomplete un-installation (apk corruption, etc.)

What is it?

Basically, there is some app data left behind from a previous installation of the app. The Play Store sees that data when trying to install the app and throws a -24 error, because it doesn't know what to do with it.

So, how do you solve it?

Simple to fix:
(I'm assuming you're rooted, chances are you are if you get this error)
- YOU'LL LOSE YOUR DATA FOR THAT APP (You would have done anyway, if it was uninstalled properly) -
1.) Using a root file manager, go to /data/data
2.) Find the package name of the app you're wanting to install
(Don't know the package name? Find the app you're wanting to install on the Play Store online and it's in the URL)
3.) Delete that folder. All of it.
4.) Try to install your app again, it should work now
5.) If you like, hit the thanks button

If you're unrooted, you can try this:

Run this in adb
Code:
adb shell rm -R -f /data/data/<packagename>
Replace <packagename> with the package name of your app (if you don't know it, see above)

If that doesn't work, a factory reset is your only option, sorry
Last edited by Quinny899; 3rd December 2012 at 06:06 PM.
The Following 190 Users Say Thank You to Quinny899 For This Useful Post: [ View ]
 
 
4th December 2012, 05:48 AM |#2  
prboy1969's Avatar
Recognized Contributor
Flag Michigan
Thanks Meter: 7,348
 
More
Great write up man .

TEAM MiK
MikROMs Since 3/13/11
The Following User Says Thank You to prboy1969 For This Useful Post: [ View ]
17th January 2013, 07:34 AM |#3  
t0ny0's Avatar
Senior Member
Flag Atlanta, GA
Thanks Meter: 463
 
More
you just saved me Thanks a bunch!
The Following 2 Users Say Thank You to t0ny0 For This Useful Post: [ View ]
28th February 2013, 10:54 AM |#4  
SynnyG's Avatar
Senior Member
Flag Strasbourg
Thanks Meter: 636
 
Donate to Me
More
F*ck, you're a genius man, many thanks to you !
The Following User Says Thank You to SynnyG For This Useful Post: [ View ]
4th March 2013, 02:32 AM |#5  
nimrodity's Avatar
Senior Member
Thanks Meter: 1,195
 
Donate to Me
More
Thx so much, you really saved me with your guide!!!
9th July 2013, 07:09 PM |#6  
n1nj4Lo's Avatar
Senior Member
Flag ★ATLANTA★
Thanks Meter: 329
 
More
I did all that but am still getting the same error with Beautiful Widgets, I just upgraded from 4.1.2 to 4.2.2, any other advice...
15th August 2013, 05:24 AM |#7  
Junior Member
Thanks Meter: 2
 
More
My device (Galaxy S4) is unrooted and i never root or install any custom rom on this device so i use the adb shell and enter the above command,
i get rm failed for /data/data/com.miui.mihome2, Permission denied
Any other suggestion or advice??Is factory reset the only option??
The Following 2 Users Say Thank You to St.Valkyrie For This Useful Post: [ View ]
6th September 2013, 05:27 PM |#8  
SahilC's Avatar
Senior Member
Flag Amherst
Thanks Meter: 879
 
More
Hey guys, I did this, but it still isn't working. Any help?

Nexus Prime, powered by CyanogenMod and LeanKernel.
24th September 2013, 01:38 AM |#9  
Junior Member
Thanks Meter: 1
 
More
It keeps saying that no such file or directory exists.... I have my phone plugged in, debugging is on, and I open ADB in command prompt...
The Following User Says Thank You to wholocked10 For This Useful Post: [ View ]
31st October 2013, 01:45 AM |#11  
Junior Member
Flag Bello
Thanks Meter: 11
 
More
Thumbs up It worked, Swype was the software
I upgraded my S4 Octa-core from 4.2.2 to 4.3, the Swype keyboard, the paid version, did not appear, so I tried to install it from Google Play (several times), error -24, I looked for an answer in the Swype forum, nothing, then I found this thread (why the hell I did not look for it here in the first place...? ), and this did the trick.

All this story just to say Thank you a lot man, you saved my day, stock keyboard is not bad, but Swype is awesome.
The Following User Says Thank You to dmunera For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread

Tags
-24, error, play, solution, store
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes