Post Reply

SD Card Unexpectedly Removed

OP OwenW71

8th December 2012, 05:38 PM   |  #11  
Senior Member
Thanks Meter: 109
 
741 posts
Join Date:Joined: Mar 2011
More
[QUOTE=havocd;35146562]I have a sandisk 64gb class 10 I havent had this problem as of yet...

+1
12th December 2012, 09:23 PM   |  #12  
limpysmalls's Avatar
Member
Flag Eugene
Thanks Meter: 7
 
59 posts
Join Date:Joined: Mar 2011
More
I am having the same issue. It is with all SD-Cards I try after some time. I have 2 32gb Sandisk class 10 that I tried and a handful of 2 and 4 gb class 4 and class 6 cards. After sometime, 20 minutes to a couple of hours I starting getting the "SD Card unexpectedly removed" Then a quick scanning s Card message. I tried formatting the cards with different computers and even using my Linux machine to see if it would fix it.

Has anyone come up with a solution yet? Should I swap the phone out for another one since I have ruled out the SD-Card as being the problem.

My 14 days hits this weekend and it is easier to get things done at T-Mobile before that time frame expires.
12th December 2012, 09:39 PM   |  #13  
Senior Member
Flag Boynton Beach
Thanks Meter: 450
 
1,700 posts
Join Date:Joined: Nov 2010
More
How about card format? All fat32? Exfat?
12th December 2012, 09:41 PM   |  #14  
limpysmalls's Avatar
Member
Flag Eugene
Thanks Meter: 7
 
59 posts
Join Date:Joined: Mar 2011
More
All fat32 for me. Phone is stock, holding out on root for awhile so I can learn why Touchwiz is so hated.

Sent from my SGH-T889 using xda premium
12th December 2012, 09:43 PM   |  #15  
Senior Member
Flag Boynton Beach
Thanks Meter: 450
 
1,700 posts
Join Date:Joined: Nov 2010
More
Maybe format on your computer in exfat, maybe make a difference?
13th December 2012, 12:27 AM   |  #16  
predation's Avatar
Senior Member
Thanks Meter: 51
 
524 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by stevessvt

Maybe format on your computer in exfat, maybe make a difference?

curious about this as well.
you guys not having problems, you format exfat??/ what is the difference between exfat and fat32?
13th December 2012, 02:52 AM   |  #17  
OP Senior Member
Thanks Meter: 26
 
177 posts
Join Date:Joined: Jul 2010
More
I tried ExFAT, but the phone did not recognize it at all.

I wonder if anyone has had this issue with a Samsung brand card?

Swyped from a hand-held Galaxy.
13th December 2012, 04:39 AM   |  #18  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2012
Im getting the same problem with my 32 gb sandisk sd card but luckily amazon is still willing to exchange it out for me
Sent from my SGH-T889 using Tapatalk 2
13th December 2012, 07:49 AM   |  #19  
limpysmalls's Avatar
Member
Flag Eugene
Thanks Meter: 7
 
59 posts
Join Date:Joined: Mar 2011
More
I formatted mine to exfat to see what would happen. I checked online and this phone supports exfat natively. I moved my files back on to the card after the format and then tossed it in the phone and it worked. It has been over an hour and still has not removed itself unexpectedly.

Will report back in tomorrow after I give it some time to settle.

Sent from my SGH-T889 using xda premium
13th December 2012, 05:27 PM   |  #20  
limpysmalls's Avatar
Member
Flag Eugene
Thanks Meter: 7
 
59 posts
Join Date:Joined: Mar 2011
More
It is still removing itself almost everytime the phone goes to sleep. The last time it actually unmounted and tols me it was safe to remove the sd card when I woke the phone up.

What cards are people running? I have 2 I am testing this with:

SanDisk ultra 32GB SD-HC U1 (comparable to class 10), 1 is formatted to exfat and is half filled with mp3's, the other is fat32 and half filed with mp3's.

The mp3's are different on each card, I have a folder of music that I always throw back on the card but thought it might be corrupted so last night I made a new folder and added fresh music to see if that was the issue.

I found the official sd formatter program from the SD Alliance to try. I just formatted 1 of the cards with it and am moving the music back now. It will be a while though. From sd to computer the speeds are 12 to 30 MB/s but from computer to sd it is 2 to 5 MB/s?

Hope to have this figured out by the end of the day.

Sent from my SGH-T889 using xda premium

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes