Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] US T-Mobile MMS not working on my Droid DNA

OP ttn1185

13th December 2012, 09:44 PM   |  #1  
OP Member
Thanks Meter: 6
 
39 posts
Join Date:Joined: May 2006
I have setup the T-Mobile APN in multiple possible ways: changed the existing one, created a new one, create 2 (one for data and one for mms). But I cant get MMS to work at all. Data is fine btw. I have Edge and HSPDA around Dallas metroplex.

Anyone got any lucks with T-Mobile MMS on this phone?
14th December 2012, 12:36 AM   |  #2  
djnicho12's Avatar
Senior Member
Flag san pablo
Thanks Meter: 20
 
153 posts
Join Date:Joined: Oct 2010
Donate to Me
More
I'm in the same boat as you but I don't really use pics message that much but I hope someone figure out how to make it work

Sent from my HTC6435LVW using xda app-developers app
14th December 2012, 05:41 PM   |  #3  
crackeyes's Avatar
Senior Member
Flag knoxville
Thanks Meter: 186
 
639 posts
Join Date:Joined: Feb 2009
Donate to Me
More
I have been trying since it came out. I have been somewhat successful by getting gosms and going to the advance settings and putting in the mmsc manually in their settings, does not work all the time but does sometimes
15th December 2012, 09:04 PM   |  #4  
crackeyes's Avatar
Senior Member
Flag knoxville
Thanks Meter: 186
 
639 posts
Join Date:Joined: Feb 2009
Donate to Me
More
Got it to work
Ok finally got it to work. I have done some major investigation but It works until a reset then all you have to do is change a simple setting to correct it

To get it to work first you have to put in your sim card. The phone will put in the generic TMO settings for APN. After that you have to go edit the settings. Change them to

Name: T-Mobile US
APN: epc.tmobile.com
Proxy: 216.155.165.050
Port: 8080
Username: (leave this blank)
Password: (leave this blank)
Server: (leave this blank)
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS Proxy: 216.155.165.050
MMS Port: 8080
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
APN Type: (leave this blank)

After that you have to go to the play store and download GOSMS pro (free app). Once it is installed open it up, go through their tutorial. Hit menu then go to settings, once there go to advance, scroll to the bottom and hit mms settings then scroll to the bottom of it put a check in the “fill apn configuration manually” box. Then you will set your MMSC to" http://mms.msg.eng.t-mobile.com/mms/wapenc " then your proxy to : " 216.155.165.050 " then your port to " 8080 ". Hit the back button and you are good to go. After that you will have MMS working (may get a did not download message but the pic did download. If you reboot you will have to go in and edit your APN to clear out the default apn type, save it and good to go
The Following 3 Users Say Thank You to crackeyes For This Useful Post: [ View ]
10th January 2013, 10:30 PM   |  #5  
Member
Thanks Meter: 3
 
49 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by crackeyes

Ok finally got it to work. I have done some major investigation but It works until a reset then all you have to do is change a simple setting to correct it

To get it to work first you have to put in your sim card. The phone will put in the generic TMO settings for APN. After that you have to go edit the settings. Change them to

Name: T-Mobile US
APN: epc.tmobile.com
Proxy: 216.155.165.050
Port: 8080
Username: (leave this blank)
Password: (leave this blank)
Server: (leave this blank)
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS Proxy: 216.155.165.050
MMS Port: 8080
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
APN Type: (leave this blank)

After that you have to go to the play store and download GOSMS pro (free app). Once it is installed open it up, go through their tutorial. Hit menu then go to settings, once there go to advance, scroll to the bottom and hit mms settings then scroll to the bottom of it put a check in the “fill apn configuration manually” box. Then you will set your MMSC to" http://mms.msg.eng.t-mobile.com/mms/wapenc " then your proxy to : " 216.155.165.050 " then your port to " 8080 ". Hit the back button and you are good to go. After that you will have MMS working (may get a did not download message but the pic did download. If you reboot you will have to go in and edit your APN to clear out the default apn type, save it and good to go

Quote:
Originally Posted by djnicho12

I'm in the same boat as you but I don't really use pics message that much but I hope someone figure out how to make it work

Sent from my HTC6435LVW using xda app-developers app

Quote:
Originally Posted by ttn1185

I have setup the T-Mobile APN in multiple possible ways: changed the existing one, created a new one, create 2 (one for data and one for mms). But I cant get MMS to work at all. Data is fine btw. I have Edge and HSPDA around Dallas metroplex.

Anyone got any lucks with T-Mobile MMS on this phone?

can you guys post your experience with data speeds for the DNA in tmobile? are you getting 4G or 3G or 2G only and if so, where are you?
thanks
11th January 2013, 12:23 AM   |  #6  
crackeyes's Avatar
Senior Member
Flag knoxville
Thanks Meter: 186
 
639 posts
Join Date:Joined: Feb 2009
Donate to Me
More
I live in an 4g market but not the 1900mhz market so i only get edge but they are suppose to have it up and running by the end of the month so we will see then
15th January 2013, 05:12 AM   |  #7  
charlieb620's Avatar
Senior Member
Flag Philadelphia, PA
Thanks Meter: 1,982
 
13,384 posts
Join Date:Joined: Jan 2009
More
I used this with multiple unbranded or unlocked phones I had. When I had the DNA briefly I used this and it worked for me.

Just pick your carrier and reboot and MMS should work.

https://play.google.com/store/apps/d...G4uZ2xvYmFsIl0.
20th April 2013, 04:27 PM   |  #8  
Senior Member
Thanks Meter: 61
 
220 posts
Join Date:Joined: Dec 2008
Quote:
Originally Posted by crackeyes

Ok finally got it to work. I have done some major investigation but It works until a reset then all you have to do is change a simple setting to correct it

To get it to work first you have to put in your sim card. The phone will put in the generic TMO settings for APN. After that you have to go edit the settings. Change them to

Name: T-Mobile US
APN: epc.tmobile.com
Proxy: 216.155.165.050
Port: 8080
Username: (leave this blank)
Password: (leave this blank)
Server: (leave this blank)
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS Proxy: 216.155.165.050
MMS Port: 8080
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
APN Type: (leave this blank)

After that you have to go to the play store and download GOSMS pro (free app). Once it is installed open it up, go through their tutorial. Hit menu then go to settings, once there go to advance, scroll to the bottom and hit mms settings then scroll to the bottom of it put a check in the “fill apn configuration manually” box. Then you will set your MMSC to" http://mms.msg.eng.t-mobile.com/mms/wapenc " then your proxy to : " 216.155.165.050 " then your port to " 8080 ". Hit the back button and you are good to go. After that you will have MMS working (may get a did not download message but the pic did download. If you reboot you will have to go in and edit your APN to clear out the default apn type, save it and good to go

Thanks, Crackeyes - these settings worked for me on my DNA (running Newt's M7 ROM, if that makes a difference). I didn't need to use GOSMS on mine. The settings you provided worked fine using the stock messaging app. I'm so happy (since I've tried settings posted in other threads and they didn't work or were missing some of the settings entries you posted).

The Following User Says Thank You to rossvtaylor For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes