Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,250 Members 41,791 Now Online
XDA Developers Android and Mobile Development Forum

"Keep Wifi on During Sleep = Never" battery problem

Tip us?
 
jim-j
Old
(Last edited by jim-j; 9th January 2013 at 02:36 PM.) Reason: Clarified that my tablet is WiFi only
#1  
Junior Member - OP
Thanks Meter 10
Posts: 5
Join Date: Jan 2013
Battery Low "Keep Wifi on During Sleep = Never" battery problem

Executive summary = You always want "Keep Wifi on During Sleep" set to "Always" if you care about your battery life.


In post #17 in the "P6210 - Huge Battery Drain on ICS" thread iosandroid found that setting "Settings->Wifi->Menu->Advanced->Keep Wifi on During Sleep" to "Never" caused battery drain. Since I feel this is big bug and my mom told me I'm special I thought I'd start a new thread with some more details on this problem, a more descriptive thread title to highlight this issue and a few questions of my own.

I have a Samsung Galaxy Tab 7.0 Plus (aka GT-P6210) WiFi only tablet that had HC (Honeycomb) when I first got it. To save battery I changed "Settings->Wifi->Menu->Advanced->Keep Wifi on During Sleep" to "Never" (actually think the wording was a little different back in the HC days, but you get the idea). I'm not sure if/how much this helped, but it didn't hurt my battery life.

Shortly after upgrading to ICS (Ice Cream Sandwich) I noticed my battery life was worse. Apparently I wasn't alone since "iosandroid" (see above) had the same problem and solution. That is, if you set Settings->Wifi->Menu->Advanced->Keep Wifi on During Sleep" to "Never" or "Only when plugged in" your better drains much faster when you're tablet is idle. How much faster? In my tests setting this to "Never" drained my battery by 3.10%/hour. If I leave this at its ICS default of "Always" my battery only drains at 0.27%/hour, OVER 10 TIMES BETTER (idle) BATTERY LIFE! See the bottom of this post for a listing of my battery drain tests.

By using "CPU Spy" I could see that with "Keep Wifi on During Sleep" set to "Never" my tablet would never go into deep sleep, but with it set to "Always" my tablet would spend almost all of its time in deep sleep. GSam Battery Monitor showed that "Kernel (Android OS)" was using up most of my battery when this problem is occurring.

This problem isn't limited to ICS, I also got the same results with JB (Jelly Bean). Specifically I used "AOKP Jelly Bean Milestone 1". With stock ICS the default setting is "Always", so only people that mess with their advanced settings will be affected by this. Note that I believe that an OTA upgrade from HC to ICS will retain your previous settings for this. In JB (at least AOKP JB), this problem will have a much wider reach since "Keep Wifi on During Sleep" defaults to "Never".


Now on to my questions:
-Does anyone know the scope of this bug? Does it only affect the P6210, or Samsung devices, or every Android device? iosandroid reported having the same problem with his phone.
-Do I have to open a tech support case with Samsung to report this bug, or is there a better way?



[Battery Drain Tests]
VERSION Keep Wifi on During Sleep? DRAIN RATE
----------------------------------------------------------------------------------------------
HC Always 1.00%/hour (lost 2% total over 2 hours)
HC Never 0.50%/hour (lost 1% total over 2 hours)
ICS Always 0.27%/hour (lost 2% total over 7.5 hours)
ICS Never 3.10%/hour (lost 24% total over 7.75 hours)
JB Always 1.0%/hour (lost 1% total over 1 hour)
JB Never 3.52%/hour (lost 81% total over 23 hours)
-Legend
--HC = Stock Honeycomb (Android 3.2)
--ICS = Stock Ice Cream Sandwich (Android 4.0.4)
--JB = AOKP Jelly Bean Milestone 1 (Android 4.1.2)
-Setting "Keep Wifi on During Sleep?" to "Only when plugged in" behaves the same as "Never" (i.e. it has same battery drain problem)
-Yes, I know my testing time periods vary wildly, but I'm too impatient to wait a day for each of the tests. For example I'm sure JB's "Always On" loss rate is much closer to ICS's.
The Following 2 Users Say Thank You to jim-j For This Useful Post: [ Click to Expand ]
 
koalauk
Old
#2  
Senior Member
Thanks Meter 38
Posts: 324
Join Date: Jan 2006
Location: Nowhere
All I can say or add to this my tenderloin HP touch pad running cm is the same keep wifi on always drains the battery slower than never.
HTC Blueangel 6.5.5 Dtwo
HTC HD Blackstone
and ZTE Blade by the morning
HTC Desire HD
Samsung Galaxy Note 2
 
viper001
Old
#3  
Senior Member
Thanks Meter 188
Posts: 608
Join Date: Dec 2010
IMO, it would be because of 3G activating when the wifi turn off during sleep.

Try doing your test in Airplane mode to isolate the activation of the Phone radio and stick only to WIFI during your comparison test.


EDIT: ooops! sorry, it just occured to me that you've got a P6210 and not a P6200. My bad.
 
jim-j
Old
#4  
Junior Member - OP
Thanks Meter 10
Posts: 5
Join Date: Jan 2013
Default Airplane mode uses more battery than WiFi always on

Quote:
Originally Posted by viper001 View Post
Try doing your test in Airplane mode
Yup, my tab is WiFi only. However I did actually test it in airplane mode and found that the battery lost 0.40%/hour (lost 11% total over 27 hours) with airplane mode enabled. This is still worse than the 0.27%/hour you lose when you just leave WiFi on (Keep Wifi on During Sleep? set to Always). This airplane mode battery drain was also unexpected to me, but in googling it seems like this is a common problem.

One last test I did was to manually turn the WiFi off. When I did that the battery only drained at a rate of 0.11%/hour (lost 1% total over 9.5 hours). I should test that longer to get a more precise number, but my short test was good enough to show that manually turning WiFi off does actually save power (it's about time something worked as I expected it to .

My next planned test it to use something like AutomateIt to automatically turn off the WiFi after the screen turns off to see if I can automate the WiFi battery savings.
 
hopya
Old
#5  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jan 2013
My GT-P6210 also has the same issue after installing Elements HD rom. I never had this issue even after upgrading from honeycomb to ICS stock.i
 
viper001
Old
#6  
Senior Member
Thanks Meter 188
Posts: 608
Join Date: Dec 2010
Quote:
Originally Posted by jim-j View Post
Yup, my tab is WiFi only. However I did actually test it in airplane mode and found that the battery lost 0.40%/hour (lost 11% total over 27 hours) with airplane mode enabled. This is still worse than the 0.27%/hour you lose when you just leave WiFi on (Keep Wifi on During Sleep? set to Always). This airplane mode battery drain was also unexpected to me, but in googling it seems like this is a common problem.

One last test I did was to manually turn the WiFi off. When I did that the battery only drained at a rate of 0.11%/hour (lost 1% total over 9.5 hours). I should test that longer to get a more precise number, but my short test was good enough to show that manually turning WiFi off does actually save power (it's about time something worked as I expected it to .

My next planned test it to use something like AutomateIt to automatically turn off the WiFi after the screen turns off to see if I can automate the WiFi battery savings.
If you know how, try looking into the build.prop. you'll find that stock wifi. supplicant_scan_interval=15. try a higher number like 90 or 180. this basically lengthens the time for wifi network searches from 15 secs to 90 or 180 seconds respectively.
 
jim-j
Old
#7  
Junior Member - OP
Thanks Meter 10
Posts: 5
Join Date: Jan 2013
Default As Krusty the Clown says, "it's not just good--it's good enough"

Quote:
Originally Posted by viper001 View Post
If you know how, try looking into the build.prop. you'll find that stock wifi. supplicant_scan_interval=15. try a higher number like 90 or 180. this basically lengthens the time for wifi network searches from 15 secs to 90 or 180 seconds respectively.
I could probably figure out how to change that, but I've decided that just leaving WiFi on all the time gives me good enough battery life. I enjoy troubleshooting these types of technical problems, but unfortunately I must return to debugging my three year old daughter's Dravet Syndrome. Her cognition is deteriorating, so I'm hoping to find a solution or workaround soon. If any of the multimillionaires that read this forum want to fund a cure for Dravet Syndrome, head on over to dravet.org or dravetfoundation.org
 
neu - smurph
Old
#8  
Senior Member
Thanks Meter 47
Posts: 181
Join Date: May 2013
I've got this issue on a Chinese Tablet running JB 4.1.1. After some investigation the conclusion I've reached is that the settings are mislabled on the GUI. "Always" results in disconnection from the SSID 15 minutes into sleep (although WIFI is still 'ON'). "Never" keeps WIFI on and connected indefinitely, and if autosync is also on you'll get lots of wake-locks and reduced standby battery life, particularly if you have location reporting on and google maps installed.
The Following User Says Thank You to neu - smurph For This Useful Post: [ Click to Expand ]
 
jim-j
Old
#9  
Junior Member - OP
Thanks Meter 10
Posts: 5
Join Date: Jan 2013
Quote:
Originally Posted by neu - smurph View Post
I've got this issue on a Chinese Tablet running JB 4.1.1. After some investigation the conclusion I've reached is that the settings are mislabled on the GUI. "Always" results in disconnection from the SSID 15 minutes into sleep (although WIFI is still 'ON'). "Never" keeps WIFI on and connected indefinitely, and if autosync is also on you'll get lots of wake-locks and reduced standby battery life, particularly if you have location reporting on and google maps installed.
Interesting results, but that wasn't my experience. For example with WiFi always on my tablet does stay connected to the network all the time. All of these weird issues is about enough to make you want to buy an iPad.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Control Your Toast Notifications with SlicedToasts

Toasts are delicious, even in their Android flavor. In Android, toast doesn’t lead … more

Rotation Lets You Take Full Control of Your Device’s Orientation Settings

To be brutally honest, the native options for screen … more

Change the Alarm Icon in the Status Bar with Xposed

It’s hard to find a more hated object than your alarm clock. They wake us up nearly … more

Return to Outer Space Outer Space with Ship Up Game

Since the release of Flappy Birds, we’ve had the “fortune” to see … more