Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM] CM 10.1 (Android 4.2) for RazrHD XT925/XT926

OP epinter

19th February 2013, 10:36 AM   |  #261  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Aug 2008
Re: [ROM] CM 10.1 (Android 4.2) for RazrHD XT925
Okay, good for you! Lots of infos there.. but does you GPS work? I'm still unable to get a fix, and that occurred since the last update.
But everything seems to work quite well and being stable!

Sent from my XT925 using xda app-developers app
19th February 2013, 11:37 AM   |  #262  
madmonkey57's Avatar
Senior Member
Thanks Meter: 248
 
524 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by hadonf

but does you GPS work? I'm still unable to get a fix, and that occurred since the last update.

My GPS was off and all was running fine. Just turned it on, Running GPS Test. I can see a whole lot of sattelites and software trying to acquire the location, but fixing takes a very long time and so far no actual location... but I'm indoors for now...
19th February 2013, 12:58 PM   |  #263  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Aug 2008
Re: [ROM] CM 10.1 (Android 4.2) for RazrHD XT925
Better than me, mine seems to be offline as I'm not able to see a single satellite while being outdoors. And I cannot find any gps source setting...

Sent from my XT925 using xda app-developers app
20th February 2013, 02:19 AM   |  #264  
Skrilax_CZ's Avatar
Recognized Developer
Flag Prague
Thanks Meter: 1,348
 
900 posts
Join Date:Joined: Dec 2009
Donate to Me
More
Hey guys, how's wifi working on the RAZR HD CM? Primarilly how long does it take for it to find a network? I'm playing with it on the Photon Q but it takes quite long to find my home wifi (@channel 13). It then works fine once it connects.
20th February 2013, 03:55 AM   |  #265  
epinter's Avatar
OP Recognized Developer
Flag Sao Paulo
Thanks Meter: 7,325
 
896 posts
Join Date:Joined: Feb 2011
Donate to Me
More
Quote:
Originally Posted by Skrilax_CZ

Hey guys, how's wifi working on the RAZR HD CM? Primarilly how long does it take for it to find a network? I'm playing with it on the Photon Q but it takes quite long to find my home wifi (@channel 13). It then works fine once it connects.

It's fast to find the network ... I think it's normal
Your work on Photon Q uses which kernel ? 4.2 is working for you ?
20th February 2013, 06:22 AM   |  #266  
Member
Flag Sydney
Thanks Meter: 31
 
71 posts
Join Date:Joined: Apr 2008
More
4.2.2 was working great for me. Until today I turned my phone off and then it wouldn't boot. on second try the screen went blank except for a single purple line across the top of the screen (I'm guessing software fault gpu controller?) after another reboot its stuck in "Starting Apps". Ill continue to play and let you guys now how it goes.


Brad
20th February 2013, 08:00 AM   |  #267  
Junior Member
Flag Isa Town
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jan 2011
More
Re: [ROM] CM 10.1 (Android 4.2) for RazrHD XT925
I upgraded from cm10 and the same for unstable and no camera, I revert it back to cm10 for now

Sent from my XT925 using xda app-developers app
20th February 2013, 01:39 PM   |  #268  
Skrilax_CZ's Avatar
Recognized Developer
Flag Prague
Thanks Meter: 1,348
 
900 posts
Join Date:Joined: Dec 2009
Donate to Me
More
Quote:
Originally Posted by epinter

It's fast to find the network ... I think it's normal
Your work on Photon Q uses which kernel ? 4.2 is working for you ?

I'm first porting CM10 (after reading the issues with the camera etc.), didn't try 4.2. It takes like a minute for the wifi driver to find my home wifi, while it takes a few seconds on stock firmware. I'm using config from stock fw in /system/etc/firmware/wlan/prima. As for kernel, I'm using the stock 3.0.8 updated to 3.0.65 (tried the common kernel from your repo, but video driver for the Q needs fixing at least, don't know about other things).

I've noticed some differences in the overlay config when probing stock firmware though, like here: https://github.com/SkrilaxCZ/android...5713149064a5c9
Last edited by Skrilax_CZ; 20th February 2013 at 01:41 PM.
20th February 2013, 04:26 PM   |  #269  
madmonkey57's Avatar
Senior Member
Thanks Meter: 248
 
524 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by Skrilax_CZ

It takes like a minute for the wifi driver to find my home wifi, while it takes a few seconds on stock firmware.

I have noticed similar behavior, initial connections on a new WIFI hotspot takes a long time (a minute or so). I haven't used a stock firmware in a while, but I don't recall it was the case.
Last edited by madmonkey57; 20th February 2013 at 04:29 PM.
20th February 2013, 11:22 PM   |  #270  
Skrilax_CZ's Avatar
Recognized Developer
Flag Prague
Thanks Meter: 1,348
 
900 posts
Join Date:Joined: Dec 2009
Donate to Me
More
Stock firmware on the Photon Q (latest ICS fw, no JB out yet) is using version 3.1.1.14_0731.1. In CM there it says (in CORE/MAC/inc/qwlan_version.h) that the firmware version 3.1.2.5, but differs from the 3.2.1.5 in codeaurora.org, in the commit epinter said it's 3.1.1.14. Also, I couldn't find 3.1.1.14 on code aurora. Well a bit puzzling

Where did you take the prima wlan driver from or which from branch / tag?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes