Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[How To]Fix Recovery Bootloop after installing twrp and 2nd bootloader

2,239 posts
Thanks Meter: 619
By stunts513, Recognized Contributor on 26th September 2013, 06:16 PM
Post Reply Subscribe to Thread Email Thread
First and foremost I AM NOT RESPONSIBLE FOR ANY HARD BRICKS,etc ,etc(Really hard to hard brick a kindle doing this unless you flash a weird rom package)

Now that thats cleared up, I have been seeing too many recovery bootloop bricks lately because I think the main tutorials people use haven't been updated(to mention you need to put a rom on the kindle beforehand now), so I thought why not write a tutorial that explains how to fix this problem since there are so many posts, that way we can just put a link to the tutorial in the peoples threads. So here we go!

Things you need to do this:
  • a micro-usb cable
  • patience
  • minimal command prompt experience

  1. Boot your kindle into twrp (it should do this on its own at this point)
  2. Make sure you have the adb drivers installed(they will need to be installed again if you flashed an older version of twrp), if not, update your drivers in the device manager with the ones in my signature.(See below if you don't know how to update your drivers)
  3. Download the attached file and extract it somewhere
  4. Put the rom and gapps in the folder you extracted the files to
  5. Open a command prompt with admin privileges(start>all programs>accessories right click command prompt, hit run as admin)
  6. CD into the directory where the extracted files are
  7. Type this into the command prompt: adb push /sdcard/
  8. As I said in the filename put either the rom or the gapps, but send both in two commands
  9. At this point once the transfer is done unplug your kindle
  10. If you are going from amazon to a cm based rom, at this point you should wipe system, cache, dalvik cache, and do a factory reset. If not just goto step 11.
  11. Hit install, browse to the /sdcard folder and choose the rom and gapps files and flash them
  12. Reboot and profit!

For people with driver issues that don't know how to install my driver:
  1. Open the device manager
  2. Find the device with a triangle next to it
  3. Right click it and hit update driver
  4. Choose the option that lets you search a folder for drivers by browsing
  5. Choose the folder you extracted my drivers to
  6. Let it search and install the drivers
  7. Profit!

Note: If adb isn't picking up the kindle in recovery, try uninstalling the current kindle devices it detects first and then updating the drivers
Attached Files
File Type: zip - [Click for QR Code] (455.7 KB, 3687 views)
Last edited by stunts513; 14th October 2013 at 10:10 AM.
The Following 14 Users Say Thank You to stunts513 For This Useful Post: [ View ]
27th September 2013, 12:46 AM |#2  
Ph0enix_216's Avatar
Senior Member
Flag /system/xbin/su
Thanks Meter: 255
It's about time someone posted a tutorial for how to fix this. Great job! This should be a sticky.
28th September 2013, 04:22 AM |#3  
Junior Member
Thanks Meter: 0
I had the same problem... the looping thing... you're tutorial saved me! thanks a lot.
Last edited by dusuke; 28th September 2013 at 04:27 AM. Reason: (to make it short)
2nd October 2013, 10:34 PM |#4  
Junior Member
Thanks Meter: 0
rom and gapps
sry for my ignorance, but what do you mean with "rom and gapps"?
i explain what i've done:
i did everything in the guide to install twrp and 2nd bootloader.
i can acces in the twrp, but if i enter the reboot menu, if i push the botton "System", i had the boot loop problem (Kindle logo became orange and then blue forever)

Now the question is: where i find the rom and the gapps you're talking about?
3rd October 2013, 01:55 AM |#5  
stunts513's Avatar
OP Recognized Contributor
Flag New Braunfels, TX
Thanks Meter: 619
Donate to Me
You choose a ROM from the android development section for your model kindle, usually it tells what version of gapps(google apps) you need to flash with it. If it doesn't tell what gapps you need its pretty easy to tell, has the gapps posted for all versions of android, and have a chart telling which version goes with what os.

Sent from my Amazon Kindle Fire HD running CM10.1 Tablet UI using xda-developers app
5th October 2013, 11:26 PM |#6  
Junior Member
Thanks Meter: 0
*cannot read
When I go to push the file to the kindle I get a message in the command prompt saying *cannot stat '': no such file or directory.
I have the zip in the same folder as the adb file
Any suggestions?
Last edited by c_hader; 5th October 2013 at 11:30 PM.
6th October 2013, 12:31 AM |#7  
stunts513's Avatar
OP Recognized Contributor
Flag New Braunfels, TX
Thanks Meter: 619
Donate to Me
Check the ROM name to make sure its not a typo? It should work. Make sure you didn't rename the ROM and add .zip because windows by default doesn't show extensions, so the filename might actually be now if you did that.

Sent from my Amazon Kindle Fire HD running CM10.1 Tablet UI using xda-developers app
14th October 2013, 09:06 AM |#8  
Junior Member
Thanks Meter: 0
Sigh, I was hoping my first post on XDA wouldn't be a help request, but here I am..

I agonized for hours over the directions in this tutorial, checked all the right boxes, but I ended up in the bootloop as described in the OP. I can get to TWRP fine, but nothing else. My ADB drivers along with the Android SDK package were installed and previously working fine. Now, of course, the device no longer has a driver in Windows. I followed the instructions here, carefully selecting the extracted folder containing the ADB files, and Device Manager tells me—

"Windows was unable to install your Kindle. If you know the manufacturer of your device, you can visit its website and check the support section for driver software."

I tried a number of times to reboot both systems, uninstall the Kindle, try to pick it up again, etc., to no avail.

My device is a Kindle Fire HD 7" originally version 7.4.6. I made backups before I started as per the directions in the linked thread and I have my desired ROM and Gapp .zips all ready to go, I just can't get anything to the device. I'd prefer to avoid needing to get a factory cable, if possible.

Thanks for any help!

Edit: I've managed to get my .zip files to the /sdcard/ directory. For anyone stuck on the same problem I was, the instructions in this thread got my ADB drivers up and running again. The rest of the steps here worked fine at that point.
Last edited by typographie; 14th October 2013 at 09:36 AM. Reason: Solved my own problem.
16th October 2013, 12:24 AM |#9  
Senior Member
Thanks Meter: 28
Oh good, someone finally made a tutorial for this.
14th November 2013, 03:46 PM |#10  
Junior Member
Thanks Meter: 0
Help please
hello i am in need of some help, at step 6 can you explain what CD is. Also in Cmd i keep on getting this message below, please could you help me i also have just installed android ADB driver interface driver.

C:\Windows\system32>adb push /sdcard/
'adb' is not recognized as an internal or external command,
operable program or batch file.
Post Reply Subscribe to Thread

recovery bootloop, stuck in recovery
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes