Remove All Ads from XDA

[SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect

147 posts
Thanks Meter: 316
By QYOBZ, Senior Member on 21st January 2013, 09:03 AM
Post Reply Subscribe to Thread Email Thread
CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.


- Account sync OFF permanently with the message: "Sync is currently experiencing problems".
- Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

Possible Cause:
- system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

Possible Solution:
edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

Please do it at your own risk.

How to do it:


1.- ROOT your device (of course)

2.- Editing the file
You will need a proper editor
Download and Install Total Commander and open it

3.- Browse with Total Commander to root/etc
(hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
Tap mount R/W
Long tap on "hosts" > edit file > Totalcmd-Editor

Open etc/hosts and edit the file. Just put # before


Edited file should look like this: localhost

remember: based on my own observation it should be look like this: one space)localhost
# one space)

5.- Turn OFF your device.
6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
7. Reboot your device.
8. Once the phone reboots, input your google account information when the phone asks for it.
9.- Sync to your account and contacts


1. Make sure you have a ROOT ACCESS on your Device.
2. Install Root Explorer, Run App, Grant SU Access.
3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
4.Tap mount R/W
5.Look for host file, long press it and open with text editor.
6. just Add # (pound sign) on the first number.
like this:

# one space)

SAVE IT and Reboot.
Now you can connect to Google Play very well.

UPDATE: 08/22/13

If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
and install this app on playstore:

run app and choose your prefer edit.

Another Way Playstore not working after Installing/Uninstalling Freedom App?

- Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
- Reboot
- Shutdown & Boot to Recovery
- Wipe Cache/Dalvik Cache
- Reboot
- Presto! back to normal.

Removed Attached Files you may download it on Google Playstore.

Total Commander:

Root Explorer:

Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

Download Other File Managers:
Root Browser: (Credits to the Devs)
ES Explorer: (Credits to the Devs)

Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

Last edited by QYOBZ; 12th May 2014 at 08:34 AM. Reason: attached file
The Following 272 Users Say Thank You to QYOBZ For This Useful Post: [ View ] Gift QYOBZ Ad-Free
23rd January 2013, 01:21 AM |#2  
Junior Member
Thanks Meter: 2
I read your solution but when i saw my host file there was a different ip address

i comment both of them and did what you said but it didn't work the first time
2nd time i did that and it worked

Last edited by saif858; 23rd January 2013 at 02:17 AM.
The Following 2 Users Say Thank You to saif858 For This Useful Post: [ View ] Gift saif858 Ad-Free
23rd January 2013, 06:00 PM |#3  
Junior Member
Thanks Meter: 0
THAKS A LOT DUDE !!!!!!! I't works
30th January 2013, 10:28 AM |#4  
Flag Bangalore
Thanks Meter: 3
Donate to Me
Thumbs up Same Error
Even i have ip, so did u change this ip to 74. or did u add the new ip below the local host portion???

---------- Post added at 03:58 PM ---------- Previous post was at 03:43 PM ----------

Ok Thanks a lot it really worked now, now this might help for some one if u have the same error as i got. No ip present below local host ( ip present ). so just copy this (# below localhost , and that worked for me....
The Following User Says Thank You to MANOJ5329 For This Useful Post: [ View ] Gift MANOJ5329 Ad-Free
3rd February 2013, 09:34 PM |#5  
Junior Member
Thanks Meter: 0
Thumbs up Thank You!
Thank you for the info, it worked on my Chines tablet as it stopped working all of a sudden.
I had a feeling that it was something like this, just had no clue how to go about it... and why the hell are they using hard-coded IP addresses anyway???

BTW, just fixing the HOST file and rebooting fixed it for me.
3rd February 2013, 10:43 PM |#6  
Senior Member
Flag Paris
Thanks Meter: 13
THANKS! Browsed all over the net to find a solution to this issue!

Tried many things and was about to decide to sell my GNex and upgrade to nexus 4!

Thanks to this thread and you all I am a happy GNex user again.

Still wonder what happened that changed this file or fckd my system...
The Following User Says Thank You to benjieb For This Useful Post: [ View ] Gift benjieb Ad-Free
4th February 2013, 04:44 PM |#7  
Senior Member
Flag Paris
Thanks Meter: 13
Uhhh, didn't work so well. I have access to my google account again (play, gmail, youtube...)

but when I try to update an app or download a new one, I get an error: RPC:S-5:AEC-0

Can anyone help ?

5th February 2013, 07:53 PM |#8  
Junior Member
Thanks Meter: 0
Thanks problem solved
Hi I was frustrated for some time over this issue, following your instructions (ES file explorer and editor) solved the problem.
Only corrected the file without factory reset than added one of my accounts.
Thanks again.
20th February 2013, 01:53 PM |#9  
Junior Member
Thanks Meter: 4
Thumbs up Thanks Alot man !!!
Thanks Alot man !!! it works

here are the steps ( your device must me rooted ) :

1. download total commandar.apk from google
2. Install it in your android mobile
3. open the total commandar from ur android mobile and goto File System root
4. search for the folder etc and open that folder
5. now search for the file name ' hosts ' and click on it .
6. select edit file and add ---> " # " <--- before 2nd line like this " # "
7. and save it
8. Reboot your device
9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
The Following 4 Users Say Thank You to ahmer47 For This Useful Post: [ View ] Gift ahmer47 Ad-Free
22nd February 2013, 02:49 AM |#10  
Junior Member
Flag Jubail
Thanks Meter: 2
Thanks It worked in my GNote II...It happened to me many times when i flash a new ROM and these is the first time a solution works
The Following User Says Thank You to a4403 For This Useful Post: [ View ] Gift a4403 Ad-Free
27th February 2013, 02:02 PM |#11  
Junior Member
Thanks Meter: 0
Originally Posted by a4403

Thanks It worked in my GNote II...It happened to me many times when i flash a new ROM and these is the first time a solution works

thanks a million man.
it works wonder ...............

Read More
Post Reply Subscribe to Thread

can't establish, google play, playstore, server error, sync

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes