Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect

OP QYOBZ

21st January 2013, 10:03 AM   |  #1  
QYOBZ's Avatar
OP Senior Member
Flag Quezon City, Philippines
Thanks Meter: 256
 
147 posts
Join Date:Joined: Sep 2012
Donate to Me
More
CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

Issues:
- Account sync OFF permanently with the message: "Sync is currently experiencing problems".
- Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

Possible Cause:
- system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

Possible Solution:
edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

Please do it at your own risk.

How to do it:

METHOD 1

1.- ROOT your device (of course)

2.- Editing the file
You will need a proper editor
Download and Install Total Commander and open it
OR DOWNLOAD BELOW

3.- Browse with Total Commander to root/etc
(hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
Tap mount R/W
Long tap on "hosts" > edit file > Totalcmd-Editor

Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

4.- SAVED

Edited file should look like this:

127.0.0.1 localhost
#74.125.93.113 android.clients.google.com

remember: based on my own observation it should be look like this:

127.0.0.1(just one space)localhost
#74.125.93.113(just one space)android.clients.google.com

5.- Turn OFF your device.
6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
7. Reboot your device.
8. Once the phone reboots, input your google account information when the phone asks for it.
9.- Sync to your account and contacts

METHOD 2:

1. Make sure you have a ROOT ACCESS on your Device.
2. Install Root Explorer, Run App, Grant SU Access.
3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
4.Tap mount R/W
5.Look for host file, long press it and open with text editor.
6. just Add # (pound sign) on the first number.
like this:

#74.125.93.113(just one space)android.clients.google.com

SAVE IT and Reboot.
Now you can connect to Google Play very well.

UPDATE: 08/22/13

If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
and install this app on playstore:
https://play.google.com/store/apps/d...eb.hosts&hl=en

run app and choose your prefer edit.

Another Way Playstore not working after Installing/Uninstalling Freedom App?

- Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
- Reboot
- Shutdown & Boot to Recovery
- Wipe Cache/Dalvik Cache
- Reboot
- Presto! back to normal.

Edit:
Removed Attached Files you may download it on Google Playstore.

Total Commander: https://play.google.com/store/apps/d...TotalCommander

Root Explorer: https://play.google.com/store/apps/d...e.rootexplorer

Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

Download Other File Managers:
Root Browser: http://forum.xda-developers.com/show....php?t=1338582 (Credits to the Devs)
ES Explorer: http://forum.xda-developers.com/show....php?t=2210417 (Credits to the Devs)

Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
Last edited by QYOBZ; 12th May 2014 at 09:34 AM. Reason: attached file
The Following 213 Users Say Thank You to QYOBZ For This Useful Post: [ View ]
23rd January 2013, 02:21 AM   |  #2  
Junior Member
Thanks Meter: 2
 
3 posts
Join Date:Joined: Jul 2012
I read your solution but when i saw my host file there was a different ip address

127.201.26.224 android.clients.google.com
mtalk.google.com

i comment both of them and did what you said but it didn't work the first time
2nd time i did that and it worked


Thanks
Last edited by saif858; 23rd January 2013 at 03:17 AM.
The Following 2 Users Say Thank You to saif858 For This Useful Post: [ View ]
23rd January 2013, 07:00 PM   |  #3  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Sep 2012
THAKS A LOT DUDE !!!!!!! I't works
30th January 2013, 11:28 AM   |  #4  
Member
Flag Bangalore
Thanks Meter: 2
 
33 posts
Join Date:Joined: Jul 2012
Donate to Me
Thumbs up Same Error
Even i have 127.122.124.92 android.clients.google.com mtalk.google.com ip, so did u change this ip to 74. or did u add the new ip below the local host portion???

---------- Post added at 03:58 PM ---------- Previous post was at 03:43 PM ----------

Ok Thanks a lot it really worked now, now this might help for some one if u have the same error as i got. No 74.125.93.113 ip present below local host (127.122.124.92 android.clients.google.com mtalk.google.com ip present ). so just copy this (#74.125.93.113 android.clients.google.com) below 127.0.0.1 localhost , and that worked for me....
3rd February 2013, 10:34 PM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2010
More
Thumbs up Thank You!
Thank you for the info, it worked on my Chines tablet as it stopped working all of a sudden.
I had a feeling that it was something like this, just had no clue how to go about it... and why the hell are they using hard-coded IP addresses anyway???

BTW, just fixing the HOST file and rebooting fixed it for me.
3rd February 2013, 11:43 PM   |  #6  
Senior Member
Flag Paris
Thanks Meter: 10
 
113 posts
Join Date:Joined: Sep 2008
More
THANKS! Browsed all over the net to find a solution to this issue!

Tried many things and was about to decide to sell my GNex and upgrade to nexus 4!

Thanks to this thread and you all I am a happy GNex user again.

Still wonder what happened that changed this file or fckd my system...
The Following User Says Thank You to benjieb For This Useful Post: [ View ]
4th February 2013, 05:44 PM   |  #7  
Senior Member
Flag Paris
Thanks Meter: 10
 
113 posts
Join Date:Joined: Sep 2008
More
Uhhh, didn't work so well. I have access to my google account again (play, gmail, youtube...)

but when I try to update an app or download a new one, I get an error: RPC:S-5:AEC-0


Can anyone help ?


thanks
5th February 2013, 08:53 PM   |  #8  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Nov 2010
Thanks problem solved
Hi I was frustrated for some time over this issue, following your instructions (ES file explorer and editor) solved the problem.
Only corrected the file without factory reset than added one of my accounts.
Thanks again.
20th February 2013, 02:53 PM   |  #9  
Junior Member
Thanks Meter: 4
 
2 posts
Join Date:Joined: Apr 2011
Thumbs up Thanks Alot man !!!
Thanks Alot man !!! it works

here are the steps ( your device must me rooted ) :

1. download total commandar.apk from google
2. Install it in your android mobile
3. open the total commandar from ur android mobile and goto File System root
4. search for the folder etc and open that folder
5. now search for the file name ' hosts ' and click on it .
6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
7. and save it
8. Reboot your device
9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
The Following 4 Users Say Thank You to ahmer47 For This Useful Post: [ View ]
22nd February 2013, 03:49 AM   |  #10  
Junior Member
Flag Jubail
Thanks Meter: 2
 
12 posts
Join Date:Joined: Jan 2012
More
Thanks It worked in my GNote II...It happened to me many times when i flash a new ROM and these is the first time a solution works

The Following User Says Thank You to a4403 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
can't establish, google play, playstore, server error, sync
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes