FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[20 Jan 2014] [KERNEL] Eclipse Kernel 1.4 =LEGENDARY= [ONLINE]

2,019 posts
Thanks Meter: 1,831
 
Post Reply Subscribe to Thread Email Thread
26th January 2013, 09:22 AM |#21  
Retired Recognized Developer
Flag Clausthal-Zellerfeld / Munich
Thanks Meter: 2,357
 
Donate to Me
More
Since you compiled the kernel from source the off-mode alarm is definitely not disabled.
 
 
26th January 2013, 11:10 AM |#22  
Senior Member
Thanks Meter: 97
 
More
Quote:
Originally Posted by Stensfie

I have flashed the zip but no changes for me....boxmax v11+...any idea?

see a couple of posts above yours on how to update by secalpus
26th January 2013, 11:18 AM |#23  
-pixelfreak-'s Avatar
Senior Member
Flag Glashütten
Thanks Meter: 3,354
 
Donate to Me
More
re
i have test this kernel yesterday and no problem with install and no problem with kernel work. for your first kernel is perfect.

good job my friend

many thanks

Pixelfreak
The Following User Says Thank You to -pixelfreak- For This Useful Post: [ View ]
26th January 2013, 11:34 AM |#24  
Dark_Avenger's Avatar
Senior Member
Flag Sofia
Thanks Meter: 311
 
More
I got a problem with the kernel - WiFi Analyzer stop refreshing. Reverting back to original marc's kernel 0.2.3 fixes the problem.
26th January 2013, 12:29 PM |#25  
Retired Recognized Developer
Flag Clausthal-Zellerfeld / Munich
Thanks Meter: 2,357
 
Donate to Me
More
Quote:
Originally Posted by Dark_Avenger

I got a problem with the kernel - WiFi Analyzer stop refreshing. Reverting back to original marc's kernel 0.2.3 fixes the problem.

That might be due to the fact that the bcm4329_204 driver is being used in this kernel. That's a hacked up version by HTC.
The Following User Says Thank You to marc1706 For This Useful Post: [ View ]
26th January 2013, 03:29 PM |#26  
Daekin's Avatar
OP Senior Member
Flag Bratislava
Thanks Meter: 1,831
 
Donate to Me
More
Re: [25 Jan 2013] [KERNEL] Eclipse Kernel 1.0 =LEGENDARY= [ONLINE]
Quote:
Originally Posted by marc1706

Since you compiled the kernel from source the off-mode alarm is definitely not disabled.

Hmm...but in build config the off.ode alarm flag is not set...





Quote:
Originally Posted by Dark_Avenger

I got a problem with the kernel - WiFi Analyzer stop refreshing. Reverting back to original marc's kernel 0.2.3 fixes the problem.

Can you post some logs? Maybe it is fixable.

Sent from my EndeavorU using Tapatalk 2
26th January 2013, 07:39 PM |#27  
Retired Recognized Developer
Flag Clausthal-Zellerfeld / Munich
Thanks Meter: 2,357
 
Donate to Me
More
Quote:
Originally Posted by Daekin

Hmm...but in build config the off.ode alarm flag is not set...

That's the HTC offmode alarm which has nothing to do with the HD2 offmode alarm.
26th January 2013, 08:18 PM |#28  
Daekin's Avatar
OP Senior Member
Flag Bratislava
Thanks Meter: 1,831
 
Donate to Me
More
Re: [25 Jan 2013] [KERNEL] Eclipse Kernel 1.0 =LEGENDARY= [ONLINE]
Ahaa. Thanks for explaining it.

We are always learning.

Btw. I have seen your new branch with bcmdhd...what is the current progress of implentation?

Sent from my EndeavorU using Tapatalk 2
Last edited by Daekin; 26th January 2013 at 08:21 PM.
26th January 2013, 09:52 PM |#29  
Rick_1995's Avatar
Recognized Developer
Whoville
Thanks Meter: 3,060
 
More
Quote:
Originally Posted by marc1706

Since you compiled the kernel from source the off-mode alarm is definitely not disabled.

actually, leo supports RTC_ALARM through both dex and pcom (and the emulated lk version which isn't quite efficient).

Code:
	DEX_SET_ALARM_RTC = 0x84,
	PCOM_SET_RTC_ALARM = 0xD,
but i've tested the PCOM command and it don't seem to work (works totally fine on an old MSM7k device), the current leo kernels already have support for wake_after which uses the pcom command, you could try and swap it with dex and see if it makes any difference.

To test it on your device:

Code:
su
echo 'time' > /sys/module/pm/parameters/wakeup_after
where time = <unknown time spec, MSM7k's unit is seconds but cotulla mentioned it appears to be milliseconds>, I tried 300, 600, 60000. expecting them to be 300s, 600s, 1s resoectively.
Last edited by Rick_1995; 26th January 2013 at 10:19 PM.
The Following 4 Users Say Thank You to Rick_1995 For This Useful Post: [ View ]
26th January 2013, 11:11 PM |#30  
specter16's Avatar
Senior Member
Flag Algiers
Thanks Meter: 36
 
Donate to Me
More
Battery life ?
how is the battery life with this kernel ???
Post Reply Subscribe to Thread

Tags
daekin, kernel, optimized, sense, stable
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes