Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[BOOTLOADER] 2nd-bootloader for Custom ROMs on KFireHD 8.9 [05/27 CM11/TWRP 2.7.x.x]

OP Hashcode

2nd February 2013, 07:24 PM   |  #11  
Hashcode's Avatar
OP Recognized Developer
Thanks Meter: 22,733
 
3,245 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Re: [BOOTLOADER] Install 2nd-bootloader for Custom ROMs on KFireHD 8.9
Quote:
Originally Posted by FroyoShark

Can't get fastboot working...
Tried 2 different 8.9's, with 3 different USB cables on Windows 7 and Linux with each.
EDIT: Nevermind, finally got it working

Awesome, feel free to share any tips.

Sent from my DROID RAZR HD using Tapatalk 2
The Following User Says Thank You to Hashcode For This Useful Post: [ View ]
2nd February 2013, 07:31 PM   |  #12  
FroyoShark's Avatar
Senior Member
Flag South Dakota
Thanks Meter: 30
 
218 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Quote:
Originally Posted by Hashcode

Awesome, feel free to share any tips.

Sent from my DROID RAZR HD using Tapatalk 2

Turns out I could only get it working on Linux using root shell, everything else failed.
2nd February 2013, 08:02 PM   |  #13  
Senior Member
Thanks Meter: 51
 
220 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by Hashcode

If you make a backup in TWRP, you can always restore it later.

Hold off on CM10.1, I'm rebuilding.

Sent from my DROID RAZR HD using Tapatalk 2

do you mean we can back up stock OS and flash it back later, without going through fastboot and keep TWRP with stock OS?
2nd February 2013, 08:09 PM   |  #14  
FroyoShark's Avatar
Senior Member
Flag South Dakota
Thanks Meter: 30
 
218 posts
Join Date:Joined: Sep 2011
Donate to Me
More
After installing CM10.1+ Gapps, it booted to a black screen, so I did a hard reset. Went back into TWRP, wiped system, and flashed just CM10.1. After that, it got stuck on the orange Kindle Fire logo (doesn't get to the blue one) and even reflashing the bootloader/recovery doesn't fix it.
EDIT: Tried restoring my system backup from the stock ROM, that didn't work either. Restoring the stock boot image makes it so I can boot into the stock ROM though.


EDIT 2: Must have done something wrong. It's working fine again, but CM10.1 still doesn't work.
Last edited by FroyoShark; 2nd February 2013 at 08:51 PM.
2nd February 2013, 11:08 PM   |  #15  
Hashcode's Avatar
OP Recognized Developer
Thanks Meter: 22,733
 
3,245 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Quote:
Originally Posted by FroyoShark

After installing CM10.1+ Gapps, it booted to a black screen, so I did a hard reset. Went back into TWRP, wiped system, and flashed just CM10.1. After that, it got stuck on the orange Kindle Fire logo (doesn't get to the blue one) and even reflashing the bootloader/recovery doesn't fix it.
EDIT: Tried restoring my system backup from the stock ROM, that didn't work either. Restoring the stock boot image makes it so I can boot into the stock ROM though.


EDIT 2: Must have done something wrong. It's working fine again, but CM10.1 still doesn't work.

When re-setting up the Kindle for the 2nd-bootloader, PLEASE re-review the steps in the OP, I added a missing step later after the original posting.

(It's the disabling of the "install-recovery.sh" file)
3rd February 2013, 12:18 AM   |  #16  
FroyoShark's Avatar
Senior Member
Flag South Dakota
Thanks Meter: 30
 
218 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Quote:
Originally Posted by Hashcode

When re-setting up the Kindle for the 2nd-bootloader, PLEASE re-review the steps in the OP, I added a missing step later after the original posting.

(It's the disabling of the "install-recovery.sh" file)

Yeah, that's how I got it working. Also, there's a typo in the OP, you put "fastboot -i 0x1949 flash recovery kdh8-twrp-2.3.3.0-recovery.img" instead of "fastboot -i 0x1949 flash recovery kfhd8-twrp-2.3.3.0-recovery.img"
3rd February 2013, 12:24 AM   |  #17  
Hashcode's Avatar
OP Recognized Developer
Thanks Meter: 22,733
 
3,245 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Re: [BOOTLOADER] Install 2nd-bootloader for Custom ROMs on KFireHD 8.9
Guh. I actually fixed (or thought I did) that typo last night. Ah well, I re-editted it just now and it looks like it took.

Thanks for pointing that out.

Sent from my DROID RAZR HD using Tapatalk 2
3rd February 2013, 01:27 AM   |  #18  
FroyoShark's Avatar
Senior Member
Flag South Dakota
Thanks Meter: 30
 
218 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Is TWRP extremely choppy for everyone else?
3rd February 2013, 02:40 AM   |  #19  
Hashcode's Avatar
OP Recognized Developer
Thanks Meter: 22,733
 
3,245 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Re: [BOOTLOADER] Install 2nd-bootloader for Custom ROMs on KFireHD 8.9
it is a little slow to respond. i built it with a custom kernel a while back.

i may try either an updated kernel or using stock kernel to see if it helps.

Sent from my DROID RAZR HD using Tapatalk 2
3rd February 2013, 03:08 AM   |  #20  
FroyoShark's Avatar
Senior Member
Flag South Dakota
Thanks Meter: 30
 
218 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Quote:
Originally Posted by Hashcode

it is a little slow to respond. i built it with a custom kernel a while back.

i may try either an updated kernel or using stock kernel to see if it helps.

Sent from my DROID RAZR HD using Tapatalk 2

That would be nice. It's not a big issue, but it's a bit annoying.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes