Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,031 Members 45,199 Now Online
XDA Developers Android and Mobile Development Forum

[Kernel][Sense 4] crpalmer | August 25, 2013

Tip us?
 
pio_masaki
Old
#101  
pio_masaki's Avatar
Recognized Contributor
Thanks Meter 3601
Posts: 4,513
Join Date: May 2012
Location: Surprise, Az

 
DONATE TO ME
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

Just wondering, anyone else notice headset being ignored when plugged in? It happened before, never happened on the no oc kernel, but is happening again on 1.0.8.

36 hours on 1.0.8 and good, besides that headset switching thing. Ill try the new one and see if its still there.

Tapatalked from my HTC DNA
A100
Guide: All things Iconia A100 | Jellytime Sosei | Carbon
Droid DNA
PAC-Man | Carbon | ReVolt | Chameleon OS | MoKee OS | IOAP
VZW LG G2
ReVolt | Carbon | IOAP
TF300T
Carbon
Nexus 7
Carbon
Thank you to those that donated, it's greatly appreciated!
 
crpalmer
Old
#102  
Senior Member - OP
Thanks Meter 1983
Posts: 1,511
Join Date: Mar 2011

 
DONATE TO ME
Quote:
Originally Posted by pio_masaki View Post
Just wondering, anyone else notice headset being ignored when plugged in? It happened before, never happened on the no oc kernel, but is happening again on 1.0.8.

36 hours on 1.0.8 and good, besides that headset switching thing. Ill try the new one and see if its still there.
Glad to hear that it's going well in terms of stability. I'm not sure what you mean by the headset being ignored. Can you explain what exactly you're doing (with what hardware?) and what it is doing and what it should be doing instead?
 
pio_masaki
Old
#103  
pio_masaki's Avatar
Recognized Contributor
Thanks Meter 3601
Posts: 4,513
Join Date: May 2012
Location: Surprise, Az

 
DONATE TO ME
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

Quote:
Originally Posted by crpalmer View Post
Glad to hear that it's going well in terms of stability. I'm not sure what you mean by the headset being ignored. Can you explain what exactly you're doing (with what hardware?) and what it is doing and what it should be doing instead?
I have a wired headset, think its from my old gs2, anyways normally plugging it in works instantly and perfectly, however only on your OC kernels its ignored, plug it in, nothing happens, no icon, audio route stays on speaker like its not plugged in. Repeated plug and unplug will eventually get it working, but that's kind of a pointless strain on the jack.

It worked on stock, UKB, viper, all kernels I've tried ( not many ) and your no oc, all instantly switched to headset, each OC kernel I've tried doesn't, though, which is what strikes me as rather odd. Just wondering if anyone else has seen this, I'm probably the only wired headset user on xda so I doubt it. Ill see what logcat has to say about it when I get some time to mess with it again if you'd like. It may be intermittent and just didn't show up on the no oc kernel, I doubt the code changes involved audio.

Note, I saw this first occur on UKB, and last night it happened on viper. Flashing another kernel seems to resolve the issue. Its a minor issue, one I can live with on this kernel.

Good news is even with min at 192 and -100 UV across the board the phone hasn't rebooted yet.

Figures I find a kernel I'm happy with and I have the only phone in the world that doesn't get along with it.

Tapatalked from my HTC DNA
A100
Guide: All things Iconia A100 | Jellytime Sosei | Carbon
Droid DNA
PAC-Man | Carbon | ReVolt | Chameleon OS | MoKee OS | IOAP
VZW LG G2
ReVolt | Carbon | IOAP
TF300T
Carbon
Nexus 7
Carbon
Thank you to those that donated, it's greatly appreciated!
 
KyJelly69
Old
#104  
Senior Member
Thanks Meter 116
Posts: 566
Join Date: Apr 2010
Location: Indianapolis
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

I know you have no interest in including s2w at this point but fwiw I vote a big +1.

Sent from my HTC6435LVW using xda app-developers app
Verizon HTC Droid DNA (S-OFF)(Hboot 1.54.0000)(TWRP 2.7.0.0)(Radio 1.01.01.1112) - CodefireX (jamiethemorris 5.6.4)
The Following 3 Users Say Thank You to KyJelly69 For This Useful Post: [ Click to Expand ]
 
crpalmer
Old
#105  
Senior Member - OP
Thanks Meter 1983
Posts: 1,511
Join Date: Mar 2011

 
DONATE TO ME
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

Quote:
Originally Posted by pio_masaki View Post
I have a wired headset, think its from my old gs2, anyways normally plugging it in works instantly and perfectly, however only on your OC kernels its ignored, plug it in, nothing happens, no icon, audio route stays on speaker like its not plugged in. Repeated plug and unplug will eventually get it working, but that's kind of a pointless strain on the jack.
I found a headset from an older phone and unfortunately it seems to work fine for me. Do you have another headset to try? Want mine?
 
crpalmer
Old
#106  
Senior Member - OP
Thanks Meter 1983
Posts: 1,511
Join Date: Mar 2011

 
DONATE TO ME
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

Quote:
Originally Posted by KyJelly69 View Post
I know you have no interest in including s2w at this point but fwiw I vote a big +1.
Unfortunately for me, my IT department requires an 8 digit password with numbers, lower and uppercase letters. Whether or not I have to hit the power button doesn't change much...

DSB almost convinced me it was stable enough to just add it. But zarboz said he wanted to submit a fix and I see people with issues.

If it seems really stable or someone wants to maintain it, I am fine adding it.
The Following 3 Users Say Thank You to crpalmer For This Useful Post: [ Click to Expand ]
 
pio_masaki
Old
#107  
pio_masaki's Avatar
Recognized Contributor
Thanks Meter 3601
Posts: 4,513
Join Date: May 2012
Location: Surprise, Az

 
DONATE TO ME
Default Re: [Kernel] [Feb 22] crpalmer's [Linaro 4.8 -O3] [Linux 3.4.33][hotplug, thermald, e

Quote:
Originally Posted by crpalmer View Post
I found a headset from an older phone and unfortunately it seems to work fine for me. Do you have another headset to try? Want mine?
Lol ill try some other stuff and see what happens, its just never happened before or after the oc kernels.

Go figure just plugged it in, worked perfectly. Guess my DNA is just really touchy.

Edit: on 1.0.11 now, maybe that's why it worked, it likes this kernel

Tapatalked from my HTC DNA
A100
Guide: All things Iconia A100 | Jellytime Sosei | Carbon
Droid DNA
PAC-Man | Carbon | ReVolt | Chameleon OS | MoKee OS | IOAP
VZW LG G2
ReVolt | Carbon | IOAP
TF300T
Carbon
Nexus 7
Carbon
Thank you to those that donated, it's greatly appreciated!
 
t1gartist
Old
#108  
Senior Member
Thanks Meter 287
Posts: 633
Join Date: Dec 2012
Location: newport news
https://github.com/tigartist/dlx-kernel.git thats the error it just wont get past the scripts/mods

and as you cant see i deleted the repo complete and re synced it into a folder same issue
 
crpalmer
Old
#109  
Senior Member - OP
Thanks Meter 1983
Posts: 1,511
Join Date: Mar 2011

 
DONATE TO ME
Quote:
Originally Posted by t1gartist View Post
https://github.com/tigartist/dlx-kernel.git thats the error it just wont get past the scripts/mods

and as you cant see i deleted the repo complete and re synced it into a folder same issue
Oh, I screwed you up there. In the code pushed up to git, I switched to a Linaro 4.8 toolchain being built by a nexus7 developer (sparksco). Change the makefile to use linaro-4.7 (make sure that the cross-compile points to your toolchain) and try again?
The Following User Says Thank You to crpalmer For This Useful Post: [ Click to Expand ]
 
t1gartist
Old
(Last edited by t1gartist; 25th February 2013 at 01:05 AM.)
#110  
Senior Member
Thanks Meter 287
Posts: 633
Join Date: Dec 2012
Location: newport news
ok i got that fixed everything went great. i fixed abootimg error and bam it compiled wonderful. and i didnt know all i had to do was mod makefile to compile with different linaro builds

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes