Post Reply

Touch Screen working but backlight is really dim! HELP!:(

20th February 2013, 06:53 AM   |  #1  
OP Junior Member
Brampton
Thanks Meter: 0
 
5 posts
Join Date:Joined: Feb 2011
So, a few days ago i received my xperia arc s housing in the mail from ebay, So the next thing i do is replace the housing and put it back together, Its all working but i notice the back button not working, open the phone up again and mess around a bit while the battery was still in the phone, but then the screen stopped working, and i just put it back together cause i couldn't do anything about it. The touch screen works but it doesn't not display anything, i can start up the phone and unlock the screen and feel the vibrations but the display is really dim, like if i take a flashlight and put it over the screen, i can see everything but when i take the flashlight away i cant see anything, The LEDs near in the home buttons are not working either. What some one did suggest is that the chip that controls the LED's are at fault and damaged. Any other suggestions would be highly appreciated.

Thank You
22nd February 2013, 07:22 AM   |  #2  
showlyshah's Avatar
Senior Member
Flag kerala
Thanks Meter: 542
 
792 posts
Join Date:Joined: Mar 2011
More
Re: Touch Screen working but backlight is really dim! HELP!:(
U must check the flex cable to the display, ( make sure u do disconnect and reconnect it with out battery) ,reinsert batt and then check.
U must check if u have damaged any flex cable or left any scratch marks on any circuit boards etc which may cause any damage to the signal/supply lines.( use a magnifying glass)
U must check for some damaged components like smd resistor,capacitor etc..
If nothing helps, gave it to authorized service center.

Sent from my NexusHD2 using xda premium
24th February 2013, 06:00 PM   |  #3  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by showlyshah

U must check the flex cable to the display, ( make sure u do disconnect and reconnect it with out battery) ,reinsert batt and then check.
U must check if u have damaged any flex cable or left any scratch marks on any circuit boards etc which may cause any damage to the signal/supply lines.( use a magnifying glass)
U must check for some damaged components like smd resistor,capacitor etc..
If nothing helps, gave it to authorized service center.

Sent from my NexusHD2 using xda premium

^^ Its probably the cable, check all your connections, and buy a test light or little multimeter for a few bucks to make sure everything is getting power.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes