Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,519 Members 37,959 Now Online
XDA Developers Android and Mobile Development Forum

How to root GoClever tablet (TAB R974.2,Rockchip 3066)

Tip us?
 
StarchiId
Old
(Last edited by StarchiId; 27th April 2013 at 10:35 PM.)
#1  
StarchiId's Avatar
Junior Member - OP
Thanks Meter 5
Posts: 7
Join Date: Mar 2013
Tablet How to root GoClever tablet (TAB R974.2,Rockchip 3066)

I searched around for a few days and tried dozens of ways to crack this baby's root. It was a tough ride and it took me a lot of nerves to keep searching but it did pay off.

The GoClever R974.2 is a rebranded Rockchip 3066 made for the Eastern European market. It's fairly cheap and offers great performance,great set of features and full Google implementation for a very affordable price. I love it.

I tried rooting it with the ICS Root Unlocker 1.0 from sourceforge - but it did not do the trick. Actually, it did it but only partially. A Superuser app was installed, however there was no root access and Superuser wouldn't uninstall either. I did a factory data reset but superuser was still there for some reason
One thing I noticed is that I can't access the recovery mode, but I think this is another problem which is bound to either the bios or firmware settings and which does not really have anything to do with the rooting. I will make another thread on that when I find a solution.
So yeah I just decided to keep searching and it was not a big surprise to find the solution to root my Chinese tablet is a Chinese program - which only leads me to one conclusion - Chinese people are awesome, but why did they have to make their writing so funking hard to read?

So here's what you need to root this baby via Windows 7 (I did it on 64x but should work on 32x too):

1. Enable USB Debugging and (Settings > Developer Options > USB Debugging) and enable installation of apps from unknown sources (Settings > Security > Unknown Sources).

2. Plug in your device via USB. Open device manager (Control Panel > Device manager). Your tablet should be under "Other Devices > GOCLEVER" since windows can't find a driver for this tablet. You have to install the driver manually. Download the Google usb drivers here:
http://www5.zippyshare.com/v/32478689/file.html
This is a pack of the original Google drivers and a modified version for GoClever, use the original google first and if it doesn't work, try the modified version. Unpack the drivers into a folder.
To install, right click on the GOCLEVER entry in the device manager and click "Update Driver Software...", on the window that opens click "Browse my computer for driver software" then on the next screen click "Let me pick from a list of device drivers from my computer".
On the next screen choose the entry "Show all devices" and click Next. Click the button "Have disk" and on the window that opens click "Browse" find the folder where you have previously unpacked the drivers and point to the directory you want to use (within the folder you unpacked the drivers into choose between either "usb_driver" or "goclever") and choose the file "android_winusb" and click Open,and then click Ok. Choose the entry "Android Composite ADB interface" from the list and click "Next", wait for the installation to finish. The device manager should now have an entry in "Android Phones > Android Composite ADB interface". This is good and means Windows can see the device and we can move on.

3. Keep your tablet plugged into the PC. Download a Chinese program called ZhuoDashi from here:
http://www.multiupload.nl/5L8T1YRAC6
Run ZhuoDaShi installation. It's in chinese but you'll be ok, just keep clicking where the Next button should be.
EDIT: BEFORE RUNNING THE PROGRAM, PLEASE UNINSTALL BLUESTACKS IF YOU HAVE IT INSTALLED. If you have bluestacks installed on your PC, the root program will conflict when trying to root your real device and it will not work. This is probably the case for most Android emulators so uninstall them before attempting to root your goclever tab. Also, temporarily disable security programs like antivirus, anti-spyware or firewall software because those might also interfere.

After the installation, run the program (it's set to run automatically after installation by default). It will detect the device automatically. Under the picture of the device look at the red text that says "Root" and click the blue link beside it.


Wait for it to finish and voila - you should now have root access!
You can also unroot the device via this program by clicking the orange wrench and screwdriver icon (sixth icon from the left). There will be 2 pirate android icons with the word ROOT contained in the writing below it. The left one is for rooting,the right one is for unrooting.

4. Now you will have an app installed called SuperSU and this is of course the superuser app. However, you will not be able to use this app to have full root access since it's SU.apk is outdated and won't let you manipulate files in the system folder. However, do not uninstall it just yet as it is still useful to grant superuser access, which you will need to install a second newer Superuser app which will update the SU.apk. So now pen the market and find the the app called "Superuser" (by Clockworkmod), then download and install it. Open the app and grant it root access when it requests it via SuperSU and it will then ask you to update the SU so agree to that too and click on install.
Now Superuser (by Clockworkmod) will be the default app managing root access.
If you wish to remove the old SuperSU app, open it and let it update the SU again, then go to settings and click "change superuser app", it will offer to remove itself, agree to that and it should now be gone. Start up Superuser (by Clockworkmod) again and let it install the updated SU again. There,now it should work.

FINALLY your tablet is rooted! HALLELLUYAH! Praise the droid!

I've patched this method together from a ton of forum and blog posts, I don't know all the sources so sorry about that, I hope it works for you!
The Following 2 Users Say Thank You to StarchiId For This Useful Post: [ Click to Expand ]
 
zam123
Old
(Last edited by zam123; 20th April 2013 at 10:40 AM.)
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Apr 2013
Quote:
Originally Posted by StarchiId View Post
Now you will have an app installed called SuperSU
Hi there, for me it seemed to update via the Chinese app successfully (progress bar went to end, and green writing showed after), but I see no SuperSU app installed.

However, I do see the blue Chinese app installed (blue logo with silver object inside it).


Update:

(1) Installed Root Validator and a terminal emulator.
(2) Ran Root Validator test, and it shows a location for a superuser app /data/app/com.koushikdutta.superuser-1.apk
(3) However, when I try to access it via the terminal is says permission denied.
(4) Also according to Root Validator, the su binary is not found.
 
zam123
Old
#3  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Apr 2013
W00t, got it rooted.

(1) Reset to factory default
(2) Try Chinese root app
(3) Goto (1)

...on 4th attempt it worked
 
mellojamie
Old
(Last edited by mellojamie; 19th May 2013 at 07:14 PM.)
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2013
Default Go Clever 76.2 ROOT

Hi Guys,
i am in no way a developer, im a complete noob, i once did jailbreak on my sons ipod touch, thats the extent of my experience, however, we recently got him a Go Clever 76.2 tab, and 1 or 2 apps havent installed due to no root access, i tried one click rooting and it never worked, do you think the above mentioned method would work with this model, i only ask as i noticed one of the packages to d-load wasnt for his model, it is 7500 i think.., if you think i would be safer taking it to a shop or not botheering i will defer to your judgement, its just a bit of 'its there so i want to do it ' on my behalf !
Also, the drivers package to download as the pc wont recognize the device, well my pc does recognize it, it comes up in the device section, or is that something different ?
Sorry for being clueless , thanks for any advice


EDIT- After some more tinkering, the Android Composite ADB shows up in my device manager, but the chinese programme wont proceed, still waiting on the pic of tablet/option to root to appear
 
Shmarkus
Old
#5  
Shmarkus's Avatar
Member
Thanks Meter 26
Posts: 84
Join Date: Sep 2011
Location: Tallinn

 
DONATE TO ME
Default R70 root working

I did a combo of this tutorial and http://forum.xda-developers.com/show....php?t=2272266 this one.

If youre familiar with adb, then the latter should work from the start!
 
sebakol9
Old
#6  
Junior Member
Thanks Meter 0
Posts: 22
Join Date: Feb 2010
It working..My go clever r104 rooted already.How to flash recovery? I would like flash custom ROM.

Sent from my TAB R104 using Tapatalk
 
Shmarkus
Old
#7  
Shmarkus's Avatar
Member
Thanks Meter 26
Posts: 84
Join Date: Sep 2011
Location: Tallinn

 
DONATE TO ME
Quote:
Originally Posted by sebakol9 View Post
It working..My go clever r104 rooted already.How to flash recovery? I would like flash custom ROM.

Sent from my TAB R104 using Tapatalk
Hi,

try this: http://forum.xda-developers.com/show....php?t=2612105
 
EsEmDee
Old
#8  
Junior Member
Thanks Meter 0
Posts: 20
Join Date: Jun 2014
Talking Works for other GoClever tablets as well?

Hi friends. I really wasn't expecting for this tablet to be possible to root, very happy to see that it is! My question: Is the method of rooting using this tutorial only limited to the GoClever R974.2, cause I have a GoClever Terra 72 and want to root it(and since I'm still under waranty, unroot it incase I need to :P). I'm still very much a noob in rooting and things alike, so I hope I can get a bit of help. Thanks!
 
qawtara
Old
#9  
qawtara's Avatar
Junior Member
Thanks Meter 1
Posts: 10
Join Date: Jun 2009
Location: Tbilisi
What About goClever Tab R104 ? Has Anyone Tested It On Other Devices ?
Samsung Note 3 N900 [32GB] + SanDisk Ultra 32 GB MicroSDHC C10/UHS1
 
EsEmDee
Old
#10  
Junior Member
Thanks Meter 0
Posts: 20
Join Date: Jun 2014
Quote:
Originally Posted by qawtara View Post
What About goClever Tab R104 ? Has Anyone Tested It On Other Devices ?
I tried it for mine, and it probably would have worked (the rooting software), but the drivers aren't for my tablet, that's why it didn't. Now, where to get drivers that don't exist? (Seriously, I've looked and lookds, there are just NO drivers for the Terra 72 D.

So if you don't have the drivers for your specific tablet, it will not work, at least I think it won't. You can just try it yourself.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes