Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

T-Mobile - US APN settings

OP bertscookie

18th April 2013, 04:36 PM   |  #1  
bertscookie's Avatar
OP Senior Member
Flag Buffalo, NY
Thanks Meter: 80
 
314 posts
Join Date:Joined: Dec 2010
More
Mods if you think this should be in a different location feel free to move it. Also I'd like to see a sticky APN thread, because apparently google is too hard to use.

I thought I'd post this because it comes up alot and there isn't a single place this information sits(as far as I could found in my searches). Also I have to find them all over again when it comes up. So here it is.

The KB from T-Mobile:
http://support.t-mobile.com/docs/DOC-1979

Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.t-mobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set> [T-Mobile states for the MT4G/Glacier to enter "None" (without quotes) for this and to NOT leave this as <Not set>]
Password: <Not set>
Server: <Not set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310
MNC: 260
Authentication type: <Not set>
APN type: default,supl,admin,dun,mms <-- Specified for MT4G otherwise --> <Not Set> OR Internet+MMS (depending on software version)
If you find yourself not able to send MMS messages it is most likely because the proxy,port,username,password fields are not <Not Set>. Just tap these values and delete any information in them. I always restart but not always necessary.

Some people enter 216.155.165.50 for the MMS Proxy and 8080 for MMS Port I have never had to and am not exactly why these values might be needed but try them if the T-Mobile settings don't work.
Last edited by bertscookie; 26th August 2013 at 09:22 PM. Reason: Correctness
The Following 17 Users Say Thank You to bertscookie For This Useful Post: [ View ]
19th April 2013, 03:38 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Mar 2013
Thumbs up thx
just what I was looking for
30th April 2013, 11:22 PM   |  #3  
aliamin86's Avatar
Senior Member
Flag newyork
Thanks Meter: 15
 
142 posts
Join Date:Joined: Oct 2008
More
Quote:
Originally Posted by bertscookie

Mods if you think this should be in a different location feel free to move it. Also I'd like to see a sticky APN thread, because apparently google is too hard to use.

I thought I'd post this because it comes up alot and there isn't a single place this information sits(as far as I could found in my searches). Also I have to find them all over again when it comes up. So here it is.

The KB from T-Mobile:
http://support.t-mobile.com/docs/DOC-1979

Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.tmobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310
MNC: 260
Authentication type: <Not set>
APN type: <Not Set> OR Internet+MMS (depending on software version)
If you find yourself not able to send MMS messages it is most likely because the proxy,port,username,password fields are not <Not Set>. Just tap these values and delete any information in them. I always restart but not always necessary.

Some people enter 216.155.165.50 for the MMS Proxy and 8080 for MMS Port I have never had to and am not exactly why these values might be needed but try them if the T-Mobile settings don't work.

The mms proxy and port is the old settings for Simple Mobile

Sent from my HTC Glacier using xda app-developers app
The Following User Says Thank You to aliamin86 For This Useful Post: [ View ]
11th June 2013, 03:58 AM   |  #4  
dannieloco's Avatar
Senior Member
Flag Long Beach, CA
Thanks Meter: 139
 
562 posts
Join Date:Joined: Jul 2012
More
I wonder if these settings might help S3 phones get LTE :/
15th June 2013, 08:36 PM   |  #5  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2013
I have been trying to get an ATT GS2 - I777 that is rooted and unlocked running on tmobile to accept and receive photos with texts for a week with no luck. I have used the settings provided by T-Mobile with no luck. I am running ICS though and it has a couple different settings. Any idea if that is what is causing it not to work. I can send regular text fine but it dies if you try to send or receive an image. Sending an image shows sending and it never goes. If I try to send from another carrier to this phone it comes back with a failed message in about 5 minutes.

The KB from T-Mobile:


Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.tmobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: had to remove due to spam filter.
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310 
MNC: 260
Authentication type: <Not set>
APN type: <Not Set> OR Internet+MMS (depending on software version)
First I have Use Packet Data and Data Roaming checked.
Then I got to APNs
There is NO MMS protocol listed
APN Type shows Internet+MMS+SUPL or each listed individually.

Then APN Protocol is IPv4 or IPv6 or both together.
APN Protocol when roaming also shows IPv4 or IPv6 or both together.

Then APN enabled has a grayed out check box that I can't select. Shows APN enabled.

Last is bearer - LTE or eHRPD or Unspecified.
17th June 2013, 02:50 AM   |  #6  
bertscookie's Avatar
OP Senior Member
Flag Buffalo, NY
Thanks Meter: 80
 
314 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by x_789

I have been trying to get an ATT GS2 - I777 that is rooted and unlocked running on tmobile to accept and receive photos with texts for a week with no luck. I have used the settings provided by T-Mobile with no luck. I am running ICS though and it has a couple different settings. Any idea if that is what is causing it not to work. I can send regular text fine but it dies if you try to send or receive an image. Sending an image shows sending and it never goes. If I try to send from another carrier to this phone it comes back with a failed message in about 5 minutes.

The KB from T-Mobile:


Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.tmobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: had to remove due to spam filter.
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310 
MNC: 260
Authentication type: <Not set>
APN type: <Not Set> OR Internet+MMS (depending on software version)
First I have Use Packet Data and Data Roaming checked.
Then I got to APNs
There is NO MMS protocol listed
APN Type shows Internet+MMS+SUPL or each listed individually.

Then APN Protocol is IPv4 or IPv6 or both together.
APN Protocol when roaming also shows IPv4 or IPv6 or both together.

Then APN enabled has a grayed out check box that I can't select. Shows APN enabled.

Last is bearer - LTE or eHRPD or Unspecified.

Well I would keep it ipv4. If you can leave any extra settings blank do that. Definitely use APN.

Have you tried leaving everything blank or "not set" except for the servers? The MMS issue is definitely your APN settings.


Sent by the power of Ra
20th June 2013, 01:31 AM   |  #7  
SBGS-FTW's Avatar
Member
Thanks Meter: 18
 
82 posts
Join Date:Joined: Apr 2012
More
Try APN name "T-Mobile US". Everything as shown in the article.

Sent from my Nexus 4 using Tapatalk 4 Beta
20th June 2013, 07:17 AM   |  #8  
Junior Member
Thanks Meter: 3
 
1 posts
Join Date:Joined: Jun 2013
Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.tmobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: had to remove due to spam filter.
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310 
MNC: 260
Authentication type: <Not set>
APN type: <Not Set> OR Internet+MMS (depending on software version)
i believe this may be wrong. the apn fast.tmobile.com should be fast.t-mobile.com
same with epc.tmobile.com (epc.t-mobile.com)
it would not work for me without the dash. (made an account just to post this found with google)
The Following 3 Users Say Thank You to kulcris For This Useful Post: [ View ]
20th June 2013, 05:47 PM   |  #9  
bertscookie's Avatar
OP Senior Member
Flag Buffalo, NY
Thanks Meter: 80
 
314 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by kulcris

Code:
APN settings laid out in the KB:
Name: T-Mobile
APN: epc.tmobile.com or fast.tmobile.com (for LTE devices)
Proxy: <Not set>
Port: <Not set>
Username: <Not set>
Password: <Not set>
Server: <Not set>
MMSC: had to remove due to spam filter.
MMS proxy: <Not set>
MMS port: <Not set>
MMS protocol: WAP 2.0
MCC: 310 
MNC: 260
Authentication type: <Not set>
APN type: <Not Set> OR Internet+MMS (depending on software version)
i believe this may be wrong. the apn fast.tmobile.com should be fast.t-mobile.com
same with epc.tmobile.com (epc.t-mobile.com)
it would not work for me without the dash. (made an account just to post this found with google)

I always have used. epc.tmobile.com however the mmsc uses the T-Mobile.com domain. I can upload screenshots of mine but they are there same as the document. However the name is "T-Mobile US" but I don't think that matters.

Sent by the power of Ra
8th July 2013, 07:30 PM   |  #10  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
my tmobile s3 all messed up
Hey guys,

I just recently bought a version samsung galaxy s3, with a sim card slot. I now use it with t-mobile and it works fine, cant call, send texts, browse internet and e.t.c. I have one problem with the text messaging, i cant receive pic messaging and i dont know why. The message comes to me as a multimedia file, but i press download, and it just tries to download, without making any progress. Can anyone help?

Post Reply Subscribe to Thread

Tags
apn, apn settings, mms, settings
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes