TWRP 2.8.3.0 Available for Supported Devices

The TeamWin Recovery Project (or TWRP, for short) has quickly become one of the most popular … more

Easily Generate and Export Material Design Palletes

For many people, it can be pretty difficult to create a palette of complementary colors. … more

Android One Expanding to Bangladesh, Nepal, and Sri Lanka

At Google I/O 2013, Google proudly announced that the Android operating system was … more

Android 5.0.2 Fixes 2012 Nexus 7! Sony’s Making a Google Glass Competitor? – XDA TV

Android 5.0.2 Lollipop is available for the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Problem to root XT910 JB with Easy Way

OP Nono-Skorium

4th May 2013, 03:58 AM   |  #1  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
Hi guys,

I used the virtual machine to root my JB on my RAZR (XT910). The process give me a succefull message but when I open SuperUser application. I have a message to install the app.
Quote:

INSTALL: The Superuser (su) must be updated. Please choose an installation method. Recovery mode installation is recommended for HTC devices.

I have choice between "Recovery Install" and "Install" but when I choose one or the other one, I have this message.
Quote:

INSTALL: There was an error installing Superuser. Please send a log of the error to the developer.

I have not a log in the app. I don't know maybe the root didn't work.

Somebody have an idea to fix that?

PS: I havn't the right to ask this on the topic "Root XT910 Jelly Bean (EASY way)".

Thanks for your help.
4th May 2013, 04:09 AM   |  #2  
Senior Member
Flag Oregon
Thanks Meter: 99
 
317 posts
Join Date:Joined: Mar 2012
More
Have you tried just downloading it from the playstore, if it says already installed, uninstall it, then reinstall it.

Sent from my DROID RAZR using xda app-developers app
4th May 2013, 04:28 AM   |  #3  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
The problem is always here. I tried with other superuser app, but I have a message the binary isn't installed. So, I think I need to use "SuperUser app" installed with the method, but it doesn't work.

Quote:

More information about my phone:
System version: 982.184.14.XT910.Retail.en.FR
Model number: XT910
Android version: 4.1.2
Baseband version: U_04.10.00R
Webtop version: wt-3.0.0
Kernel version: 3.0.8-g7198280
Buid number: 9.8.2O-124_SPUEM-14

The "USB debugging" and "Unknown sources" are enabled.
4th May 2013, 04:23 PM   |  #4  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
No idea? Because, I read a lot of topics but obviously I m alone with this problem. I will try to flash with an another firmware.
Quote:

Branding: Retail British
Version: 9.8.2O-124_SPUEM-14 FULL
Android Version: 4.1.2

EDIT 1:
And retry to to root. But I will like to know why the root don't work on my RAZR... It's very weird.

The problem is always here! I don't understand... Look the picture, it's OK but when I install Ad Away (for exemple), a popup says my phone isn't rooted.

EDIT 2:
Quote:

Quote:

Very nice! But I have one problem, after every reboot it tells me SU binary need to be updated, how can i fix this?
Update by wifi

Or
You press hardware button when phone vibrated? During rooting?

Ok, I can try this. But when I need to press the button? After the vibration?
Attached Thumbnails
Click image for larger version

Name:	virtualbox.jpg
Views:	102
Size:	42.7 KB
ID:	1935092  
Last edited by Nono-Skorium; 4th May 2013 at 05:52 PM.
6th May 2013, 03:37 AM   |  #5  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
Nobody know why some people have this problem? Time is very long, very very long... We need to root our phone

Sent from my XT910 using xda premium
6th May 2013, 10:26 PM   |  #6  
Luisit0's Avatar
Senior Member
Flag San Juan
Thanks Meter: 608
 
2,943 posts
Join Date:Joined: Mar 2011
More
well, at least ur phone has something... in my case, it didnt get to recognize my phone! it stayed on * daemon started successfully * and doesnt continue... drivers installed fine when I plugged my phone to the PC, so I'm clueless as to what I can do here...
7th May 2013, 02:22 AM   |  #7  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
tDiveste later
Have you check the USB Settings in VirtualBox. Maybe, it's just that? I don't know.

It's always impossible for me to root my RAZR... I try with my VM on Debian, but the phone don't find the VM with the remote storage. The IP address is correct (192.168.1.XX) but the connection is not established.

Maybe we need a "oneclick tool" to root the phone, I hope that this tool is almost ready
23rd May 2013, 08:43 PM   |  #8  
OP Junior Member
Flag Dublin
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
More
My phone is rooted with success. But I didn't use Easy Way VM. I made a virtual machine with Debian and I followed the main tutorial with Ubuntu.

Sent from my XT910 using xda premium

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes