Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,799 Members 47,745 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem to root XT910 JB with Easy Way

Tip us?
 
Nono-Skorium
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
Default [Q] Problem to root XT910 JB with Easy Way

Hi guys,

I used the virtual machine to root my JB on my RAZR (XT910). The process give me a succefull message but when I open SuperUser application. I have a message to install the app.
Quote:
INSTALL: The Superuser (su) must be updated. Please choose an installation method. Recovery mode installation is recommended for HTC devices.
I have choice between "Recovery Install" and "Install" but when I choose one or the other one, I have this message.
Quote:
INSTALL: There was an error installing Superuser. Please send a log of the error to the developer.
I have not a log in the app. I don't know maybe the root didn't work.

Somebody have an idea to fix that?

PS: I havn't the right to ask this on the topic "Root XT910 Jelly Bean (EASY way)".

Thanks for your help.
 
Draxin
Old
#2  
Senior Member
Thanks Meter 97
Posts: 317
Join Date: Mar 2012
Location: Oregon
Have you tried just downloading it from the playstore, if it says already installed, uninstall it, then reinstall it.

Sent from my DROID RAZR using xda app-developers app
 
Nono-Skorium
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
The problem is always here. I tried with other superuser app, but I have a message the binary isn't installed. So, I think I need to use "SuperUser app" installed with the method, but it doesn't work.

Quote:
More information about my phone:
System version: 982.184.14.XT910.Retail.en.FR
Model number: XT910
Android version: 4.1.2
Baseband version: U_04.10.00R
Webtop version: wt-3.0.0
Kernel version: 3.0.8-g7198280
Buid number: 9.8.2O-124_SPUEM-14
The "USB debugging" and "Unknown sources" are enabled.
 
Nono-Skorium
Old
(Last edited by Nono-Skorium; 4th May 2013 at 04:52 PM.)
#4  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
No idea? Because, I read a lot of topics but obviously I m alone with this problem. I will try to flash with an another firmware.
Quote:
Branding: Retail British
Version: 9.8.2O-124_SPUEM-14 FULL
Android Version: 4.1.2
EDIT 1:
And retry to to root. But I will like to know why the root don't work on my RAZR... It's very weird.

The problem is always here! I don't understand... Look the picture, it's OK but when I install Ad Away (for exemple), a popup says my phone isn't rooted.

EDIT 2:
Quote:
Quote:
Very nice! But I have one problem, after every reboot it tells me SU binary need to be updated, how can i fix this?
Update by wifi
Or
You press hardware button when phone vibrated? During rooting?
Ok, I can try this. But when I need to press the button? After the vibration?
Attached Thumbnails
Click image for larger version

Name:	virtualbox.jpg
Views:	95
Size:	42.7 KB
ID:	1935092  
 
Nono-Skorium
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
Nobody know why some people have this problem? Time is very long, very very long... We need to root our phone

Sent from my XT910 using xda premium
 
Luisit0
Old
#6  
Luisit0's Avatar
Senior Member
Thanks Meter 608
Posts: 2,942
Join Date: Mar 2011
Location: San Juan
well, at least ur phone has something... in my case, it didnt get to recognize my phone! it stayed on * daemon started successfully * and doesnt continue... drivers installed fine when I plugged my phone to the PC, so I'm clueless as to what I can do here...
Current Phone:
AT&T HTC One 32GB

Status: Bootloader Unlocked / Rooted / S-Off / SuperCID / Modded HBoot

Recovery: TWRP v2.6.3.3

Android: JB 4.4 / Firmware 4.06.1540.3

Kernel: ElementalX v10.9

Rom: ViperOne v4.1.0 - 4.06.1540.3 Based
 
Nono-Skorium
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
Default tDiveste later

Have you check the USB Settings in VirtualBox. Maybe, it's just that? I don't know.

It's always impossible for me to root my RAZR... I try with my VM on Debian, but the phone don't find the VM with the remote storage. The IP address is correct (192.168.1.XX) but the connection is not established.

Maybe we need a "oneclick tool" to root the phone, I hope that this tool is almost ready
 
Nono-Skorium
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Dec 2012
Location: Dublin
My phone is rooted with success. But I didn't use Easy Way VM. I made a virtual machine with Debian and I followed the main tutorial with Ubuntu.

Sent from my XT910 using xda premium

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Android 4.4.3 Begins Rolling Out to European HTC One M8

Shortly after the USA Unlocked and Developer Editions of the HTC One M8 received the … more

Modernize Your Emails with Email Popup

SMS andHangouts messages likely won’t ever replace traditional Emails for more formal … more

Change Your Toast Notification Style with XToast

Android uses multipletypes of notifications. One of these isknown as a toast notification. … more

Port Sony Xperia Themes to CyanogenMod 11 with Ease

In addition the obvious proficiency with graphics, creating agood Android theme … more