Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,477 Members 42,129 Now Online
XDA Developers Android and Mobile Development Forum

[Tips]Android Studio not starting, tips here.

Tip us?
 
lolrenx
Old
(Last edited by lolrenx; 31st May 2013 at 01:21 PM.)
#1  
lolrenx's Avatar
Member - OP
Thanks Meter 41
Posts: 91
Join Date: Jul 2008
Location: London
Default [Tips]Android Studio not starting, tips here.

Hello,

I ran into a couple problems having android studio to install and work. thought I'd share my findings!

First, it wouldn't install. Not finding Java JDK even though it was installed.
This is solved by changing the name of C:\Windows\System32\Java.exe to something else before the installation.
Don't forget to change it back to java.exe once installed.

After installing Android studio, it wouldn't run (normal or admin didn't change a thing).
You will need to create a system environment variable named JDK_HOME with your JDK installation path (in my case C:\Program Files\Java\jdk1.7.0_21\ ).
Android studio should now launch. (more help here )

Now that Android Studio launches, it asks for the latest android SDK
Just download and install the SDK 22 from Here

make sure you run the .exe as administrator after installation

NB :
Quote:
Originally Posted by dbarrera View Post
For those having issues starting Android Studio in some Linux distros, such as Studio not finding JAVA_HOME, JDK_HOME, STUDIO_JDK, set any of those variables to the directory where Java is installed (e.g. /usr/java/jdk1.7.0_21) previously to the whole validation statements in the startup shell file (studio.sh) and everything should be fine...
Hope this saves some head scratching !
JFLTEXX + OMNI
The Following 26 Users Say Thank You to lolrenx For This Useful Post: [ Click to Expand ]
 
akkaash
Old
#2  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Oct 2012
Location: Mumbai
Quote:
After installing Android studio, it wouldn't run (normal or admin didn't change a thing).
You will need to create a system environment variable named JDK_HOME with your JDK installation path (in my case C:\Program Files\Java\jdk1.7.0_21\ ). Android studion should now launch. (more help here )
worked perfectly for me. Thanks
 
anishjhaveri
Old
#3  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: May 2013
Thumbs up Perfect!

Worked for me too...thanks for saving time.
The Following User Says Thank You to anishjhaveri For This Useful Post: [ Click to Expand ]
 
madhucm
Old
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2013
Unhappy Window 7 with jdk 1.6

Quote:
Originally Posted by anishjhaveri View Post
Worked for me too...thanks for saving time.
Does Android Studio requires JDK 7 or greater ?? coz i have JDK 1.6 on my Windows 7 it doesnt start up even after setting JDK_HOME or JAVA_HOME. http://forum.xda-developers.com/images/icons/icon9.gif
 
craig@xatik
Old
#5  
craig@xatik's Avatar
Senior Member
Thanks Meter 232
Posts: 253
Join Date: Mar 2012
Location: Twin Cities, MN

 
DONATE TO ME
Quote:
Originally Posted by madhucm View Post
Does Android Studio requires JDK 7 or greater ?? coz i have JDK 1.6 on my Windows 7 it doesnt start up even after setting JDK_HOME or JAVA_HOME. http://forum.xda-developers.com/images/icons/icon9.gif
It should work fine on 1.6.
Maybe it depends if you're 32bit or 64bit?

My personal setup is Windows 8 64 bit running the 64bit version of Java 1.7.


Also, for the SDK issues, if you already have the SDK installed from using Eclipse, you can just point Android Studio to that SDK under Project Settings or something (I forget the exact wording of the setting and I'm not at my computer right now...)
Don't forget to hit Thanks if you found my post helpful!

Creator of the Man Test and Droid Draw!
Check out how Manly you are or enjoy creating patterns with the Turtle Graphics remake Droid Draw today! Both are available on Google Play for Android devices 2.2+
 
se0siris
Old
#6  
se0siris's Avatar
Member
Thanks Meter 5
Posts: 99
Join Date: Dec 2007
Location: Manchester, UK
Thank you! I was having trouble getting Android Studio to start once installed. Setting JDK_HOME fixed this.
 
Gingerbread23
Old
(Last edited by Gingerbread23; 16th May 2013 at 09:50 PM.)
#7  
Senior Member
Thanks Meter 5
Posts: 109
Join Date: Mar 2012
Im using Windows 7 Ultimate 64 bit and set the JDK_HOME variable but it wont start...

/Edit: it works now.
 
bentech4u
Old
#8  
bentech4u's Avatar
Member
Thanks Meter 2
Posts: 74
Join Date: Nov 2008
HI

Thanks for this tips.

working fine for me
 
13th Dev
Old
(Last edited by 13th Dev; 17th May 2013 at 03:15 PM.)
#9  
Member
Thanks Meter 5
Posts: 48
Join Date: May 2012
Location: Indore, India
If someone is just beginning app development, starting with hello world app. Would you recommend him eclipse or android studio?

Sent from my HTC Desire S using xda app-developers app
 
Intrepid90
Old
#10  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: May 2013
I'm having a small issue with Android Studio for Mac, and was wondering if anyone was running into a similar issue or has any advice.

When running my application, I'm getting an error on the install, specifically a Failure: [install_failed_invalid_apk].

I'm sure it's something really simple and elementary, but it wasn't an error I'm familiar with seeing coming from Eclipse.

Tags
adt, android studio, jdk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes