Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM][Official][4.3] CyanogenMod 10.2 for the Verizon Galaxy S4

OP invisiblek

1st June 2013, 01:02 PM   |  #1  
Nightly builds for the cm-10.2 branch for this device have stopped.
Please see here for nightly builds of cm-11.0 (kitkat)
Or continue for the stable cm-10.2 build...


CyanogenMod is a free, community built, aftermarket firmware distribution of Android 4.3 (Jelly Bean), which is designed to increase performance and reliability over stock Android for your device.

Q/A thread:
http://forum.xda-developers.com/show....php?t=2346808
Please use the above unless you have something development-related to contribute here. Thank you.

Code:
#include <std_disclaimer.h>

/*
 * Your warranty is now void.
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
 *
 */
CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). CyanogenMod does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for CyanogenMod is available in the CyanogenMod Github repo. And if you would like to contribute to CyanogenMod, please visit our Gerrit Code Review. Your changelog is whatever was merged into gerrit.

Instructions

First time flashing CyanogenMod 10.2 your device, or coming from another ROM?
  1. Download the zip(s).
  2. Install a compatible Recovery (see here)
  3. Perform a NANDroid backup of your current ROM (Optional)
  4. Wipe data & cache partitions of your device (required when coming from stock!).
  5. Flash CyanogenMod.
  6. Optional: Install the Google Apps addon package.

Useful Links

Other Issues?

Before posting on this thread, make sure of a few things:
  • Make sure you have the LATEST version of ClockworkMod recovery. Other recoveries may work but will not be supported by CyanogenMod
  • You've utilized the search function of the forums. Nothing irritates me more than lazy people who do not search for an answer before asking.
  • If you are the only one having a problem. Boot into recovery, wipe data/factory reset, reflash the rom/gapps and nothing else. Boot up and see if the problem persists.
  • Make sure your post is relevant to this thread. "I'm having problems rooting/unlocking" is NOT relevant here.
  • LOGS LOGS LOGS!!!! Use this: https://play.google.com/store/apps/d...Wwuc3lzbG9nIl0

Download Links

CyanogenMod:
Download: http://download.cyanogenmod.org/?dev...zw&type=stable

Google apps addon:
Download: http://goo.im/gapps (use latest 4.3 gapps)
Mirror: http://invisiblek.chickenkiller.com/pits/

The CyanogenMod team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

XDA:DevDB Information
CyanogenMod 10.2 for the Verizon Galaxy S4, a ROM for the Verizon Samsung Galaxy S 4

Contributors
invisiblek

Version Information
Status: Testing

Created 2013-09-13
Last Updated 2014-04-23
Last edited by invisiblek; 19th August 2013 at 04:24 PM.
The Following 65 Users Say Thank You to invisiblek For This Useful Post: [ View ]
1st June 2013, 01:07 PM   |  #3  
Senior Member
Flag New Mexico
Thanks Meter: 53
 
418 posts
Join Date:Joined: Mar 2006
Quote:
Originally Posted by invisiblek

Known issues:

None at this time

is in call bluetooth working? downloading now and will test when i get my headset back, but I know that has been the major problem with the other cdma jf builds. I was going to look at it all today but if you've got it fixed it would save me the trouble haha

Thanks for your time on this man!
1st June 2013, 01:22 PM   |  #4  
Quote:
Originally Posted by fallingup

is in call bluetooth working? downloading now and will test when i get my headset back, but I know that has been the major problem with the other cdma jf builds. I was going to look at it all today but if you've got it fixed it would save me the trouble haha

Thanks for your time on this man!

Steve fixed it last night
https://github.com/CyanogenMod/andro...003f169ee01d17
The Following 2 Users Say Thank You to invisiblek For This Useful Post: [ View ]
1st June 2013, 01:33 PM   |  #5  
Senior Member
Flag New Mexico
Thanks Meter: 53
 
418 posts
Join Date:Joined: Mar 2006
Quote:
Originally Posted by invisiblek

Steve fixed it last night
https://github.com/CyanogenMod/andro...003f169ee01d17

Nice. Might try to build some carbon goodness since i went through all of the trouble of blowing off the dust of my build box

edit: it was early and i cant read
Last edited by fallingup; 1st June 2013 at 01:46 PM.
1st June 2013, 02:01 PM   |  #6  
Senior Member
Thanks Meter: 62
 
282 posts
Join Date:Joined: Dec 2011
More
Hey. Glad there's a thread up now. I already reported this via PM, but I thought I'd throw it out there for the community, and I have a workaround.

I can't seem to get a GPS lock in Navigation. However, on stock it works fine. I saw another user post in the help section that he has the same issue on stock. He mentioned that turning off mobile and wifi location fixes the issue for him. I took a shot and it worked. Not sure what to make of it.

Anyone else see this behavior?
The Following User Says Thank You to SonicJoe For This Useful Post: [ View ]
1st June 2013, 02:02 PM   |  #7  
Senior Member
Thanks Meter: 33
 
191 posts
Join Date:Joined: Aug 2010
Awesome will flash shortly! Is GPS fixed?
1st June 2013, 03:32 PM   |  #8  
Member
Flag Knoxville, TN
Thanks Meter: 5
 
74 posts
Join Date:Joined: May 2010
More
Bluetooth is just turning itself off and a2dp isn't working.

Sent from my SCH-I545 using xda premium
1st June 2013, 04:28 PM   |  #9  
twiz0r's Avatar
Senior Member
Flag Vegas
Thanks Meter: 68
 
1,166 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by SonicJoe

Hey. Glad there's a thread up now. I already reported this via PM, but I thought I'd throw it out there for the community, and I have a workaround.

I can't seem to get a GPS lock in Navigation. However, on stock it works fine. I saw another user post in the help section that he has the same issue on stock. He mentioned that turning off mobile and wifi location fixes the issue for him. I took a shot and it worked. Not sure what to make of it.

Anyone else see this behavior?

It's a known aosp issue. Last rom I tried workaround didn't work for me. Hopefully it works for me now

Sent from my SCH-I545 using Tapatalk 2
The Following User Says Thank You to twiz0r For This Useful Post: [ View ]
1st June 2013, 04:48 PM   |  #10  
Senior Member
Thanks Meter: 62
 
282 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by twiz0r

It's a known aosp issue. Last rom I tried workaround didn't work for me. Hopefully it works for me now

Sent from my SCH-I545 using Tapatalk 2

I'm not 100% sure that is accurate, unless it affects phones or devices with mobile data only. I have a GTab 2 wifi running CM 10.1 and it works fine. I tested there before sending my logcat to invisiblek to make sure it was a device issue, not a CM issue.

Post Reply Subscribe to Thread

Tags
4.2.2, aosp, cyanogenmod, jellybean, jfltevzw
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes