Official TWRP Recovery Lands on Micromax Canvas Magnus

With the recent release of Android One, Micromax and MediaTek released fully buildable … more

Update Overload: SuperSU Heavily Updated

There are apps and apps out there. Very few can reach the level of popularity required to stay at … more

Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Adding Google Apps to the Huawei Ascend G520-000 (Chinese model)

OP JethroUK

29th June 2013, 09:39 AM   |  #1  
OP Member
Thanks Meter: 6
 
57 posts
Join Date:Joined: Aug 2012
Post Updated 19/7/13 right here to save you reading the whole thread:

Bought Huawei G520 (quad core) direct from China 125

It starts up in Chinese, but with a little help from Google I managed to change it to English quite easily



Just look for the "A" icon and then it's the top option to change to English

(If you put an English sim in it first, it defaults to English anyway)

No Google apps!

I didn't anticipate the China vs Google being a problem, especially since "Android" is "Google"s own OS. How can you have an Google OS with no Google apps, but you can, and China have.

Anyway I spent the next 2 days solid trying different solutions, different rooting tools, flashing tools, downloading Google apps by apk (some do work but most just close down & cant login)

Locked up the phone in my desperate attempts to install virtually anything....but...

....I managed to find the Huawei G520 000 Official Stock Rom here....





..UPDATE 19/7/13) have since found newer official B192 version here - havent tried it though....





...either of which is easy to install.....unzip the folder and copy just the folder called "dload" to the root of your sd card - remove your G520 battery for about 30 seconds...refit the battery....hold both volume keys with one hand...now hold the power button too until the process starts (about 15 seconds)

Even managed to install Clockworkmod (whatever that is), dont ask me how,where, just a result of trying so much software I guess - When I saw it I figured it was rooted, but still couldn't install anything with it so I guess it was still not rooted

Anyway I discovered that the "Bootloader" is locked on this model - was directed to.....

Huawei website where you can request bootloader code (16 digit number)

....and found out the same as you, that the G520 is not listed - Dang!

Decided to ......

send an email to Huawei just on the hope they might respond

.... - I wrote down all the details as required from the official form and sent it.....Would you believe it, they only went and sent me the bootloader unlock code THE VERY NEXT DAY - in fact it was within about 8 hours - BRILLIANT!

...you need a usb driver to perform the unlock procedure and to be honest i installed loads so i cant remember which one to credit but i found this

.........official Huawei Generic USB driver...

...it should work although is does make you wonder why they dont link to it in the first place? If I remember right, if its the correct driver and you connect you mobile in USB Debugging mode (Settings > Developer settings > USB Debuggin = checked) the PC says "connected in ADB mode"....

Followed the official Huawei bootloader unlocking procedure...

...and Bobs your uncle "Your bootloader is UNLOCKED" - Yaaaaaaaaaaaayyyyyyyyyy

I thought the rest was easy now - nope

Tried a million and one rooting/flashing tools, still wouldn't root (I downloaded "Root Explorer apk" to my mobile to try and access the root directory and thats how i knew it wasn't rooting - nearly gave up on the whole idea - figured it was root locked for ever

The G520-000 is Exclusively Chinese so I started searching China, which was difficult, not just because it's Chinese but you cant use Google because for the same reasons it doesn't search China - so I ended up using the G520 browser its-self to search (got millions of hits because its very popular in China) and if it looked interesting I emailed link back to my PC where Google translated the web page - loads of forums about flashing the G520-000

Anyway I found a buzz on Chinese forums .......
about this tool



....and can you believe it - It rooted it in 1 minute

It's in Chinese and installs Chinese superuser...but its easy to follow - Moderators that dont read Chinese...this is the companies own tool and its totally freeeeeeeeeee

Just remember that it prompts in Chinese and on the left is "Deny" and on the right is "Allow"

Tried Zardamans excellent suggestion here....

.....but although I installed Google apps , the current OS kept closing them down so you still couldn't login & and it generating repeated errors so i uninstalled them in the end...on reflection it could be that I was "deny"ing privileges inadvertently, until i learnt a bit of Chinese.....anyway

Read an article which suggested using "Root Explorer" to install ONLY the 5 apps below

OneTime Initializer.apk
GoogleLoginService.apk
Google Services Framework.apk
Setup Wizard.apk
Gmail.apk

directly into root\systems\apps folder

Restart you phone - login to Gmail - done!

now install any/all of the other google apps including Playstore (this is the app that crashes the system if you install it before Gmail) just by running the apk file

I have:

Google playstore (sometimes called Phonesky.apk)
G+
ContactSyncAdaptor
CalendarSyncAdaptor
Chrome
Play movies
Google music

All working fine now

Yaaaaaaaaaaayyyyyyyyyyyyyy!!!!!!!!!!!
Last edited by JethroUK; 19th July 2013 at 11:40 PM.
The Following 4 Users Say Thank You to JethroUK For This Useful Post: [ View ]
6th July 2013, 05:27 PM   |  #2  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
I hope this works on G520-5000


So I skipped all the parts that didn't work for you and downloaded this chinese program.

When I click the green button nothing happens.
I am guessing I need to install the phones drivers but I don't know how.




Please help, this is my first smartphone and I don't know much.
I am very happy with the phone but the lack of google play bugs me.
Spent the last 2 days researching this problem.

All I found was this but it didn't help:



As a new user to this forum I can't post links so i sent you a pm.

Thank you
6th July 2013, 09:54 PM   |  #3  
OP Member
Thanks Meter: 6
 
57 posts
Join Date:Joined: Aug 2012
Heres an easier one

http://www.winkabarkyaw.net/2013/04/...g520-5000.html

Just download the Huawei Driver

Once youve installed this driver on your PC - just run the rooting software - it will recognise your phone and root it
Last edited by JethroUK; 6th July 2013 at 09:59 PM.
The Following User Says Thank You to JethroUK For This Useful Post: [ View ]
7th July 2013, 12:29 AM   |  #4  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
Thank you so much.

I will try it tomorrow because it won't work on my 64bit Windows 7. I will install a 32bit version.
I will post results.

Update 1 :
I installed the driver on 32bit Windows 7 successfully.

Got stuck on the bootloader code.
I've sent them an e-mail.
First I need them to explain how to get the product ID, this *#*#1357946#*#* doesn't work for me.
This is going to take longer than expected.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2.jpg
Views:	275
Size:	27.7 KB
ID:	2097523  
Last edited by kdebogovi; 7th July 2013 at 07:22 PM.
8th July 2013, 11:44 AM   |  #5  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
They replied:


Quote:

Dear Customer,

Thank you for contacting Huawei device.

Sorry that there have no bootloader unlock code for this item.

Once again thank you for contacting Huawei device.

Best Regards.

Huawei Device Customer Care Team.



What to do now?
8th July 2013, 11:56 PM   |  #6  
OP Member
Thanks Meter: 6
 
57 posts
Join Date:Joined: Aug 2012
Did you supply all the phone details

IMEI
Serial No
Product code

?
11th July 2013, 11:24 PM   |  #7  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by JethroUK

Did you supply all the phone details

IMEI
Serial No
Product code

?


I can't get the Product Id with *#*#1357946#*#*.

I sent them an email asking them how to get the Product ID but no response.
12th July 2013, 08:32 PM   |  #8  
OP Member
Thanks Meter: 6
 
57 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by kdebogovi

I can't get the Product Id with *#*#1357946#*#*.

I sent them an email asking them how to get the Product ID but no response.

Huawei method of *#*#1357946#*#* for Product ID works fine on mine - are you sure you are typing it correctly?

Otherwise I cant imagine - all the rest of the numbers are in the settings>about menu
12th July 2013, 09:52 PM   |  #9  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2013
Yes I am sure. When I type the last asterisk it wipes the rest of the code and nothing happens.

There is also no Product ID anywhere else to be found on the phone. There is some CMI IT ID number behind the battery but it is a 10 digit number.

I'm glad it works on G520-000, on G520-5000 it does not.
Apparently I am not the only one.

Anyways they responded to my mail with this after I explained the code doesn't work:

Quote:

Dear Customer,

Thank you for contacting Huawei device.

Would you please kindly input *#*#1357946#*#* to check the product ID.

Once again thank you for contacting Huawei device.

Best Regards.

Huawei Device Customer Care Team.

LOOOL

I already sent another mail.
13th July 2013, 09:51 PM   |  #10  
Junior Member
Thanks Meter: 1
 
1 posts
Join Date:Joined: Jul 2013
Thanks!
Thanks for the thorough information Jethro - I managed to unlock my g520-0000
Just like you I have tried many flash tools and at the end I had to update to the B190 rom because the phone was already a mess (downloaded the one from the link you have posted), because the phone could not root with Vroot.

So, what worked for me - generally I combined some parts of a tutorial for unlocking my other phone (Huwaei y300) with parts of your long story

1. The unlock procedure
After receiving the code from Huawei I unlocked he bootloader following this unlock procedure (only the unlock procedure from the tutorial, not the whole tutorial!!! - Step 2) : huawei-y300.tumblr.com/post/47366836617/how-to-unlock-and-root-huawei-ascend-y300-all

2. After that downloaded VROOT from the link you have posted and it rooted the phone in a minute

3. Installed Root Explorer

4. Installed Google apps / Playstore ....

From another tutorial about y300 I downloaded a Google apps .zip with many google .apk files - huawei-y300.tumblr.com/install-google-apps
First: I downloaded the archive in order to extract and copy only 4 of the .apk files.
The archive has sub-folders. The 4 apk are in sub-folder gapps-jb-20121011-signed\system\app of the archive:
GoogleLoginService.apk
GoogleServicesFramework.apk
OneTimeInitializer.apk
Phonesky.apk

Second: I used Root Explorer and copied the 4 files to root\system\app

* When trying to paste the 4 files the Chinese SuperUser installed by Vroot asks you for root rights for Root explorer - press the RIGHT Chinese button which should mean sth. like YES If you press the left one you will deny rights and after that like me will have to go through the Chinese menu of SU, find Root explorer and give root permissions to it - it took me 30 minutes and was not sure what I'm actually doing

Third: Restart the phone.

After the phone restarts you can start Playstore


Best,
Last edited by dimakcho; 13th July 2013 at 09:57 PM.

The Following User Says Thank You to dimakcho For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes