Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HOWTO] Expand storage space with Link2SD and SDExt2Mounter

OP WhoDunnit

1st July 2013, 12:36 AM   |  #1  
WhoDunnit's Avatar
OP Senior Member
Thanks Meter: 85
 
127 posts
Join Date:Joined: Sep 2007
I guess everybody would like to expand the Ouya's internal memory. I tried the usual tools, and although DirectoryBind is working, it doesn't help much because there are no obb or data directories to be moved for Ouya games.

However, Link2SD works just fine!

Prerequisites:
  1. Installed SuperUser on Ouya
  2. Link2SD apk
  3. USB drive with a 2nd primary partition formatted as ext4

There are plenty of guides that explain how to get the SuperUser apk installed, so just use the search button above.

The Link2SD apk you can install on your phone from Google Play, and copy it to some place from where you can install it on your Ouya.

Use any tool (gparted, MiniTool Partition, etc.) to create a 2nd, primary partition on your USB drive, and format it to ext4. Use the search button if you are in doubt.

Now, Link2SD does not seem to recognize that there is indeed an ext4 formatted 2nd partition on the USB drive.
To make it work you have to mount it manually (see below), or install my SDExt2Mounter for Ouya, or use the script in post #3.

Manual way:
So, insert the USB drive in Ouya, and do the following:
[in adb shell]:
  1. su
  2. mkdir /data/sdext2
  3. mount -t ext4 /dev/block/vold/8\:2 /data/sdext2
  4. exit

Now start Link2SD on the Ouya, and start using that cumbersome touchpad to move apps and data (use the Link button, as Move to SD card does not work for Ouya) to your new found storage space! There are some options in the Link2SD menu to make all future installed app be automatically moved (and linked) to the new location, but I haven't tested that one yet.

Of course things will break if you remove the USB drive from the Ouya, and if you really power down the Ouya, you have to make sure you first mount the ext4 partition before the launcher starts, or you cannot use the games!

Use SDExt2Mounter:
Make sure you have rooted your Ouya and installed busybox; you will have to reroot your Ouya after each firmware upgrade!
Install SDExt2Mounter; you will find the app in the "PLAY" menu, not in the "MAKE" menu. Yes! My first Ouya app!
  • Start SDExt2Mounter
  • Grant it PERMANTENT root access if asked
  • Press the (make and) mount button
  • Press the AutoMount on Boot button
  • Reboot your Ouya
After the reboot step, your Ouya will automatically mount the sdext2 partition so your games will show up in the launcher. Obviously, you only need to go through these steps once.

Start the app, grant it PERMANTENT root access, and hit the "(make and) mount button".

Changelog:
v1.2: Added Automount option to mount sdext2 on boot, so your games show up in the launcher.
v1.1: Corrected directory path; added SuperUser permission
Attached Files
File Type: apk SDExt2Mounter_1.1.apk - [Click for QR Code] (94.9 KB, 242 views)
File Type: apk SDExt2Mounter_1.2.apk - [Click for QR Code] (97.7 KB, 805 views)
Last edited by WhoDunnit; 31st July 2013 at 03:46 PM. Reason: updated SDExt2Mounter
The Following 18 Users Say Thank You to WhoDunnit For This Useful Post: [ View ]
1st July 2013, 01:40 AM   |  #2  
professorpoptart's Avatar
Senior Member
Thanks Meter: 107
 
159 posts
Join Date:Joined: Jul 2010
More
Awesome! on the todo list.. FYI though be sure not to put your main launcher or su stuff on the linked partition.
1st July 2013, 08:28 AM   |  #3  
natorus87's Avatar
Senior Member
Thanks Meter: 525
 
256 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Thumbs up
here i have made smal script....extract it to system/etc/init.d an then install Universal Init.d
https://play.google.com/store/apps/d...5pbml0LmQiXQ..

Now open the app and give it su permissions and turn inti.d support on! Now all goes automatically
Attached Files
File Type: zip usbext4mount.zip - [Click for QR Code] (230 Bytes, 408 views)
The Following 4 Users Say Thank You to natorus87 For This Useful Post: [ View ]
1st July 2013, 09:08 AM   |  #4  
Senior Member
Thanks Meter: 34
 
254 posts
Join Date:Joined: Mar 2011
What happens if you start up your OUYA with the USB drive not plugged in? Would it just not show the apps? Or maybe show an error? Basically I'm wondering if there could be any complications with the OUYA if I forgot to add the HDD to the OUYA before turning it on.
1st July 2013, 01:18 PM   |  #5  
professorpoptart's Avatar
Senior Member
Thanks Meter: 107
 
159 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by JLCollier2005

What happens if you start up your OUYA with the USB drive not plugged in? Would it just not show the apps? Or maybe show an error? Basically I'm wondering if there could be any complications with the OUYA if I forgot to add the HDD to the OUYA before turning it on.

The links are basically shortcuts made to the app on the new partition. The same idea if you remove a drive with all your steam games on it, worst case the shortcut won't work.

Also they would then just show a link icon instead of the actual app icon as this is rendered from a file in the apk itself.
7th July 2013, 05:15 AM   |  #6  
Senior Member
Flag Indio
Thanks Meter: 11
 
128 posts
Join Date:Joined: Dec 2010
More
After reboot even with the init script any linked apps were gone for me

Sent from my OUYA Console using xda app-developers app
8th July 2013, 04:43 AM   |  #7  
Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Apr 2010
Someone correct me if I'm wrong, since I am in no way an expert, but looking at the init.d script I think there should be a space in between 'shmkdir /data/sdext2' and 'mount -t...' ? Haven't powered down yet so I can't confirm whether it works or not.
10th July 2013, 09:26 PM   |  #8  
Junior Member
Flag Minneapolis
Thanks Meter: 1
 
12 posts
Join Date:Joined: Nov 2010
More
I have this working great now!

When I tried to go to the play store and download Universal Init.d, it would force close upon opening. I had to search for and download an earlier version, Uni-init v1.0.apk.

It does take longer for my OUYA to boot now, so just wait for it.
11th July 2013, 12:51 AM   |  #9  
foil's Avatar
Senior Member
Flag 0x000000FF
Thanks Meter: 194
 
186 posts
Join Date:Joined: Jan 2008
More
Do you mind if I add this script into my Ouya ToolBox?
All credit will be given to you, of course.
Thank you!

http://forum.xda-developers.com/show....php?t=2350900
The Following 3 Users Say Thank You to foil For This Useful Post: [ View ]
11th July 2013, 02:59 AM   |  #10  
Asadullah's Avatar
Senior Member
Flag casselberry
Thanks Meter: 296
 
909 posts
Join Date:Joined: Aug 2010
More
I believe that you can add the ability to mount the ext partition to the ramdisk in the boot.img

Post Reply Subscribe to Thread

Tags
app2sd, ext4, link2sd, ouya, storage
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes