Post Reply

Xperia Z Ultra Defective Screen, DOA

OP fhsieh

4th August 2013, 05:48 PM   |  #1  
OP Senior Member
Thanks Meter: 28
 
457 posts
Join Date:Joined: Aug 2008
More
I ordered an Xperia Z Ultra and received it in the mail yesterday. Unfortunately, the unit I received has a defective screen. When you press the power button, the screen backlight turns on but stays completely blank (black). Android is still running fine underneath -- pressing back/home/app softkeys gives haptic/audio feedback, pressing volume rocker gives volume up/down sounds, etc. However the screen stays completely blank and the device is unusable.

No matter how many times you press the power button, the screen still remains blank/black. The screen will only turn on correctly, randomly. On my unit, anywhere between 5 and 150 power button presses.

The screen also has a noticable yellow tinge.



Turning-off the phone first does not solve the problem. In fact, the screen is still blank when booting up (i.e.: the "Sony/Xperia" loading screen/boot animation).
Pressing the hard-off button next to the SIM card tray also does not solve the problem.
Pressing and holding Power+VolUp also does not solve the problem.
Factory-resetting via Settings also does not solve the problem.
Reflashing latest firmware from PC Companion or SUS also does not solve the problem. (Flashes correctly, but screen is still defective)



So just beware, for anyone getting a C6802. Either confirm in-person that you don't have a defective unit, or have your retailor confirm for you.

The unit I received:
- C6802 (3G-only), White
- Hong Kong, unbranded
- Manufature date: 13W29 (2013, Week 29)
- Firmware version: 14.1.B.0.471

Edit:
Other YouTubers similar/worse defect on their Xperia Z Ultra:




Last edited by fhsieh; 6th August 2013 at 07:00 PM.
4th August 2013, 06:18 PM   |  #2  
Andrewtst's Avatar
Senior Member
Flag Johor
Thanks Meter: 1,467
 
4,279 posts
Join Date:Joined: Aug 2009
Donate to Me
More
Both video upload by same person, it is ridiculous having two units and both is defective.

Lucky me and my friend + at least 30 users (report at Malaysia lowyat forum), our units running perfectly fine and no issue with great panel display, not as above video look that terrible and full with problem.
5th August 2013, 12:32 AM   |  #3  
Junior Member
Flag San Jose, CA
Thanks Meter: 4
 
27 posts
Join Date:Joined: Oct 2007
More
Got my C6802 on Friday and love it!
No screen problems at all here.

Sent from my C6802 using xda app-developers app
5th August 2013, 01:56 AM   |  #4  
Member
Thanks Meter: 8
 
99 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by cmclaughlan

Got my C6802 on Friday and love it!
No screen problems at all here.

Sent from my C6802 using xda app-developers app

Seconded.
5th August 2013, 08:22 PM   |  #5  
OP Senior Member
Thanks Meter: 28
 
457 posts
Join Date:Joined: Aug 2008
More
Good to hear you haven't had any problems. Hopefully this is a limited issue that won't affect a lot of units.

Unfortunately the RMA process for me will take some time, and my retailor just ran out of stock, so looks like I'll be waiting for some time before I can get a replacement.
5th August 2013, 10:42 PM   |  #6  
Senior Member
Thanks Meter: 40
 
234 posts
Join Date:Joined: Dec 2010
Bought from a reputable seller?

Sent from my LT29i using Tapatalk 2
6th August 2013, 07:37 AM   |  #7  
OP Senior Member
Thanks Meter: 28
 
457 posts
Join Date:Joined: Aug 2008
More
Quote:
Originally Posted by Lusterboi

Bought from a reputable seller?

Ordered from Expansys. As I'm in Japan, I ordered from their Japan division (based in Hong Kong), which is unfortunately under-staffed. Sadly, I'll have to pay additional shipping costs for the replacement, as well as paying import tax again for the replacement. Hopefully Expansys will be willing to help cover some of the extra cost, but so far I haven't heard back from them (because they're just under-staffed).
6th August 2013, 08:30 AM   |  #8  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Dec 2009
I'm facing black last night. third day of purchase. after press hard rest button solved

Sent from my C6802 using xda app-developers app
6th August 2013, 08:38 AM   |  #9  
OP Senior Member
Thanks Meter: 28
 
457 posts
Join Date:Joined: Aug 2008
More
Quote:
Originally Posted by avenloh

I'm facing black last night. third day of purchase. after press hard rest button solved

Did you have the same blank screen problem as in the video?

And can you explain the "hard reset button"?



I have tried soft-off (Power+VolUp, or OFF switch located next to SIM tray), software factory reset (Settings > Backup & Reset), and Sony PC Companion/Update Service (reflash factory firmware), and my device still has the same issue.

Thanks.
6th August 2013, 08:52 AM   |  #10  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by fhsieh

Did you have the same blank screen problem as in the video?

And can you explain the "hard reset button"?



I have tried soft-off (Power+VolUp, or OFF switch located next to SIM tray), software factory reset (Settings > Backup & Reset), and Sony PC Companion/Update Service (reflash factory firmware), and my device still has the same issue.

Thanks.

mine is just blank. no line as second video. still can recieve call (using bluttoth). but nothing show. plug in chaarger also cannot charge. press the button beside sim card solved

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z Ultra General by ThreadRank