Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Lumia 920 Amber Update via Rogers Dev ROM

OP snickler

11th August 2013, 07:36 AM   |  #1  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
UPDATE! Rogers has released an official Amber ROM for Rogers branded L920s. If you want them, here are the product codes for the equivalent colors

059R2L8 RM-820 VAR AMERICA CA ROGERS SL YELLOW
059R3R8 RM-820 VAR AMERICA CA ROGERSWIR SL RED
059Q6W4 RM-820 VAR AMERICA CA ROGERSWIR SL BLACK
059R6P3 RM-820 VAR AMERICA CA ROGERSWIRE SL WHIT

Use the firmware download option from NCS in order to download the ROMS or use http://www.mrcrab.net/Nokia-Product-Code.html.

After installing the Rogers ROM, you'll need to get the access point app and choose AT&T LTE 2 in order to have data and MMS. I forgot to put it in here, but thanks to @riceboyler

Quote:
Originally Posted by riceboyler

If you haven't yet, install the Nokia Access Point app, (http://www.windowsphone.com/en-us/st...3-25c10463942d) and then choose AT&T LTE2. That fixed all of my issues except tethering...





Hi All,

I've spent the past 4 days looking for a solution to get the Amber Update on my AT&T Branded Lumia 920 without installing a European ROM and changing to RM-821. After searching endlessly, I've found my solution that works!

Prerequisites
* Nokia WP8 Drivers
* Nokia Care Suite 2013.13.4.4
* WperHelper v1.2 Note: This is in Chinese. I don't know Chinese AT ALL, but I've been able to figure my way around the app
* Rogers Pre-Poritco ROM. Download the last group of files for Roger, not the AT&T ones.

Steps:
* DONT PLUG IN YOUR PHONE YET TO THE COMPUTER.
* Extract/Install Nokia Care Suite. Open Care Suite when it's done installing and just put it to the side
* Install WperHelper. It's all in chinese, but the buttons should be easy to navigate through
* Download the last group of files for the pre-portico ROM if you haven't done so already.
* Go to the Run menu on your system and go to "C:\programdata\nokia\Packages\Products". Create a new folder named "RM-820". If you already have files in here from a previous ROM installation, move them somewhere else. The group of files you downloaded for the Pre-Portico ROM will need to be moved inside of this folder.
* Rename the pre-portico files removing the checksum from beginning of the file name.

Here's what you should have as files
  • * RM820_1232.2109.1242.1002_RETAIL_nam_canada_200_02 _100347_prd_signed.ffu
    * RM-820_RM-821_RM-822_TypeLabel_Group1_DM_5.33x5.33_CoO_Eng__001.xml
    * CustomerNvi_31019d17537fb461136cdf3481825681_12421 _100343_8410.nvi
    * RM820_059R2L8_1232.2109.1242.1002_039.vpl
    * 112545v3.pcx
    * RM820_059R2L8_1232.2109.1242.1002_039.dcp
    * RM820_059R2L8_1232.2109.1242.1002_039_signature.bi n
    * RM820_059R2L8_ccc_v039.bin
    * RM820_059R2L8_hwt_v039.bin
    * NWP8_WP8_Rogers_Fido_simlock_crcFCB5.bin
    * DC_template_development_v4.bin
* Go back to NCS and double click on the Product Support Tool. If you don't see the little menu with the choices of apps to install, go to "C:\Program Files (x86)\Nokia\Nokia Care Suite\Product Support Tool For Store 5.0" and click on ProductSupportToolForStore.exe (Make sure the icon is an arrow. We don't need to open the .MANIFEST file).
* When the Sign in popup comes on the screen. click Work offline.
Click File -> Open Product and type in RM-820 in the filter then press Open
* At the bottom left panel, click on Programming -> Recovery.
* In the Properties listing, you should see 059R2L8 RM-820_Rogers_Canada_VAR240202_V2_Yellow 1232.2109.1242.1002
* Click on that line that shows the data that I listed above then click the Start button.
* Plug in your phone to the USB now, hold the Vol-Down + Power buttons until the phone restarts and you hear a vibration.
* When you hear the vibration, press Retry.
* You should see a little menu saying that the Product Code doesn't match, press Okay to continue.
* Let it flash.
* After the phone has flashed, set it up, but don't login to your Microsoft account yet (It's pointless at this point). Configure Wi-Fi though.
* Go to Settings -> Phone update and check for updates. The first round of updates will put you on to Portico.
* After these updates go through (It will take forever for it to finish Preparing to Install), you'll have to check for updates two more times in order to install Nokia Updates.
* After these two extra updates, your phone will be up to date.
* Now comes the fun part. Open up the WperHelper that you installed earlier.
* On the Top group of text links(The bigger text), chose the second one from the left. It should bring up a screen with 4 drop downs.
* From left to right, choose the following as values: Nokia, Lumia 920, RM-820, 3047.0000.1326.2001.
* Click on the 059R2L5 button that is located under the first dropdown. At the bottom right part of the screen, you'll see a download icon (downward facing arrow with a line underneath of it). Click it.
* This will start to download the ROM. When complete, Click on the Top group of text links, click on the third one then click on the second smaller text link underneath of it.
* You should see bbs.wper.com_059R2L5.7z. Click on it then click the lightning bolt on the bottom left corner. This will extract the FFU package.
* After it's complete, you'll see a new screen with a picture of a Windows phone and a bunch of Chinese text (I wish I had a translation). At this point you'll want to click the button that is listed directly under ( Step ).
* This will automatically begin the ROM updating process. You'll be able to see a little log running at the bottom of the screen on whether the Flashing is working or not.
* The place where the Windows Phone is showing will display the actual progress of flashing as it appears on your phone. You should be seeing the red screen with the progress bar on your windows phone by now. If this happens for you, then you're on your way to having the Amber Update.


A few things to note

After fully flashed, it'll bring you back to the typical phone set up screen. After you get to the main homescreen, wait a minute or so because it will require a reboot. After you bring the phone back up, go to Settings -> Access Point and choose AT&T - LTE 2 - Lumia. This will set up the MMS and Data settings correctly.

Have fun!

EDIT:

I've found a way to get Internet Sharing working for AT&T Customers.

* Install the Spanish keyboard via Settings -> Keyboard -> add keyboards-> Spanish (Spain). It should be showing a Preparing Download status.
* A menu should a pear that says that the update is ready to be installed. At this point, postpone it.
* You should see internet sharing underneath Settings. Click on it and attempt to turn it on. You should see the error to call 611.
* Go back to Settings -> language+region and set the Country/Region to United States. Let it reboot.
* After reboot, Go into Settings -> phone update and install the update and let it reboot.
* After this reboot, play around with the phone for 5 or 10 minutes. Let it get used to the change in region then go to Settings -> internet sharing and attempt to turn it on.
* At this point, you shouldn't see any errors and you should be able to share your connection.

Try this out and see if it works. For the heads up
Last edited by snickler; 15th September 2013 at 06:04 PM. Reason: Put the wrong set of correct file names in
The Following 6 Users Say Thank You to snickler For This Useful Post: [ View ]
11th August 2013, 01:09 PM   |  #2  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Also, be sure to update your extras+info app in order to get call and SMS blocking. Download here

I've found a way to get Internet Sharing working for AT&T Customers.

* Install the Spanish keyboard via Settings -> Keyboard -> add keyboards-> Spanish (Spain). It should be showing a Preparing Download status.
* A menu should a pear that says that the update is ready to be installed. At this point, postpone it.
* You should see internet sharing underneath Settings. Click on it and attempt to turn it on. You should see the error to call 611.
* Go back to Settings -> language+region and set the Country/Region to United States. Let it reboot.
* After reboot, Go into Settings -> phone update and install the update and let it reboot.
* After this reboot, play around with the phone for 5 or 10 minutes. Let it get used to the change in region then go to Settings -> internet sharing and attempt to turn it on.
* At this point, you shouldn't see any errors and you should be able to share your connection.

Try this out and see if it works.
Last edited by snickler; 11th August 2013 at 03:39 PM.
The Following User Says Thank You to snickler For This Useful Post: [ View ]
11th August 2013, 04:48 PM   |  #3  
captblaze's Avatar
Senior Member
Thanks Meter: 24
 
361 posts
Join Date:Joined: Aug 2007
is this unbranded after final install and can it be rolled back to an ATT branded rom successfully?
11th August 2013, 06:02 PM   |  #4  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by captblaze

is this unbranded after final install and can it be rolled back to an ATT branded rom successfully?

its actually using an AT&T developer ROM. You should be able to go back to a stock AT&T ROM
The Following User Says Thank You to snickler For This Useful Post: [ View ]
11th August 2013, 08:17 PM   |  #5  
revxx14's Avatar
Senior Member
Flag Chicago
Thanks Meter: 60
 
315 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by snickler

its actually using an AT&T developer ROM. You should be able to go back to a stock AT&T ROM

How do I revert back to a standard ROM? I tried just downloading an AT&T ROM from the same place that we're supposed to get the pre-Portico ROMs, but that tells me that the ROM isn't meant for my device.

This is the message I get:

0xFA001304: Platform ID check fails. Reason(s): The FFU file is not meant for this product. The platform ID of image does not match with platform ID of the device.

Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.MurzimProgrammingException: 0xFA001304: Platform ID check fails. Reason(s): The FFU file is not meant for this product. The platform ID of image does not match with platform ID of the device.

at Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.RecoveryDialogModel.Flash()
at Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.RecoveryDialogModel.<HandleDownloadVariantPack ageCompleted>b__8(Object state)
11th August 2013, 09:42 PM   |  #6  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by revxx14

How do I revert back to a standard ROM? I tried just downloading an AT&T ROM from the same place that we're supposed to get the pre-Portico ROMs, but that tells me that the ROM isn't meant for my device.

This is the message I get:

0xFA001304: Platform ID check fails. Reason(s): The FFU file is not meant for this product. The platform ID of image does not match with platform ID of the device.

Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.MurzimProgrammingException: 0xFA001304: Platform ID check fails. Reason(s): The FFU file is not meant for this product. The platform ID of image does not match with platform ID of the device.

at Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.RecoveryDialogModel.Flash()
at Nokia.CareSuite.PlugIns.MurzimRecovery.RecoveryDia log.RecoveryDialogModel.<HandleDownloadVariantPack ageCompleted>b__8(Object state)

Was this AFTER you installed the AT&T Dev Rom with Amber on it?
11th August 2013, 10:02 PM   |  #7  
revxx14's Avatar
Senior Member
Flag Chicago
Thanks Meter: 60
 
315 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by snickler

Was this AFTER you installed the AT&T Dev Rom with Amber on it?

Yep. For now, I'm just reinstalling everything and going to deal with the no tethering. It's not that big of a deal, just pretty annoying. I've tried several of the AT&T ROMs listed in the link in the OP.

I think visual voicemail is broke as well, but that I don't care about at all.
11th August 2013, 10:19 PM   |  #8  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by revxx14

Yep. For now, I'm just reinstalling everything and going to deal with the no tethering. It's not that big of a deal, just pretty annoying. I've tried several of the AT&T ROMs listed in the link in the OP.

I think visual voicemail is broke as well, but that I don't care about at all.

Visual voice mail works after you first call your voicemail. That same thing happened to me.

Hmm that's interesting that you can't flash back to a stock rom anymore even though this is a RM-820 ROM.
11th August 2013, 11:11 PM   |  #9  
Member
Thanks Meter: 6
 
78 posts
Join Date:Joined: Dec 2009
More
does this works with any RM-820 Lumia 920? Mine is RM-820 but it is from Mexico.
11th August 2013, 11:37 PM   |  #10  
snickler's Avatar
OP Forum Moderator / Recognized Developer
Flag Wheeling, WV
Thanks Meter: 535
 
892 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by lrhage

does this works with any RM-820 Lumia 920? Mine is RM-820 but it is from Mexico.

It should still work.

The Following User Says Thank You to snickler For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes