Post Reply

[DEV][ROM][JB 4.3][Unofficial] CM10.2.1

OP bubor

27th August 2013, 07:07 AM   |  #1  
OP Senior Member
Thanks Meter: 1,076
 
556 posts
Join Date:Joined: Feb 2013
Donate to Me
More
CM 10.2


Issue:
No BT call.
Broken audio in VOIP (viber,skype,teamspeak etc). Tinyalsa would fix that, but it breaks calls. ( Read this)
Mic key (voice search) works, you need to enable: settings -> system -> hardware keys -> enable custom actions (check) and app switch set to voice search.
To get home key logn press action: settings -> system -> hardware keys -> enable custom actions (check) and home key (long press) set to Recent app switcher
When you upgrade, phone app may not work, you must remove the shourtcut, and readd. (thanks scotte9999)
Sometimes it stuck boot logo (cm,samsung,roger), or boot loop, try to remove battery and wait 4-5minutes, or flash stock ICS with odin, and try again. (report back if any of those works)
Liblight works very simple, when your lcd birghtness low buttons and keyboard light is on. You can use qwertyled or other liblight,read more.
Slow storage performance in some apps.
Camera doesnt put exif orientation to the jpeg.

Report issue, bugs
Always try it with clean (full wipe) install before post issue. Dont send PM, I wouldnt reply.

Download ( http://dualhoki.vim.hu/bubor/dev/10.2/ ) :
nightly:http://dualhoki.vim.hu/bubor/dev/10.2/nightly ( for mirror replace hostname to rpi.bubor.hu )
OLD release:http://dualhoki.vim.hu/bubor/dev/10.2/M1 ( for mirror replace hostname to rpi.bubor.hu )
Release:http://dualhoki.vim.hu/bubor/dev/10.2/RC1 ( for mirror replace hostname to rpi.bubor.hu )
Linaro test build, include usb serial console: http://dualhoki.vim.hu/bubor/dev/10.2/linaro
Bigger gapps http://dualhoki.vim.hu/bubor/dev/gapps-jb-4.3-full.zip , rom has a minimalized gapps, you might need something (for example talkback)


Changelog
20130826: first release
20130827: fix phone call
20130827-2: include tonyp's gapps package. https://github.com/tonyp/android_vendor_google
20130828: update ril.h, it should fix call issue
20130902: selinux, facelock
20130904: keyboard light
20130905: filemanager fix (total commander see storages)
20130911: phone encypt support
20130913: BT LPM support, overclock support
20130924: update cm-10.2
20130926: replace charger to the old one.
20131002: www/com key
20131007: update cm-10.2
20131014: keyboard arrow bug
20131022: disable fsync via sysfs ( echo 0 >/sys/module/sync/parameters/fsync_enabled )
20131028: torch fix (quick settings etc)
20131028 second release: vibration intensity settings -> (device) more -> Vibrator intensity
20131104 usb storage mount fix
20131109-m1: sdcard removable, dynamic_fsync, fsync_enabled removed, some sdcard performance improve
20131110-m1: fix traffic indicator arrows
20131113-m1: update gapps (gmaps, google play store), include recovery
20131126-m1: removed _ofline_ charger (probably nobody used)
20131204-rc1: update to rc1
20140225: update to CM 10.2.1

Cm 10.2 changelog
http://review.cyanogenmod.org/

Install:
I use TWRP, but CWMR would work too. Use latest modem ( UCLJ3
You need only one zip, gapps included.
Full wipe.
Install from recovery.
Last edited by bubor; 25th February 2014 at 08:02 AM.
The Following 51 Users Say Thank You to bubor For This Useful Post: [ View ]
27th August 2013, 07:07 AM   |  #2  
OP Senior Member
Thanks Meter: 1,076
 
556 posts
Join Date:Joined: Feb 2013
Donate to Me
More
reserved
Can I install top of my old rom?
You always could do that, but you must do clean install when report bog.

canīt swap SDCards
  • edit /sysrem/build.prob and add:
    Code:
    # Change to 1 for swapping SD cards
     persist.sys.vold.switchexternal=1
    below
    Code:
    # Storage configuration
    ro.vold.switchablepair=/storage/sdcard0,/storage/sdcard1
You can use recovery installable zip: http://dualhoki.vim.hu/bubor/dev/swa...externelsd.zip

gyroscope fix
power off the phone (better remove battery for sure), put on a desk, power on and wait, it shoud calibrate itself.

Fix skype audio
Read this. It will break your call sound, Incoming calls work fine with ring tone on.

Slow io performance
type as root:
echo 0 >/sys/module/sync/parameters/fsync_enabled
You can place in /system/etc/init.d/S99fsync file this code, chmod 775 /system/etc/init.d/S99fsync , Settings will persist, until reinstall the rom.
Its disable fsync, what makes it faster, but you would lost date on crash. Internal sd card was 1.2M/sec, after 6.2M/sec
removed in 20131109

Credits:
* tonyp https://github.com/tonyp/android_vendor_google
* Epsylon3 https://github.com/tpruvot/android_device_samsung_i9103
* kick buttowski
* Adam77Root
* yohan4ws
* gtmaster303
* The-Covenant team
* dman3285
* thegreatergood
* spyke555
Last edited by bubor; 10th November 2013 at 08:09 AM.
The Following 14 Users Say Thank You to bubor For This Useful Post: [ View ]
27th August 2013, 03:42 PM   |  #3  
Senior Member
Thanks Meter: 31
 
395 posts
Join Date:Joined: Feb 2012
More
That's awesome man, good work.

Sent from my SGH-I927 using XDA Premium 4 mobile app
27th August 2013, 05:26 PM   |  #4  
Member
Thanks Meter: 1
 
31 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by taiber2000

That's awesome man, good work.

Sent from my SGH-I927 using XDA Premium 4 mobile app

how about the bluetooth headset? Is it working?
27th August 2013, 06:21 PM   |  #5  
jadeisjaded's Avatar
Member
Thanks Meter: 22
 
59 posts
Join Date:Joined: Aug 2013
More
Thanks, bubor! I'm going to try it out today and report any issues I encounter.
Last edited by jadeisjaded; 27th August 2013 at 06:28 PM.
27th August 2013, 06:42 PM   |  #6  
OP Senior Member
Thanks Meter: 1,076
 
556 posts
Join Date:Joined: Feb 2013
Donate to Me
More
Quote:
Originally Posted by dr.mefisto

how about the bluetooth headset? Is it working?

Read first post, BT call doesnt work, but mp3 playing with headset works.
The Following 4 Users Say Thank You to bubor For This Useful Post: [ View ]
27th August 2013, 06:55 PM   |  #7  
Member
Thanks Meter: 1
 
31 posts
Join Date:Joined: Feb 2013
well, sorry I really don't know how did I skept this
27th August 2013, 09:37 PM   |  #8  
Member
ESTANCIAS
Thanks Meter: 12
 
82 posts
Join Date:Joined: Feb 2013
SIM not detected, but I can make calls and send and recive SMS


edit

No service, insert SIM and reboot
Last edited by ugoPS; 27th August 2013 at 09:45 PM.
29th August 2013, 03:31 AM   |  #9  
Junior Member
Flag Toronto
Thanks Meter: 2
 
17 posts
Join Date:Joined: Jun 2012
Donate to Me
More
I noticed that the Phone app as well as Local and Navigation apps aren't available. I'm re-downloading the zip and will do a fresh reinstall. Steps I took to upgrade from CM10.1.2:

Using CWM
1) Copy CM10.2 zip to sdcard
2) Backup
3) Wipe data/factory reset
4) Wipe dalvik cache
5) Install CM10.2 from zip
6) Restore data (advanced restore -> restore data)
7) Reboot

All user installed apps were upgraded upon first boot. And they seem to work fine. Even Gmail and Maps works. I can receive calls, and I can make calls from the People app. But when I tap on the Phone app, a message states that the app is not installed. In addition, there is no Local or Navigation app in my app list.
29th August 2013, 04:45 AM   |  #10  
Member
ESTANCIAS
Thanks Meter: 12
 
82 posts
Join Date:Joined: Feb 2013
Using CWM
1) Copy CM10.2 zip to sdcard
2) Wipe data/factory reset
3) Wipe dalvik cache
4) advanced/ wipe davlin cache
5) formar sistem
6) instal from sd card
7) reboot

Calls work well for me
Sent from my SGH-I927 using xda app-developers app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Captivate Glide Android Development by ThreadRank