XDA Xposed Tuesday: Modify the Look of Your Volume Control – XDA TV

How many screenshots have you seen with a volume status bar in the … more

Prepare Your Nokia X2 for Battle with Nokia X2 Tools

Unveiled in June this year, the Nokia X2 is the Finnish companys second crack at an … more

Increase the Speaker Volume of Your Samsung Gear 2 with Tool and Tutorial

I think its pretty safe to say that any sound coming out of a … more

Unlock Hidden Camera Settings on Your Moto G

At one point in time or another, weve all gotten very fiddly with the camera settings on our … more
Post Reply

[Q] L9 p769 stuck in S/W Upgrade Mode

13th September 2013, 02:33 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2012
Hello,

Well this is my first time posting here. And my first time rooting a phone, I've rooted tablets before.

I bought an Lg Optimus MS769 and that same day I rooted it. I used this tutorial to flash the v20f T Mobile ROM http://forum.xda-developers.com/show....php?t=2085344
After that my phone didn't look like Metro anymore my phone loaded like if it was a T Mobile one. I wanted to install CWM and a custom ROM but in some tutorials it said that I had to have unlocked bootloader which I didn't. After going through some tutorials somehow while using the R&D Test tool my phone got stuck in the S/W mode and would not go anywhere else. The only thing I was able to do was turn it on and off, no hard reset or anything. Now when I try to redo the tutorial I used to flash my phone it stops in step 11 when the phone update tool is updating. It just says that my phone is not connected, that I have to reconnect it and click restart to resume update.

Does anyone know how to get it unbricked and back to "normal"? I'ved tried fastboot and that seems to be the only thing I can do with my phone. But all it does is go to a black screen with the lg logo and it's inverted. After doing this it turned my S/W upgrade mode inverted too! I did noticed that the logo in the S/W upgrade mode was green and now when it got inverted it turned blue. Maybe this was my imagination. I don't understand fastboot though because I can't do anything there, I press all buttons but nothing happens. I try fastboot from this tutorial http://forum.xda-developers.com/show....php?t=2119090 and when I get to step 14 I don't know what they mean by installing the drivers again. When I try to it just says they are up to date.

So can someone tell me in detail what to do? That way I don't spend too much time trying to figure out things because I'm short in time with work and school. Thank you and here a few pics of what my phone looks like the places where it appears on my computer.






Thanks!
13th September 2013, 03:01 AM   |  #2  
Senior Member
Flag Chicago
Thanks Meter: 427
 
493 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by akwlb

Hello,

Well this is my first time posting here. And my first time rooting a phone, I've rooted tablets before.

I bought an Lg Optimus MS769 and ....:


Fastboot your phone, select option 5.
Fastboot again , this time use #1
type
Code:
fastboot erase cache
Remove the battery, unlpug the usb cable, press the volume+ and connect the phone to the computer. You should see S/W upgrade mode, Place the battery back in your phone. Try flashing with R&D Test .
Last edited by Lelus; 13th September 2013 at 03:51 AM.
The Following User Says Thank You to Lelus For This Useful Post: [ View ]
13th September 2013, 04:09 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Lelus

Fastboot your phone, select option 5.
Fastboot again , this time use #1
type

Code:
fastboot erase cache
Remove the battery, unlpug the usb cable, press the volume+ and connect the phone to the computer. You should see S/W upgrade mode, Place the battery back in your phone. Try flashing with R&D Test .

What do you mean by select option 5 and then #1? When I'm in fastboot I can't do anything, its just the screen, no options show and nothing happens when I i press any buttons. I tried to do what you said and this what it looked like. When I go back to R&D the same thing keeps happening. It says there's problems communicating my phone with the pc.
This is how I fastboot it and how I did the fastboot erase cache like you said
13th September 2013, 04:12 AM   |  #4  
Senior Member
Flag Chicago
Thanks Meter: 427
 
493 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by akwlb

What do you mean by select option 5 and then #1? When I'm in fastboot I can't do anything, its just the screen, no options show and nothing happens when I i press any buttons. I tried to do what you said and this what it looked like. When I go back to R&D the same thing keeps happening. It says there's problems communicating my phone with the pc.
This is how I fastboot it and how I did the fastboot erase cache like you said

Use this one

and don't worry about drivers.
13th September 2013, 05:23 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Lelus

Use this one

and don't worry about drivers.

I used the new fastboot you said. Well this got my inverted s/w upgrade mode fixed. Now it is normal and the little s/w logo is back to green. When I try to do the phone update it stops once again at 15%. The first time I flashed the v20f I had this problem but instead of going straight to s/w mode to upgrade the phone I had to just connect the phone and put it in lg software mode. When I did this and ran the update it automatically set my phone in s/w upgrade mode. But since my screen is only stuck in s/w I guess that is why it is failing the update. When I do run the fastboot at the end it takes me to the "yours" folder. Is there any files i can download and put in the yours folder and run them through the fastboot to maybe get the phone unstuck in the s/w upgrade mode?

Well I feel a little more relieved and thanks for your help.
13th September 2013, 12:55 PM   |  #6  
Senior Member
Flag Chicago
Thanks Meter: 427
 
493 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by akwlb

I used the new fastboot you said. Well this got my inverted s/w upgrade mode fixed. Now it is normal and the little s/w logo is back to green. When I try to do the phone update it stops once again at 15%. The first time I flashed the v20f I had this problem but instead of going straight to s/w mode to upgrade the phone I had to just connect the phone and put it in lg software mode. When I did this and ran the update it automatically set my phone in s/w upgrade mode. But since my screen is only stuck in s/w I guess that is why it is failing the update. When I do run the fastboot at the end it takes me to the "yours" folder. Is there any files i can download and put in the yours folder and run them through the fastboot to maybe get the phone unstuck in the s/w upgrade mode?

Well I feel a little more relieved and thanks for your help.

try following :
Code:
fastboot erase boot
fastboot erase recovery
fastboot erase divxkey
fastboot erase misc
fastboot erase fota
fastboot erase reserved
fastboot erase system
fastboot erase userdata
fastboot erase cache
fastboot erase persist
fastboot erase mlt
hopefully it'll let you go past 15%
14th September 2013, 07:25 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by Lelus

try following :

Code:
fastboot erase boot
fastboot erase recovery
fastboot erase divxkey
fastboot erase misc
fastboot erase fota
fastboot erase reserved
fastboot erase system
fastboot erase userdata
fastboot erase cache
fastboot erase persist
fastboot erase mlt
hopefully it'll let you go past 15%

I put all those commands then tried to do it again. Now it stops right at the Analysis part saying that USB cable and my phone are not connected. Or something it gets all the way to the Update part and also stops at 15%. After I did those commands I went again to do the faboot option 5 then 1 and tried it again and the same thing keeps happening. I even tried doing option 7 because my phone came with jb already and still no luck. When it is updating the phone does shuts off("disconnects itself") and then turns itself back on. I don't know if that is normal.

On the R&D test tool. What should the work directory be? I changed it at one point, is it the same as where you have the kds file in? The first time I did this I had phone mode in emergency and then I see another video that says that phone with v20f should keep phone mode in DIAG.
14th September 2013, 02:33 PM   |  #8  
Senior Member
Flag Pathumthani
Thanks Meter: 704
 
882 posts
Join Date:Joined: Aug 2011
More
Quote:
Originally Posted by akwlb

I put all those commands then tried to do it again. Now it stops right at the Analysis part saying that USB cable and my phone are not connected. Or something it gets all the way to the Update part and also stops at 15%. After I did those commands I went again to do the faboot option 5 then 1 and tried it again and the same thing keeps happening. I even tried doing option 7 because my phone came with jb already and still no luck. When it is updating the phone does shuts off("disconnects itself") and then turns itself back on. I don't know if that is normal.

On the R&D test tool. What should the work directory be? I changed it at one point, is it the same as where you have the kds file in? The first time I did this I had phone mode in emergency and then I see another video that says that phone with v20f should keep phone mode in DIAG.

In fastboot, did you choose option 5 to flash x-loader & uboot as Lelus said? Most user with JB need to do this before R&D tool can detect their phone in S/W update mode (and get pass 15%).

For DIAG mode in R&D tool that will work only when you can turn your phone on and put it in LG software mode.

Last option please try to use LG mobile support tool to recover your phone. And to do this you must remove some lines added for offline flash from hosts file because it need to download file from LG server.
Last edited by artit; 14th September 2013 at 02:35 PM.
16th September 2013, 05:08 AM   |  #9  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by artit

In fastboot, did you choose option 5 to flash x-loader & uboot as Lelus said? Most user with JB need to do this before R&D tool can detect their phone in S/W update mode (and get pass 15%).

For DIAG mode in R&D tool that will work only when you can turn your phone on and put it in LG software mode.

Last option please try to use LG mobile support tool to recover your phone. And to do this you must remove some lines added for offline flash from hosts file because it need to download file from LG server.

Yup I even did it again to test it. In fastboot I pick option 5, then option 1 to erase cache and then when I run the R&D tool It passes through analysis and download just fine. When it reaches the update I notice that at 4-5% the phone turns itself off or disconnects itself and then it connects back and reaches all the way to 15% and after a little while being on 15% it says that there is no connection between my phone and computer, to reconnect it and press restart to resume update.

The Lg tool makes me choose the phone I got and I picked the metro pcs ms769 and downloads the drivers. I tried doing the tmobile p769 but they only have the t mobile p769bk and when I choose that one it says files not found when downloading. So i proceeded with the metro pcs ms769 once I connect my phone and its detected I go to options and upgrade recovery. It then automatically finds my IMEI number to start. Like on the R&D tool I get past analyzing pc settings and download even though the download takes about an hour. When I get to the update it stops around 4% after the time elapsed reached 3 and a half hours I just closed it.

When my phone first got stuck in S/W mode I could unplug it and it will still be there, even when I turned off the phone and took out the battery. After a while now it only turns on when it is plugged in into the computer, if it is unplugged nothing happens when I try to turn it on.
16th September 2013, 05:14 AM   |  #10  
Senior Member
Flag Chicago
Thanks Meter: 427
 
493 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by akwlb

Yup I even did it again to test it. In fastboot I pick option 5, then option 1 to erase cache and then when I run the R&D tool It passes through analysis and download just fine. When it reaches the update I notice that at 4-5% the phone turns itself off or disconnects itself and then it connects back and reaches all the way to 15% and after a little while being on 15% it says that there is no connection between my phone and computer, to reconnect it and press restart to resume update.

The Lg tool makes me choose the phone I got and I picked the metro pcs ms769 and downloads the drivers. I tried doing the tmobile p769 but they only have the t mobile p769bk and when I choose that one it says files not found when downloading. So i proceeded with the metro pcs ms769 once I connect my phone and its detected I go to options and upgrade recovery. It then automatically finds my IMEI number to start. Like on the R&D tool I get past analyzing pc settings and download even though the download takes about an hour. When I get to the update it stops around 4% after the time elapsed reached 3 and a half hours I just closed it.

When my phone first got stuck in S/W mode I could unplug it and it will still be there, even when I turned off the phone and took out the battery. After a while now it only turns on when it is plugged in into the computer, if it is unplugged nothing happens when I try to turn it on.

If lg tool doesn't work , nothing probably will, unfortunately you might not be able to restore your phone. I remember few people in same situation. Hopefully the warranty will cover it.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes