Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Closed

[DEV ONLY] Dual Recovery for Xperia Z1 (LOCKED BOOTLOADERS)

OP DooMLoRD

Announcement from DooMLoRD: THIS IS STILL IN DEVELOPMENT!
23rd September 2013, 10:35 PM   |  #1  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,020
 
13,124 posts
Join Date:Joined: Jul 2010
info:

this is based on the XZU recovery for locked bootloaders by @Krabappel2548

This thread will stay a dev and discussion thread for further development issues and fixes!

Download link can be found here: XZU recovery for locked bootloaders

THIS IS INTENDED FOR LOCKED BOOTLOADER DEVICES! But works on Unlocked bootloader too


THIS IS STILL IN DEVELOPMENT STAGE!


DO NOT EXPECT IT TO WORK PROBLEM FREE!


requirements:

rooted Xperia Z1


how to enter recovery:

when you see the Sony bootlogo and when device vibrates/leds light up u can use the entry keys to enter the corresponding recovery

VOLUME UP -> CWM
VOLUME DOWN -> TWRP


what works:

BOTH CWM 6.0.3.6 and TWRP 2.6.3.0 work
you can enter both recoveries and flash small files


what doesnt work:

in this particular version of CWM, adb doesnt work; it will be fixed later.. for debugging use TWRP

Shoudl be fixed:
TWRP and CWM both can destroy /cache and /system when trying to format it. Restoring your phone using an FTF is the only option left if that happens. You can however try to not format but use rm -rf instead in TWRP (TIC BOX!!), which will do for now.

regards,

Krabappel2548,
[NUT]
DooMLoRD

Last edit by Krabappel2548 on 19-10-'13

XDA:DevDB Information
Dual Recovery for Xperia Z1 (LOCKED BOOTLOADERS), a Tool/Utility for the Sony Xperia Z1

Contributors
DooMLoRD, [NUT], krabappel2548

Version Information
Status: Testing
Current Beta Version: 0.3
Beta Release Date: 2013-10-15

Created 2013-09-23
Last Updated 2013-10-19
The Following 50 Users Say Thank You to DooMLoRD For This Useful Post: [ View ]
23rd September 2013, 10:35 PM   |  #2  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,020
 
13,124 posts
Join Date:Joined: Jul 2010
Reserved
The Following User Says Thank You to DooMLoRD For This Useful Post: [ View ]
24th September 2013, 09:33 AM   |  #3  
[NUT]'s Avatar
Recognized Contributor
Flag Cyberspace and the Universe
Thanks Meter: 6,145
 
4,139 posts
Join Date:Joined: Oct 2012
Donate to Me
More
For anyone who does not own a Z1 (like me) and wants to search through the init actions.
Attached Files
File Type: 7z system_etc.7z - [Click for QR Code] (1.95 MB, 423 views)
File Type: zip z1-ramdisk.zip - [Click for QR Code] (2.67 MB, 494 views)
Last edited by [NUT]; 30th September 2013 at 03:07 PM.
The Following 2 Users Say Thank You to [NUT] For This Useful Post: [ View ]
25th September 2013, 07:59 AM   |  #4  
acer73's Avatar
Recognized Contributor
Flag Salerno
Thanks Meter: 4,097
 
2,950 posts
Join Date:Joined: Nov 2005
Donate to Me
Look also L2 Error detected! in 1089 Line. Usb don't work right and i think because we can't write in memory stack stack(0xe4859e70 to 0xe4859eb8) for lock bootloader. Problem it's in arch / arm / mach-msm but i don't find where!
26th September 2013, 02:10 PM   |  #5  
[NUT]'s Avatar
Recognized Contributor
Flag Cyberspace and the Universe
Thanks Meter: 6,145
 
4,139 posts
Join Date:Joined: Oct 2012
Donate to Me
More
As DooMLoRD's OP somehow does not fire the mention system... repeat for function

@Kali- @Bin4ry we need your help guys!
27th September 2013, 07:32 AM   |  #6  
Bin4ry's Avatar
Recognized Developer
Flag Schwelm (NRW)
Thanks Meter: 5,750
 
1,833 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Oh now I got marked. I'll take a look at the weekend I don't have time Today sorry!

But just for me to know, ist that selfcompiled or a copy n paste version with a unpacked -> repacked ramdisk?
Have you checked against my posted recovery in Z Ultra forums? I can remember there was a similar problem on the locked bl recovery, you guys really seem to screw it somehow.
Also can i get a gdrive link to the files? Then I can grab it over my different systems more easy

Gesendet von meinem C6903 mit Tapatalk 4
Last edited by Bin4ry; 27th September 2013 at 07:47 AM.
The Following 2 Users Say Thank You to Bin4ry For This Useful Post: [ View ]
27th September 2013, 10:13 AM   |  #7  
[NUT]'s Avatar
Recognized Contributor
Flag Cyberspace and the Universe
Thanks Meter: 6,145
 
4,139 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Quote:
Originally Posted by Bin4ry

Oh now I got marked. I'll take a look at the weekend I don't have time Today sorry!

But just for me to know, ist that selfcompiled or a copy n paste version with a unpacked -> repacked ramdisk?
Have you checked against my posted recovery in Z Ultra forums? I can remember there was a similar problem on the locked bl recovery, you guys really seem to screw it somehow.
Also can i get a gdrive link to the files? Then I can grab it over my different systems more easy

Gesendet von meinem C6903 mit Tapatalk 4

It was a self-compiled version by @DooMLoRD, with a ramdisk slightly modified to get it to work for the Z1. What did you do to get it to work on the ZU? @krabappel2548 tried and failed there too...

EDIT: Just to be clear: it's not that the recovery does not work, it does, it's the kernel which triggers a reboot after 40 seconds because it seems to be unable to initialize the modem.
27th September 2013, 11:52 PM   |  #8  
DooMLoRD's Avatar
OP Recognized Developer
Flag Noida
Thanks Meter: 39,020
 
13,124 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by Bin4ry

Oh now I got marked. I'll take a look at the weekend I don't have time Today sorry!

But just for me to know, ist that selfcompiled or a copy n paste version with a unpacked -> repacked ramdisk?
Have you checked against my posted recovery in Z Ultra forums? I can remember there was a similar problem on the locked bl recovery, you guys really seem to screw it somehow.
Also can i get a gdrive link to the files? Then I can grab it over my different systems more easy

Gesendet von meinem C6903 mit Tapatalk 4

the boot hijack scripts, chargemon, are based on the ones for Xperia Z by @[NUT], with the necessary modifications, if any, for Xperia Z1

the ramdisks for the recoveries are using the same CPIO as the ones for unlocked bootloader...

recovery works well on unlocked bootloader with recovery integrated in kernel ramdisk...

will send u link over gtalk


did u post recovery for LOCKED bootloaders for Z Ultra?
28th September 2013, 06:55 PM   |  #9  
Bin4ry's Avatar
Recognized Developer
Flag Schwelm (NRW)
Thanks Meter: 5,750
 
1,833 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Ok i did some first tests!
My own recovery works (see cm boot.img !). But this one does not work when ramdisk-recovery is integrated into your dualboot script!

So it is definetly a problem with the services from the "host" system. The ramdisks which get extracted also work fine when integrated into cm boot.img!

So wild guess here: You try to stop all services from host system but it seems not to work, since you dont really need anything running for recovery, but some of the host services dont want to stop here and waiting for the system to bootup. SOMETHING seems to reboot it then when nothing is happening :P
Need to see deeper whats happening, its quite a funny problem i think :P

Regards
The Following 2 Users Say Thank You to Bin4ry For This Useful Post: [ View ]
28th September 2013, 10:05 PM   |  #10  
[NUT]'s Avatar
Recognized Contributor
Flag Cyberspace and the Universe
Thanks Meter: 6,145
 
4,139 posts
Join Date:Joined: Oct 2012
Donate to Me
More
I came to the same conclusion, but I had to give up as I had no idea what services could have been responsible

It might be the RIL service as it slingshots a lot of the radio/modem functionality... But I'm really not too sure...

Sent from my C6603 using xda app-developers app

Thread Closed Subscribe to Thread
Previous Thread Next Thread