FORUMS

What Are the Best Looking Apps on Android?

As more developers are updating their apps with Material Design elements, we’re … more

Cyngn Explained: Who’s Cyanogen, What’s Cyanogen OS?

While Cyanogen, Inc has been the source of many headlines lately, there … more

Verizon Moto X 2014 Receives Root On Kitkat 4.4.4

The Verizon Moto X 2014 has finally received root, albeit only on Kitkat 4.4.4 … more

Android 5.1.1 Released, Google Cell Service – XDA TV

Android Lollipop 5.1.1 has been released. That and much more news is covered … more
Post Reply Subscribe to Thread Email Thread

[Q] Straight Talk LTE on custom ROMs

25th September 2013, 12:09 AM |#1  
OP Junior Member
Flag San Francisco
Thanks Meter: 1
 
More
Hello there,
I have a new sim card from Straight Talk, that supports LTE/4g and i'm running Jellybean Sandwich v2.0 on my Note. With this new sim and updated APN settings I'm still getting only typical HSPA+ data connection, no luck on getting LTE to work yet.

Under Phone info (*#*#4636#*#*) menu settings I cannot switch a preferred network type, it goes back to "WCDMA preferred" all the time. Already have tried another modem (UCMD3) with no success whatsoever, it won't let me select anything else. I'm getting the same HSPA+ connection.

Any advice on how to get LTE to work, please?
 
 
26th September 2013, 03:28 PM |#2  
Senior Member
Thanks Meter: 160
 
More
I purchased my sim card a little over a month ago, and I just started seeing LTE yesterday. I'm running the most recently 10.2 nightly. I am using an AT&T GS3, not a note, however. I never purchased a new sim card. I think I may have just gotten lucky, as my wife's phone (AT&T htc one x) doesn't get LTE on straight talk, and we got our sim cards in the same envelope.
The Following User Says Thank You to tokuzumi For This Useful Post: [ View ]
26th September 2013, 10:28 PM |#3  
scariola's Avatar
Senior Member
Flag Sandy Eggo, CA
Thanks Meter: 446
 
More
Check the APN settings.
http://m.youtube.com/watch?v=s46eVgK...%3Ds46eVgKJcu8

Also make sure you are on an ATT radio. Go into dialer and press *#2263# and set to automatic if not done already.
The Following User Says Thank You to scariola For This Useful Post: [ View ]
27th September 2013, 03:32 AM |#4  
OP Junior Member
Flag San Francisco
Thanks Meter: 1
 
More
Quote:
Originally Posted by scariola

Check the APN settings.
http://m.youtube.com/watch?v=s46eVgK...%3Ds46eVgKJcu8

Also make sure you are on an ATT radio. Go into dialer and press *#2263# and set to automatic if not done already.

Looks like my APN setting are fine, thank you. I guess i need to reflash a stock ROM in order to get *#2263# to work (this combination doesn't work on custom ROMs unfortunately).
27th September 2013, 03:37 AM |#5  
OP Junior Member
Flag San Francisco
Thanks Meter: 1
 
More
Quote:
Originally Posted by tokuzumi

I purchased my sim card a little over a month ago, and I just started seeing LTE yesterday. I'm running the most recently 10.2 nightly. I am using an AT&T GS3, not a note, however. I never purchased a new sim card. I think I may have just gotten lucky, as my wife's phone (AT&T htc one x) doesn't get LTE on straight talk, and we got our sim cards in the same envelope.

Lucky you! I hope i'll get LTE to work soon too. Was running 10.2 nightly before flashing Jellybean Sandwich.
Are you using the APN settings on your GS3 off Straight Talk website?
27th September 2013, 04:49 AM |#6  
scariola's Avatar
Senior Member
Flag Sandy Eggo, CA
Thanks Meter: 446
 
More
Quote:
Originally Posted by Sfboy

Lucky you! I hope i'll get LTE to work soon too. Was running 10.2 nightly before flashing Jellybean Sandwich.
Are you using the APN settings on your GS3 off Straight Talk website?

Custom roms your dialer is *#*#4636#*#* phone information then wcdma preferred change to lte/wcdma/gsm option. Should save automatically.
27th September 2013, 08:35 AM |#7  
OP Junior Member
Flag San Francisco
Thanks Meter: 1
 
More
Quote:
Originally Posted by scariola

Custom roms your dialer is *#*#4636#*#* phone information then wcdma preferred change to lte/wcdma/gsm option. Should save automatically.

Yep tried that initially but it would always go back to "WCDMA Preferred". I have no idea why ;(
8th October 2013, 03:26 AM |#8  
Senior Member
Thanks Meter: 68
 
More
Quote:
Originally Posted by Sfboy

Yep tried that initially but it would always go back to "WCDMA Preferred". I have no idea why ;(

I've seen the same issue on CM 10.1 nightlies and now the 4.3 AOKP rom that I'm running. Under the Mobile network settings go to network operators. It normally takes a minute or two before it displays the carriers (ATT/T-Mobile). Once you select AT&T (if they are listed twice it doesn't seem to matter which you select), then try to go back and change the network mode to gsm/wcdma/lte.

Even though my sim card uses the new APN settings, I still had to contact Straight Talk's BYOB number and ask them to re-provision my sim card for LTE support.

I confirmed today that I'm getting LTE. The speed test I ran 13.61Mbps down and 4.25 Mbps up.
The Following User Says Thank You to jman315 For This Useful Post: [ View ]
8th October 2013, 03:39 AM |#9  
rangercaptain's Avatar
Senior Member
Flag West Coast of California
Thanks Meter: 1,689
 
More
Quote:
Originally Posted by Sfboy

Yep tried that initially but it would always go back to "WCDMA Preferred". I have no idea why ;(

That's all it will ever be. Why? Because note 1 modems are locked (RAT Restricted).

And H+ is 4G/LTE. Some roms might not have an LTE icon. To know for sure check phone settings and see that the network type is 14 (4G/LTE).
The Following User Says Thank You to rangercaptain For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes