Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,704 Members 52,492 Now Online
XDA Developers Android and Mobile Development Forum

FIX: Content Adaptive Backlight

Tip us?
 
xdabbeb
Old
#1  
xdabbeb's Avatar
Recognized Developer - OP
Thanks Meter 2994
Posts: 582
Join Date: Sep 2010

 
DONATE TO ME
Default FIX: Content Adaptive Backlight

I've seen a few threads/comments here about the flickering/adjusting of the backlight level at lower (less than 50%) brightness levels even though auto-brightness was off. As was suspected, it's just due to a content adaptive backlight module. It can be shut off by just running the CABLPreferences activity of the com.qualcomm.cabl app. It also looks like there is a "quality" setting in there to play with that just varies the aggressiveness of the effect.

If you don't know how to launch an activity, you can do the following:

Via ADB:
Code:
adb shell "am start -a android.intent.action.MAIN -n com.qualcomm.cabl/com.qualcomm.cabl.CABLPreferences"
Via Terminal on your phone:
Code:
am start -a android.intent.action.MAIN -n com.qualcomm.cabl/com.qualcomm.cabl.CABLPreferences
I haven't done any more checking, but I'm guessing this is just a flag that could be set in sys/devices/blah... by init.d script on boot as well.

If you prefer a gui, there are plenty of launchers out there that can select an activity to start. I actually had it set up as a long-press pie on LMT while I was playing with it.

It seems (on my phone, at least), that the app wasn't as good at turning it back on, but you can just clear the app data/cache on "Content Adaptive Backlight Settings" in application manager, reboot, and you'll be back to stock behavior.

Sorry I didn't post this sooner. I've been too busy playing with the G2!
The Following 3 Users Say Thank You to xdabbeb For This Useful Post: [ Click to Expand ]
 
jayochs
Old
#2  
jayochs's Avatar
Senior Member
Thanks Meter 2718
Posts: 8,008
Join Date: Jul 2010
Location: Central NJ
this doesn't work.

I've tried this weeks ago. simply telling the app to turn it off does nothing, as it's still on no matter what. deleting the app produces the same exact effect.

in the build prop, the line pointing to cabl is set to false. therefore it's really not even reading what the app is saying it seems.

I believe it's a kernel issue that can only be solved once we get a custom one.

again, this isn't a fix and doesn't turn it off at all sadly.

Sent from my VS980 4G using Tapatalk 4

https://www.youtube.com/watch?v=slwk...e_gdata_player this video was made when it was set unchecked and set to off.

Sent from my VS980 4G using Tapatalk 4
LG G2
Samsung Galaxy S Tab 8.4 (white)
Google Nexus 7 (2013)
 


Previous Devices:

HTC One M8 (returned)
Samsung Galaxy S5 (returned)
HTC Droid DNA
Samsung Galaxy SIII 16gb Blue

Samsung Galaxy Nexus (sold)
Nexus 7 2012 (sold)
Samsung Galaxy S4 (sold)
Samsung Galaxy SIII 16gb White (sold)
HTC Incredible (AMOLED)
HTC Eris

HTC Rezound (sold)
HTC Evo View 4G
 
xdabbeb
Old
#3  
xdabbeb's Avatar
Recognized Developer - OP
Thanks Meter 2994
Posts: 582
Join Date: Sep 2010

 
DONATE TO ME
I read your post about this a couple of weeks ago and saw that you mentioned deleting the app, but did you try running it, unchecking the box and rebooting? Deleting it won't do anything, as the app is set to run on boot and (as far as I can tell) set whatever selection you have chosen. I did and this seems to have worked for me I checked by scrolling through a spot on settings that had normally triggered it. I'll play with it more later to see if I either got lucky when I tested it or it is still happening. I agree that this is working on a kernel level.
 
SysAdmNj
Old
#4  
SysAdmNj's Avatar
Senior Member
Thanks Meter 182
Posts: 1,946
Join Date: Jun 2010
Is this issue on all carrier versions?

I use auto-brightness and the annoyance I have is that it doesn't change brightness right away when entering different lighting environments. It either takes time or doesn't change at all until I uncheck/check the auto-brightness setting.
The Following 3 Users Say Thank You to SysAdmNj For This Useful Post: [ Click to Expand ]
 
jayochs
Old
#5  
jayochs's Avatar
Senior Member
Thanks Meter 2718
Posts: 8,008
Join Date: Jul 2010
Location: Central NJ
Quote:
Originally Posted by xdabbeb View Post
I read your post about this a couple of weeks ago and saw that you mentioned deleting the app, but did you try running it, unchecking the box and rebooting? Deleting it won't do anything, as the app is set to run on boot and (as far as I can tell) set whatever selection you have chosen. I did and this seems to have worked for me I checked by scrolling through a spot on settings that had normally triggered it. I'll play with it more later to see if I either got lucky when I tested it or it is still happening. I agree that this is working on a kernel level.
yeah, if the app is deleted, then it can't run unless defaulted to on without the app. . so i tried deleting it, and then i also tried un checking the box, and it still does it. no matter what, there must be a setting somewhere else to actually turn it off. did you see that line in the build prop? it's set to false... weird right?

Sent from my VS980 4G using Tapatalk 4
LG G2
Samsung Galaxy S Tab 8.4 (white)
Google Nexus 7 (2013)
 


Previous Devices:

HTC One M8 (returned)
Samsung Galaxy S5 (returned)
HTC Droid DNA
Samsung Galaxy SIII 16gb Blue

Samsung Galaxy Nexus (sold)
Nexus 7 2012 (sold)
Samsung Galaxy S4 (sold)
Samsung Galaxy SIII 16gb White (sold)
HTC Incredible (AMOLED)
HTC Eris

HTC Rezound (sold)
HTC Evo View 4G
 
xdabbeb
Old
#6  
xdabbeb's Avatar
Recognized Developer - OP
Thanks Meter 2994
Posts: 582
Join Date: Sep 2010

 
DONATE TO ME
Quote:
Originally Posted by jayochs View Post
yeah, if the app is deleted, then it can't run unless defaulted to on without the app. . so i tried deleting it, and then i also tried un checking the box, and it still does it. no matter what, there must be a setting somewhere else to actually turn it off. did you see that line in the build prop? it's set to false... weird right?

Sent from my VS980 4G using Tapatalk 4
Yep, I did...and I remembered I had set it to true before I even began messing with the CABL App. I was thinking that could be the difference between what you and I had tried, but I just did a bit more testing to see if it was happening still and unfortunately I think I may have seen it. I'll play with it a bit more later to be sure. I also did a quick look in the usual places for this to be turned on/off in /sys/class/ and couldn't find anything. I suppose it's possible LG built the kernel for this device without the ability to turn it off. If so...that'll be unfortunate.
 
whittikins
Old
#7  
Senior Member
Thanks Meter 133
Posts: 579
Join Date: Oct 2011
Quote:
Originally Posted by xdabbeb View Post
Yep, I did...and I remembered I had set it to true before I even began messing with the CABL App. I was thinking that could be the difference between what you and I had tried, but I just did a bit more testing to see if it was happening still and unfortunately I think I may have seen it. I'll play with it a bit more later to be sure. I also did a quick look in the usual places for this to be turned on/off in /sys/class/ and couldn't find anything. I suppose it's possible LG built the kernel for this device without the ability to turn it off. If so...that'll be unfortunate.
I believe the original Nexus 7 had this feature in the kernel too. However, in custom kernels you could use Trickster mod to toggle the feature off. I think the kernel devs had to expose the setting though, so maybe we'll get this taken care of if we can get a custom kernel.
The Following 2 Users Say Thank You to whittikins For This Useful Post: [ Click to Expand ]
 
scrosler
Old
#8  
scrosler's Avatar
Recognized Developer
Thanks Meter 49826
Posts: 22,961
Join Date: Feb 2007
Location: Fargo

 
DONATE TO ME
Here are some build props for Qualcom devices that control the CABL


Code:
ro.qualcomm.cabl=1
hw.cabl.level=Auto
persist.qcom.cabl.video_only=1

By adding / editing these lines in the build.prop you should be able to adjust as noted in the lines.

And yes, it is in the kernel.


Dont know why LG has an app for it?
The Following 2 Users Say Thank You to scrosler For This Useful Post: [ Click to Expand ]
 
jayochs
Old
#9  
jayochs's Avatar
Senior Member
Thanks Meter 2718
Posts: 8,008
Join Date: Jul 2010
Location: Central NJ
Scott, I sent you a message on hangouts but in my build prop, i don't show a 1 for the cabl setting.. i show false... as if it's already turned off in the build prop. I changed it to true once and it didn't do anything. those two top settings seem to be what's in the app.. you can check a box to turn it on and off (the first line) and then you can set the degree to which it handles the cabl (second line.) I've messed with both in the app and it did absolutely nothing... does the kernel need to be changed as well?

Sent from my VS980 4G using Tapatalk 4
LG G2
Samsung Galaxy S Tab 8.4 (white)
Google Nexus 7 (2013)
 


Previous Devices:

HTC One M8 (returned)
Samsung Galaxy S5 (returned)
HTC Droid DNA
Samsung Galaxy SIII 16gb Blue

Samsung Galaxy Nexus (sold)
Nexus 7 2012 (sold)
Samsung Galaxy S4 (sold)
Samsung Galaxy SIII 16gb White (sold)
HTC Incredible (AMOLED)
HTC Eris

HTC Rezound (sold)
HTC Evo View 4G
 
Noam23
Old
#10  
Senior Member
Thanks Meter 127
Posts: 732
Join Date: Feb 2008
Quote:
Originally Posted by xdabbeb View Post
I've seen a few threads/comments here about the flickering/adjusting of the backlight level at lower (less than 50%) brightness levels even though auto-brightness was off. As was suspected, it's just due to a content adaptive backlight module. It can be shut off by just running the CABLPreferences activity of the com.qualcomm.cabl app. It also looks like there is a "quality" setting in there to play with that just varies the aggressiveness of the effect.
I'm not sure you really want to "fix" this feature.

LCD screens (like the one in the LG G2) have inherent low contrast ratio (just 1500:1, in comparison to infinity, with AMOLEDs). In order to compensate, LCD screens use a feature called "dynamic contrast", in which the backlight dims when the screen shows darker content, in order for the perceived black levels to appear darker (and not grey). I'm not sure you want to disable this feature, because the outcome will be grey blacks.

The Following User Says Thank You to Noam23 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes