Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,970 Members 48,791 Now Online
XDA Developers Android and Mobile Development Forum

WiFi problems: "Network disabled because Internet connection is slow"

Tip us?
 
jmichael08
Old
#21  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Nov 2010
Default hero

Quote:
Originally Posted by cfchong View Post
try unticking auto network switch option in wifi settings




try unticking scanning always available option in wifi settings
you are a hero. now if I could just get this phone to pair with my car bluetooth automatically like my gnex did I would not have a single gripe with this phone.
The Following User Says Thank You to jmichael08 For This Useful Post: [ Click to Expand ]
 
Spere
Old
#22  
Senior Member
Thanks Meter 48
Posts: 192
Join Date: Aug 2013
Quote:
Originally Posted by cudo View Post
What does it do? Will it affect my battery life?
I have honestly to say, I don't know

I believe it does affect your battery life (since it's called Power Save Mode)
Haven't got any need to try it.

(I got same kind issue with wlan on my old-old Nokia. For that helped disabling power save mode --> increased radio power (or something) so that wlan connection came a lot more stable)

Just posted that here because I saw that option on menu while playing with my Note. I't might help, or it might not, dunno
 
Riccosf1
Old
#23  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2007
same here.. burned through my data plan due to this poor network thinggy
hopefully unticking the boxes fixes things
ill let u guys know in a few days
 
mesubbu
Old
#24  
mesubbu's Avatar
Junior Member
Thanks Meter 1
Posts: 6
Join Date: Nov 2012
Location: Bangalore
Thumbs up It worked!!

Thanks!! after updating my Note II to 4.1.3 i was having this wifi issue at home and office. for nearly all week i was on 3G connectivity. Your suggestion solved the problem. Now i am able to connect like a breeze!! Thanks a lot.

Subbu


Quote:
Originally Posted by stesteste View Post
goto wifi setting and advanced .left click.and uncheck as in pic



Sent from my SM-N9005 using Tapatalk 2
 
kaos217
Old
#25  
Member
Thanks Meter 4
Posts: 52
Join Date: Jun 2008
I have a GS3, but I am experiencing this identical issue on 4.3

The dilemma (coming from 4.1.2) is that without checking "Auto Network Switch" under advanced wireless settings, I could not send or receive any MMS. I was getting the download prompt for inbound mms which never downloaded, and the sending message for outbound. Once unchecked, MMS works as it should. And as is pointed out here, that is somehow because the phone chooses mobile data over wireless because the connectivity integrity check of wireless determines 'Network disables because Internet connection is slow'. Which is not the case at all. I can clearly see my signal strength is excellent and the bandwidth test confirms that I am getting a good deal of my 75/35 FiOS pipe.

This only leaves the following options:

1. Uncheck 'Auto Network Switch' (under wireless>advanced) which will reconnect device to Wireless AP, but prevent MMS in or out. (should be noted that on 4.1.2, there was no 'auto network switch' option. If you were on wireless and sent/received mms, it briefly connected to mobile data to handle message.)

2. Check 'Auto Network Switch'. This allows MMS to work as expected but only because your device remains on mobile data. Indefinitely. No matter how good any wireless connection actually is, the phone defaults to disabling Wi-Fi in favor of mobile data. I can confirm there is no issue with my network connection being slow. I have excellent signal to my AP and to the Internet.


Desktop Speedtest Results



Mobile Speedtest Results



So this issue appears to be related to more than one device... is this an overall Samsung 4.3 issue?
 
tbrand68
Old
#26  
Junior Member
Thanks Meter 1
Posts: 12
Join Date: Mar 2010
Quote:
Originally Posted by kaos217 View Post
I have a GS3, but I am experiencing this identical issue on 4.3

The dilemma (coming from 4.1.2) is that without checking "Auto Network Switch" under advanced wireless settings, I could not send or receive any MMS. I was getting the download prompt for inbound mms which never downloaded, and the sending message for outbound. Once unchecked, MMS works as it should. And as is pointed out here, that is somehow because the phone chooses mobile data over wireless because the connectivity integrity check of wireless determines 'Network disables because Internet connection is slow'. Which is not the case at all. I can clearly see my signal strength is excellent and the bandwidth test confirms that I am getting a good deal of my 75/35 FiOS pipe.

This only leaves the following options:

1. Uncheck 'Auto Network Switch' (under wireless>advanced) which will reconnect device to Wireless AP, but prevent MMS in or out. (should be noted that on 4.1.2, there was no 'auto network switch' option. If you were on wireless and sent/received mms, it briefly connected to mobile data to handle message.)

2. Check 'Auto Network Switch'. This allows MMS to work as expected but only because your device remains on mobile data. Indefinitely. No matter how good any wireless connection actually is, the phone defaults to disabling Wi-Fi in favor of mobile data. I can confirm there is no issue with my network connection being slow. I have excellent signal to my AP and to the Internet.


Desktop Speedtest Results



Mobile Speedtest Results



So this issue appears to be related to more than one device... is this an overall Samsung 4.3 issue?

I was having the same issue (dropping wifi until I unticked the Auto Network Check)... did that and wifi was stable...
I started getting the MMS sending fail...
I looked around forever trying to figure this out... and while putting the Auto Network Check back on would enable MMS, I knew this couldn't be the cause of the problem (in my case)... How did I know this?? My wife has the exact same phone.. and she could send MMS messages just fine with that checked or not... so I figured it had to be something else.
I read that an MMS has to be sent via the DATA network... so I looked for an app on my phone that might "force" things through some other connection... I found it. ADBLOCK... it sets up a local proxy to block the ads... it also blocks the dns lookup for the MMS data site...
I uninstalled that and I can send MMS messages with or without the AUTO NETWORK CHECK checked now... just like my wifes phone...
The problem now is all those pesky ads popping up in the free apps... damned if you do and damned if you don't!
Anyway, just my 2 cents on this "issue".

Tim
 
richronn
Old
#27  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Default wifi advance settings

Quote:
Originally Posted by stesteste View Post
goto wifi setting and advanced .left click.and uncheck as in pic



Sent from my SM-N9005 using Tapatalk 2
I disabled (unchecked) "auto network switch" and the wifi immediately reconnected; "always allow scanning" was already unchecked
 
herojig
Old
#28  
herojig's Avatar
Member
Thanks Meter 4
Posts: 54
Join Date: Oct 2012
Location: Kathmandu
Quote:
Originally Posted by magichoward View Post
Me too ....wish I kept my note 2.

Sent from my SM-N900 using XDA Premium 4 mobile app

was your note 2 on 4.3? mine is, and same problem cropped up here when i upgraded my ROM (Hurricane 6). Battery life halved and signal problems galore on a note 2.
 
Andrewtst
Old
#29  
Andrewtst's Avatar
Senior Member
Thanks Meter 1373
Posts: 4,168
Join Date: Aug 2009
Location: Johor

 
DONATE TO ME
Un-tick both as screenshot at WiFi Advanced will solved the WiFi issue.

This is common issue at 4.3 for all Android phone, this new feature in 4.3 is silly useless.

Phone: HTC ONE (M8) | | Kernel: Stock | ROM: ViperOneM8 v1.8.0 - 4.4.2 KitKat
Future Phone: ~ nil

Ex. Phone: Nokia 3310, Samsung S500, Nokia 7610, 7270, 7280, SE K750, Nokia N73, LG Viewty KU990, Samsung Pixon, UltraTOUCH, OMNIA II, Nokia 3120 Classic, Google Nexus One, Samsung Galaxy S II, S III, Sony Xperia Z, Z Ultra, Samsung Galaxy Note 3.

Tablet: Sony Xperia Tablet Z | ROM: Stock v10.5.A.0.230 - 4.4.2 KitKat
Future Tablet: Still Finding

Ex. Tablet: Google Nexus 10
 
balabok
Old
#30  
Member
Thanks Meter 1
Posts: 30
Join Date: Jan 2009
Location: Santa Clarita, CA
I had this same connection issue. Droidwall was the culprit so I turned it off for now until I can find solution.

Tags
disabled, note 3, wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes