Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,867 Members 41,445 Now Online
XDA Developers Android and Mobile Development Forum

LG G2 critical bug regarding signal

Tip us?
 
Cst79
Old
(Last edited by Cst79; 20th October 2013 at 12:41 PM.)
#1  
Member - OP
Thanks Meter 35
Posts: 67
Join Date: Oct 2013
Default LG G2 critical bug regarding signal

Hi,

I think I discovered what seems to be a critical software bug regarding the signal of the LG G2 in weak signal environments.

In my house, the signal is generally very weak. However, it is usable. But when the phone shows 0 bars of signal due to it being placed in a very weak signal spot or hands covering the antenna, the signal strength never comes back and my number cannot be called until I take one of the following actions:

If I turn the Wi-Fi off, the signal comes back instantly. If I make a call, the signal comes back instantly and I can make the call. And if I turn the airplane mode on and then off, the signal reappears.

This has never happened on my Nexus 4, and it only happens inside my house where I have a weak signal.

Any ideas regarding the resolution of this ? Can I boost the signal sensitivity from somewhere in a secret menu ?

I hope that this issue will be solved in an upcoming update, but I can't be sure.

PS: I am running the International version of the G2, on Vodafone Romania.
The Following 2 Users Say Thank You to Cst79 For This Useful Post: [ Click to Expand ]
 
DaveHTC200
Old
#2  
Senior Member
Thanks Meter 123
Posts: 624
Join Date: Oct 2008
I have seen a similar issue at times, on international version!

Sent from my LG-D802 using xda app-developers app
SGSII - Slightly Modified
 
mm79k
Old
#3  
Senior Member
Thanks Meter 31
Posts: 113
Join Date: Jul 2006
I have no issues with my D802.

Coming out of the elevator at work (where I usually lose the signal) the phone connects automatically every single time.
 
Cst79
Old
#4  
Member - OP
Thanks Meter 35
Posts: 67
Join Date: Oct 2013
Quote:
Originally Posted by mm79k View Post
I have no issues with my D802.

Coming out of the elevator at work (where I usually lose the signal) the phone connects automatically every single time.
Of course. My phone also reconnects every time after a no-signal area, this situation is probably well-tested by LG. The problem only seems to occur in an area with a constant weak signal.
 
kcharng
Old
#5  
kcharng's Avatar
Senior Member
Thanks Meter 73
Posts: 367
Join Date: Jul 2010
Location: bangkok
Hi,

There are options in wifi setting that may help especially the low signal setting. Have you play around with it?




-LG G2
The Following 4 Users Say Thank You to kcharng For This Useful Post: [ Click to Expand ]
 
Cst79
Old
#6  
Member - OP
Thanks Meter 35
Posts: 67
Join Date: Oct 2013
Quote:
Originally Posted by kcharng View Post
Hi,

There are options in wifi setting that may help especially the low signal setting. Have you play around with it?




-LG G2
Yes I did, altered both those settings and nothing improved.

However, I did a factory reset today and I couldn't reproduce the problem anymore, until now it appeared at least 2-3 times daily, there are a few hours with no problems already. But I'm not convinced that the problem is solved.
 
Z_Black
Old
#7  
Member
Thanks Meter 13
Posts: 72
Join Date: May 2011
You aren't by chance seeing the signal drop off because of Wi-fi calling are you? I noticed the signal dropping completely when I was connected to my home network, then realized the Wi-Fi calling feature takes over for calls, textxs etc.. If I turn wifi off, it comes right back, similar to what you're seeing, though our circumstances may be different. Reception at my place is spotty at best as well and sometimes I'm roaming on at&t and other times I'm on a native tmobile tower.
ZLB Photography - www.zlbphotography.com
Personal Site and blog - www.zblackwood.com
 
Cst79
Old
#8  
Member - OP
Thanks Meter 35
Posts: 67
Join Date: Oct 2013
Quote:
Originally Posted by Z_Black View Post
You aren't by chance seeing the signal drop off because of Wi-fi calling are you? I noticed the signal dropping completely when I was connected to my home network, then realized the Wi-Fi calling feature takes over for calls, textxs etc.. If I turn wifi off, it comes right back, similar to what you're seeing, though our circumstances may be different. Reception at my place is spotty at best as well and sometimes I'm roaming on at&t and other times I'm on a native tmobile tower.
No, it's definitely a signal issue. I put a prepaid SIM card in it from another phone operator. The signal is much stronger and I don't have any signal drop problems anymore. The only problem is that I am tied by contract to the first operator, so this is only good for testing.
 
rob77
Old
#9  
Senior Member
Thanks Meter 4
Posts: 159
Join Date: Jan 2011
I have just had this problem twice today. I was in a low signal area and the bars showed a red x next to them with emergency calls only. I went to another area i know has strong signal but it didnt reconnect like it should. Eventually it came back after about 25 mins but it should come straight back and not leave me without use of my phone for that length of time. I never had this problem with my s3!
 
mcmanuf
Old
#10  
Senior Member
Thanks Meter 20
Posts: 180
Join Date: Aug 2009
Unhappy I have a serious problem with my phone

Quote:
Originally Posted by rob77 View Post
I have just had this problem twice today. I was in a low signal area and the bars showed a red x next to them with emergency calls only. I went to another area i know has strong signal but it didnt reconnect like it should. Eventually it came back after about 25 mins but it should come straight back and not leave me without use of my phone for that length of time. I never had this problem with my s3!
I also have very critical bug with my LG G2 international version reception quality.
I have never experienced the same problems with Galaxy S3

It seems to loose network connectivity, it seems randomly, bit happens more often when wifi is turned on
And also if I use the network actively it happens more often

I have sent it in for reparis (after only having it for 5 days) and my retailer sent it to LG themselves. They have checked the phone and say it passes all tests
Now I have also ordered a new SIM card, but the problem persists. The first day I lost signal 11 times. The last days I have lost it maybe 2-7 times a day.

It takes approx 1 minute to find signal after it has been lost

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes