FORUMS

Analysis & Opinion

Top Forum Discussions

[GUIDE] Return to stock for Canadian HTC One Users

1,907 posts
Thanks Meter: 480
 
By SaHiLzZ, Senior Member on 16th November 2013, 05:44 AM
Post Reply Subscribe to Thread Email Thread
This guide is for Canadian HTC One Bell Rogers Telus users who need to go back to stock firmware for warranty after flashing custom recovery/rom. If you have installed Open EU, Google, Dev, ATT, or any other kind of RUU, see post #2.


Requirements:
1. Your HBOOT is 1.55.
2. You received OTA to JB 4.3 from Rogers Bell Telus
3. Your main version is 3.x.661.x, 3.x.666.x, 3.x.631.x,
4. Some working knowledge of ADB/Fastboot.


Steps to restore stock:

Quote:

1. Download your respective nandroid backup from below:

Rogers Nandroid: Stock_JB_4.3_ROGER001_TWRP_3.22.631.1.zip - http://www.htc1guru.com/dld/m7-twrp-...-22-631-1-zip/
Bell Nandroid: Stock_JB_4.3_BM___001_TWRP_3.23.666.1.zip - http://www.htc1guru.com/dld/m7-twrp-...-23-666-1-zip/
Telus Nandroid: Stock_JB_4.3_TELUS001_TWRP_3.22.661.1.zip - http://goo.gl/sYoqei

Quote:

Telus RUU ZIP: http://www.htc1guru.com/dld/ruu-zip-...decrypted-zip/
Run fastboot oem rebootRUU.
Then, flash the RUU with the command fastboot flash zip filename

2. Download latest TWRP from: http://techerrata.com/browse/twrp2/m7

3. Reboot your device in fastboot and flash TWRP recovery. I used 2.6.3.0.

4. Reboot into recovery and do a backup of what you have working now (very important)

5. Boot back into OS

6. Unzip the nandroid backup folder and copy it to your \\SDCARD\TWRP\BACKUPS\######\somefolder\

7. Reboot back into TWRP, and restore the nandroid file

8. Reboot, your phone should be booting into your carrier firmware

9. Root

10. S-Off: Rumrunner thread, link: http://forum.xda-developers.com/show....php?t=2488772

11. Verify all is WORKING OK, then flash stock recovery, Link: http://goo.gl/2Kntxz

12. Remove *Tempered* from boot thread, link: http://forum.xda-developers.com/show....php?t=2477792

13. Unroot from SuperSU app.

14. S-On if you must, highly NOT suggested. command: fastboot oem writesecureflag 3

15. All should be good now.

Last edited by SaHiLzZ; 11th August 2014 at 05:56 PM.
The Following 11 Users Say Thank You to SaHiLzZ For This Useful Post: [ View ]
 
 
16th November 2013, 05:46 AM |#2  
OP Senior Member
Thanks Meter: 480
 
More
** I am working from theory, and NOT actual experience with this **

Guide for HBOOT 1.44 (4.1.2) & those on DEV/GPE/ATT/INTL RUU based firmwares

Bell: 1.29.666.5 - http://www.htc1guru.com/dld/m7-cwm-n...-29-666-5-zip/
Rogers: 1.29.631.4 - http://www.htc1guru.com/dld/m7-cwm-n...013-06-03-zip/
Telus: 1.29.661.5 - http://www.htc1guru.com/dld/m7-twrp-...-29-661-5-rar/

Stock Recovery for 1.44 HBOOT: http://goo.gl/Yzkwtl

1.44 HBOOT (S-Off required): http://d-h.st/qfc

Assumptions:

1. You have S-Off
2. You have 1.44 HBOOT
3. You know how to use fastboot/adb commands.

Steps to revert to 4.1.2 HTC One:

Quote:

1. Install earliest possible RUU for Dev edition.. 1.29.1540.3 http://www.htc1guru.com/dld/ruu-zip-...29-1540-3-zip/

Make sure your CID is 11111111 and MID is PN0712000.

1a. If it fails to install, install the 1.44 HBOOT from above: fastboot flash zip hboot.zip and then re-flash the DEV zip file as fastboot flash zip devruu.zip

2. Install recovery. CWM for Bell & Rogers, TWRP for Telus. Do a backup from custom recovery (mostly to generate a backup path to use in step 4)

3. Reboot back into OS

4. Unzip the nandroid backup folder and copy it to your \\SDCARD\TWRP\BACKUPS\######\somefolder\ or \\data\media\clockworkmod\ .... (I am hazy on the path detail for CWM) You may need to use ES File Explorer to move the folder around if cwm is using 0\clockworkmod folder.

5. Reboot into recovery, select restore, and restore the nandroid file.

6. You should be booting into the earliest HTC OS for Rogers, Bell, Telus. (Your fastboot getvar all will still say 1.29.1540.3, this will change after an OTA)

7. Change your CID to Rogers001, BM___001, or TELUS001 accordingly in fastboot.

8. If you are rooted, either unroot supersu, or flash this file unroot-flashable.zip from recovery: http://goo.gl/JBmJVQ

9. Install stock recovery from fastboot http://goo.gl/Yzkwtl. Do a factory reset to verify that recovery has installed. You should NOT see CWM or TWRP during reset process.

10. Reboot back into OS and check for OTA, your OTA should come through and install itself, your fastboot getvar all should now result in the correct 1.29.x.17 main version.

11. At this time, you are stock, with S-Off and unlocked bootloader. If you want to continue further to lock bootloader and S-ON, start from step 9 in post 1.

Last edited by SaHiLzZ; 9th December 2013 at 03:02 AM.
The Following 2 Users Say Thank You to SaHiLzZ For This Useful Post: [ View ]
16th November 2013, 05:47 AM |#3  
OP Senior Member
Thanks Meter: 480
 
More
Miscellaneous tips and tricks:

Last edited by SaHiLzZ; 26th February 2014 at 06:17 PM.
The Following 3 Users Say Thank You to SaHiLzZ For This Useful Post: [ View ]
18th November 2013, 07:26 PM |#4  
Junior Member
Flag prince albert
Thanks Meter: 5
 
More
Thanks for the help! was looking for the nandroid back ups. will check back when you have the 1.44 written up. Is there a way i can upgrade my hboot to 1.55 from 1.44 in order to use the nandroid in post 1. If load the 1.29 nandroid my touch screen wont work and i need to go buy a otg cable in order to accept whats on the screen.
20th November 2013, 10:06 PM |#5  
josh7cfc's Avatar
Junior Member
Thanks Meter: 0
 
More
Talking Thank You so much!!
I've been searching for the ROGERS RUU or Nandroid all day, new to Android so I didn't think of making a "nandroid" backup before flashing ROMs, but you saved me mate

Cheers!
20th November 2013, 11:23 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Rogers htc one stuck on fastboot screen
Rogers htc one stuck on fastboot screen.
20th November 2013, 11:27 PM |#7  
OP Senior Member
Thanks Meter: 480
 
More
What have you tried so far? How did it get stuck?
20th November 2013, 11:32 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Stuck on fastboot
Quote:
Originally Posted by SaHiLzZ

What have you tried so far? How did it get stuck?

Before following your instructions today, i relocked the bootloader and tried few exe and zip ruu yesterday. After that its stuck on fastboot screen.
Last edited by vksahota; 20th November 2013 at 11:37 PM.
20th November 2013, 11:46 PM |#9  
OP Senior Member
Thanks Meter: 480
 
More
What's the output of fastboot getvar all ?
20th November 2013, 11:50 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by SaHiLzZ

What's the output of fastboot getvar all ?

(bootloader) version: 0.5
(bootloader) version-bootloader: 1.55.0000
(bootloader) version-baseband: 4A.20.3263.16
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 3.22.631.1
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno:
(bootloader) imei:
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0712000
(bootloader) cidnum: ROGER001
(bootloader) battery-status: good
(bootloader) battery-voltage: 3983mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-fe1214a4f2
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.080s
Last edited by vksahota; 21st November 2013 at 12:54 AM.
20th November 2013, 11:58 PM |#11  
OP Senior Member
Thanks Meter: 480
 
More
1. Unlock boot loader and download rogers nandroid and unzip.
2. Flash TWRP
3. Boot into TWRP
4. Run a fake backup. If it fails.. Got a SD card issue, let me know so I can guide you through it.
5. On computer type adb devices. Should come back with device in recovery mode
6. AD
The Following User Says Thank You to SaHiLzZ For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes