5,594,700 Members 33,830 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Camera and album crash

Tip us?
 
makere
Old
(Last edited by makere; 28th November 2013 at 07:08 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Mar 2013
Default [Q] Camera and album crash

So I cleaned off caches and updated system applications in my phone, and now the camera application has dissappeared .

Can someone post the .apk for it, or help me to get it back?
 
jontr
Old
#2  
Senior Member
Thanks Meter 32
Posts: 137
Join Date: Jan 2012
Location: Youghal
Quote:
Originally Posted by makere View Post
So I cleaned off caches and updated system applications in my phone, and now the camera application has dissappeared .

Can someone post the .apk for it, or help me to get it back?
what happens when you press&hold shutter button?
 
makere
Old
(Last edited by makere; 27th November 2013 at 09:07 PM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Mar 2013
Quote:
Originally Posted by jontr View Post
what happens when you press&hold shutter button?
The phone vibrates slightly once, then nothing. Also if I try to run motionshot, it crashes. I tried already updating the fw to 257 and it didn't help.

Edit: I got the camera app back, by going through every camera related application and removing updates to them. Now the camera crashes if I try to launch it...

Sent from my C6903 using Tapatalk
 
jontr
Old
#4  
Senior Member
Thanks Meter 32
Posts: 137
Join Date: Jan 2012
Location: Youghal
Try to clear data for album app maybe?
 
makere
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Mar 2013
Quote:
Originally Posted by jontr View Post
Try to clear data for album app maybe?
This didn't help, however, I noticed that the album crashes as well. I tried deleting the thumbnails, but that didn't help neither.

So all other camera apps seem to work (Info-eye etc), but the normal camera and album crash. I will try to move my pictures to other folders tomorrow to see if it helps.

Sent from my C6903 using Tapatalk
 
gregbradley
Old
#6  
gregbradley's Avatar
Recognized Contributor
Thanks Meter 3299
Posts: 7,716
Join Date: Mar 2011
Location: Manchester

 
DONATE TO ME
Clear data for camera common in settings, I bet you recently changed FW versions

Sent from my C6903 using XDA Premium 4 mobile app


If you are unsure, then read this.
If you are still unsure, watch this.

 

My contributions.
If I have seen further it is by standing on the shoulders of giants. Sir Isaac Newton


[X10] | [NEO] | [Xperia T/TX] |
[Xperia Z1]
You are free to share my work, but please provide the correct credits and a link to my original thread.
<<DO NOT MIRROR MY FILES>>


Follow me on twitter
 
makere
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Mar 2013
Quote:
Originally Posted by gregbradley View Post
Clear data for camera common in settings, I bet you recently changed FW versions

Sent from my C6903 using XDA Premium 4 mobile app
Sadly this didn't help.

Sent from my C6903 using Tapatalk
 
gregbradley
Old
#8  
gregbradley's Avatar
Recognized Contributor
Thanks Meter 3299
Posts: 7,716
Join Date: Mar 2011
Location: Manchester

 
DONATE TO ME
Quote:
Originally Posted by makere View Post
Sadly this didn't help.

Sent from my C6903 using Tapatalk
OK, backup any data you want to save and do a software repair using pccompanion (Software repair will wipe data)


If you are unsure, then read this.
If you are still unsure, watch this.

 

My contributions.
If I have seen further it is by standing on the shoulders of giants. Sir Isaac Newton


[X10] | [NEO] | [Xperia T/TX] |
[Xperia Z1]
You are free to share my work, but please provide the correct credits and a link to my original thread.
<<DO NOT MIRROR MY FILES>>


Follow me on twitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...