FORUMS

Analysis & Opinion

Top Forum Discussions

[LOGO] Remove 'Unlocked Warning' message

158 posts
Thanks Meter: 578
 
Post Reply Subscribe to Thread Email Thread
After unlock your device, it will show a warning message instead the original green motorola logo. I did some modifications on logo.bin and it will back to original logo.

To do it, simply do:

fastboot flash logo logo_file_name

PS: Remember to use fastboot packed with factory image.


ADDED CWM FLASHABLE IMAGES!!!

logo.zip - original Moto G logo image without warning message
logo_gpe.zip - GPE Moto G logo image without unlocked padlock

[]'s
Attached Files
File Type: zip original_logo.zip - [Click for QR Code] (297.6 KB, 91927 views)
File Type: zip logo.zip - [Click for QR Code] (845.1 KB, 18549 views)
File Type: zip logo_gpe.zip - [Click for QR Code] (301.0 KB, 10401 views)
Last edited by ffosilva; 4th February 2014 at 03:44 PM.
The Following 286 Users Say Thank You to ffosilva For This Useful Post: [ View ]
 
 
29th November 2013, 06:22 PM |#2  
shaftenberg's Avatar
Senior Member
Flag Cologne
Thanks Meter: 726
 
More
You are the king! Thanks a million times!

How did you do this? Just curious, as this did not work on RAZRi months ago.
29th November 2013, 06:37 PM |#3  
ffosilva's Avatar
OP Senior Member
Flag Campina Grande
Thanks Meter: 578
 
Donate to Me
More
Quote:
Originally Posted by shaftenberg

You are the king! Thanks a million times!

How did you do this? Just curious, as this did not work on RAZRi months ago.

Via hex edit, man! I discovered that on header of file there's a mapping of boot type -> offset of image. =P So I changed offset of logo_unlocked to be the same as logo_boot.
The Following 11 Users Say Thank You to ffosilva For This Useful Post: [ View ]
29th November 2013, 06:46 PM |#4  
shaftenberg's Avatar
Senior Member
Flag Cologne
Thanks Meter: 726
 
More
so simple... double king!
29th November 2013, 06:46 PM |#5  
Alejandrissimo's Avatar
Senior Member
Thanks Meter: 607
 
Donate to Me
More
can cofirm this works awesome on telcel Mogo G now the ugly warning is gone, thanks a million
29th November 2013, 08:01 PM |#6  
Senior Member
Flag Scotland
Thanks Meter: 9
 
More
Tried to flash and don't know what has happened the image is not what it should be. Could someone point me in the right direction to get the correct fastboot so I can reflash. Thanks
29th November 2013, 08:06 PM |#7  
ffosilva's Avatar
OP Senior Member
Flag Campina Grande
Thanks Meter: 578
 
Donate to Me
More
Did you decompressed zip file?

Sent from my XT1033 using Tapatalk
The Following User Says Thank You to ffosilva For This Useful Post: [ View ]
29th November 2013, 08:12 PM |#8  
Benowit's Avatar
Senior Member
Flag Amiens
Thanks Meter: 171
 
More
Work fine thanks
29th November 2013, 08:22 PM |#9  
Senior Member
Flag Scotland
Thanks Meter: 9
 
More
Quote:
Originally Posted by ffosilva

Did you decompressed zip file?

Sent from my XT1033 using Tapatalk

Just reflashed it now working changed my usb port this time
29th November 2013, 10:41 PM |#10  
Senior Member
Thanks Meter: 29
 
More
I can't wait to get home from college to flash this baby... I shouldn't even be here with a brand new phone in hand =\

Thanks in advance... I know will work =D

Sent from my Moto G
29th November 2013, 11:35 PM |#11  
Senior Member
Thanks Meter: 39
 
More
Works great thanks! I wonder if this would work for my moto x as well?

Read More
Post Reply Subscribe to Thread

Tags
boot logo, moto g
Previous Thread Next Thread
Thread Tools
Display Modes