5,595,815 Members 36,240 Now Online
XDA Developers Android and Mobile Development Forum

"wlan_wake" kernel wakelock high drain problem

Tip us?
 
Bruninho98
Old
#1  
Bruninho98's Avatar
Member - OP
Thanks Meter 6
Posts: 30
Join Date: Jul 2013
Location: Esposende

 
DONATE TO ME
Battery Low "wlan_wake" kernel wakelock high drain problem

Hello, I'm having a problem, my Wakelock Detector detects a lot of wake time (72%) by a kernel wakelock named "wlan_wake" and I don't really know how to solve it! I have a Samsung Galaxy S4 i9505 with the 4.3 android version, official release, and this started to happend less than a week ago. I cleaned cache and dalvik, I tryed to let the wifi always off, and nothing worked... Solutions?
 
zetlaw
Old
#2  
Member
Thanks Meter 32
Posts: 95
Join Date: Feb 2008
Location: Beer Sheva

 
DONATE TO ME
Quote:
Originally Posted by Bruninho98 View Post
Hello, I'm having a problem, my Wakelock Detector detects a lot of wake time (72%) by a kernel wakelock named "wlan_wake" and I don't really know how to solve it! I have a Samsung Galaxy S4 i9505 with the 4.3 android version, official release, and this started to happend less than a week ago. I cleaned cache and dalvik, I tryed to let the wifi always off, and nothing worked... Solutions?
Did you recently install viber ?
Viber is known cause of keeping wifi on while the phone is in sleep mode. you can easily Greenify it.
 
medoooooo
Old
#3  
medoooooo's Avatar
Senior Member
Thanks Meter 186
Posts: 431
Join Date: Jul 2012
Location: Doha
Go to settings wifi advanced settings and disable wifi search whlie wifi is off (sory dont know the right name because I use miui
This disables the search for wifi networks while the wifi is off its a know issue in android 4.3

Sent from my GT-I9500 using Tapatalk
galaxy s4 i9500 cm 11 stock kernel

THREADS
[app] [4.0+[ Google Keyboard 2.0.19 With numbers row
The Following User Says Thank You to medoooooo For This Useful Post: [ Click to Expand ]
 
Bruninho98
Old
#4  
Bruninho98's Avatar
Member - OP
Thanks Meter 6
Posts: 30
Join Date: Jul 2013
Location: Esposende

 
DONATE TO ME
Thanks!

Enviado do meu GT-I9505 através de Tapatalk
Devices:

IF I HELPED, LEAVE A "THANKS". Thank you, thank me!
 
nirockz11
Old
(Last edited by nirockz11; 21st December 2013 at 05:32 PM.)
#5  
Junior Member
Thanks Meter 5
Posts: 25
Join Date: May 2013
It didn't help me!
but after restarting the phone the problem is gone. AND ITS BACK AFTER 2 DAYS!!!
EVERY TIME!!

Ohh yes.. And I know that if i turn of the WIFI the problem is gone..
BUT!!! I want the Wifi to be ALWAYS on..

Please help!!!
 
Z-Blade
Old
#6  
Member
Thanks Meter 12
Posts: 58
Join Date: Jan 2012
I would suggest doing a full wipe on your ROM or trying a different kernal. By the way, using CAPS and a lot of !!!!!!! will just make people not want to help you.
 
planetf1
Old
#7  
Senior Member
Thanks Meter 58
Posts: 539
Join Date: Jan 2010
Same here. See http://forum.xda-developers.com/show....php?t=2533853

Sent from my GT-N8013 using Tapatalk 4
 
Squall-Leonhart
Old
#8  
Senior Member
Thanks Meter 33
Posts: 173
Join Date: Aug 2012
Location: Here
this issue was introduced with 4.1.2

and it seems to be always occur after a application has updated through googleplay.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Google Glass XE16 Update Factory Image and Rooted Bootloader Now Available

You may recall that early yesterday, we talked about the XE16 … more

Add Swipe Utilities to Your App with SimpleFingerGestures Library

Gestures have become an increasingly important element in smartphone UI … more

Android App Review: Lock it Down with Lockdown Pro – XDA Developer TV

Our smartphones are our lives. They store our contacts, emails, … more