5,599,842 Members 46,932 Now Online
XDA Developers Android and Mobile Development Forum

Error compiling APK for i9505 (SOLVED)

Tip us?
 
cybdani
Old
(Last edited by cybdani; 4th May 2013 at 03:57 PM.)
#1  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Default Error compiling APK for i9505 (SOLVED)

Hi all!
I get these errors compiling apk's even without changes:

Code:
invalid resource directory name: ........\res/drawable-land-xxhdpi
invalid resource directory name: ........\res/drawable-sw359dp-port-xxhdpi
etc etc etc
framework installed ok to 1.apk
twframework installed ok to 2.apk


SOLUTIONS

Problem 1: invalid resource directory name: ........\res/drawable-land-xxhdpi, etc etc

-Be sure you are using an updated aapt.

Problem 2: Errors with styles when compiling

-Thanks to user .malo2000 for his solution:
-Extract files system_bar_notification_panel_title.xml and system_bar_settings_view.xml from apk. Decompile apk without these files, make changes, compile again and then push system_bar_notification_panel_title.xml and system_bar_settings_view.xml into apk. Remember to zipalign apk when finished.
The Following User Says Thank You to cybdani For This Useful Post: [ Click to Expand ]
 
Xback
Old
#2  
Xback's Avatar
Senior Member
Thanks Meter 291
Posts: 129
Join Date: Dec 2012
Location: Mumbai
Install SystemUI.apk also from system/app/
Nd try
Nd make sure if u changed ny pngs check out is it renamed properly


If Yuh like it Then Don't forget to Presssss Thanks
The Following 2 Users Say Thank You to Xback For This Useful Post: [ Click to Expand ]
 
cybdani
Old
(Last edited by cybdani; 1st May 2013 at 01:14 PM.)
#3  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Installed systemui as 127.apk but no luck, same errors.
I did not changes at the moment. Just can't get compiling again.

I tried to add ids 2 and 127 to apktool.yml and no luck.
 
adyscorpius
Old
#4  
Senior Member
Thanks Meter 1501
Posts: 2,024
Join Date: Oct 2010
Location: Delhi

 
DONATE TO ME
I got similar errors for SecContacts.. Looks like there are more dependent frameworks...

Sent from my GT-I9500 using Tapatalk 2




ROM: AdyScorpiusMIUIv5
Current Device: HTC One M7 - Couldn't bear Touchwizz!!
The Following User Says Thank You to adyscorpius For This Useful Post: [ Click to Expand ]
 
cybdani
Old
#5  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Tried installing MMAppFramework as 127 and added to yml file and same errors....
The Following User Says Thank You to cybdani For This Useful Post: [ Click to Expand ]
 
cybdani
Old
(Last edited by cybdani; 1st May 2013 at 05:29 PM.)
#6  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Hi guys. I've found a solution to compile it. But there´s a problem with apktool, I think...

Renamed the directories name ending with xxhdpi to xhdpi. Compiles ok, no errors. But obviously, apps compiled with this method does not work. Tested with SamsungCamera2, black screen and then FC.

How can we deal with that? Expect a new release of apktool?

PD: issue opened.
 
cybdani
Old
#7  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Ok, problem solved.
I was using an outdated aapt file. For those that have this problem, check aptktool and aapt version.
Now compiling ok.
Hope this helps.
 
bluflight
Old
#8  
bluflight's Avatar
Senior Member
Thanks Meter 298
Posts: 231
Join Date: Nov 2008
Quote:
Originally Posted by cybdani View Post
Ok, problem solved.
I was using an outdated aapt file. For those that have this problem, check aptktool and aapt version.
Now compiling ok.
Hope this helps.
I have all updated in my apktool, also aapt (but last version is dated 23december), but i have every time the same problems to compile. I watch everytime here http://forum.xda-developers.com/show...php?p=28366939. You found aapt file update from another link/thread?
The Following 2 Users Say Thank You to bluflight For This Useful Post: [ Click to Expand ]
 
cybdani
Old
#9  
cybdani's Avatar
Senior Member - OP
Thanks Meter 183
Posts: 458
Join Date: Feb 2012
Location: Barcelona
Quote:
Originally Posted by bluflight View Post
I have all updated in my apktool, also aapt (but last version is dated 23december), but i have every time the same problems to compile. I watch everytime here http://forum.xda-developers.com/show...php?p=28366939. You found aapt file update from another link/thread?
Download from official site here https://code.google.com/p/android-ap...r.bz2&can=2&q=
Dated 2 feb 2013
The Following 2 Users Say Thank You to cybdani For This Useful Post: [ Click to Expand ]
 
bluflight
Old
#10  
bluflight's Avatar
Senior Member
Thanks Meter 298
Posts: 231
Join Date: Nov 2008
Quote:
Originally Posted by cybdani View Post
Download from official site here https://code.google.com/p/android-ap...r.bz2&can=2&q=
Dated 2 feb 2013
Thanks for the help but for me not work.. This from official site be the same i update last time. I work on S2 and i have no problems, only now with 9505 i have this problems, and i know very much people have the same issue..

The Following User Says Thank You to bluflight For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes