5,595,645 Members 45,641 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Is rooting needed prior to downgrade stock firmware to previous version (stock)?

Tip us?
 
mfreeman3769
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 22
Join Date: Dec 2013
Default [Q] Is rooting needed prior to downgrade stock firmware to previous version (stock)?

Hello,

I have tried to downgarde S4 i337m Bell Canada from 4.3 to 4.2.2. Sam Mobile version - and the flash crashes at 2% (fails) using ODIN. Using Odin I can flash back to 4.3 and it works.

Is this an issue with the firmware file itself, or do I need to root and prep the phone in any other way?

I think the file is the cause, I don't see how the Phone's 4.3 would 'block' the flash.

Thanks,
 
RockRatt
Old
#2  
RockRatt's Avatar
Recognized Contributor
Thanks Meter 3383
Posts: 3,745
Join Date: Aug 2010
Quote:
Originally Posted by mfreeman3769 View Post
Hello,

I have tried to downgarde S4 i337m Bell Canada from 4.3 to 4.2.2. Sam Mobile version - and the flash crashes at 2% (fails) using ODIN. Using Odin I can flash back to 4.3 and it works.

Is this an issue with the firmware file itself, or do I need to root and prep the phone in any other way?

I think the file is the cause, I don't see how the Phone's 4.3 would 'block' the flash.

Thanks,
I believe it is ALL S4's that took the updates to 4.3 and IF you try flashing back from 4.3 to 4.2.2 you can brick your phone. Check out the international S4 forums and see these results. The bootloaders do NOT ALLOW going backwards any longer. The same thing is happening on the S3's that updated to 4.3 as well. At least with the S3's they can still get a custom recovery and flash any Roms, including 4.2.2 based Roms that do not flash bootloaders.

Sent From My Spiderman,Ironman,Red,Dark Blue,Green, GreyedOut BadAss Themed I337
The Following User Says Thank You to RockRatt For This Useful Post: [ Click to Expand ]
 
HiTideBlastoise
Old
#3  
Senior Member
Thanks Meter 31
Posts: 222
Join Date: Nov 2012
I thought you could on the 1337m.

Sent from my SAMSUNG-SGH-I337 using xda app-developers app
 
SaHiLzZ
Old
#4  
Senior Member
Thanks Meter 297
Posts: 1,367
Join Date: Jan 2011
Use mobile odin and flash the old firmware. MobileOdin does not flash bootloaders. Also I have seen 4.3 bootloader mixed with 4.2.2 firmware disables wifi for some reason.

Let us know how it goes.
The Following User Says Thank You to SaHiLzZ For This Useful Post: [ Click to Expand ]
 
mfreeman3769
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 22
Join Date: Dec 2013
Mobile Odin not working in 4.3 ....


Quote:
Originally Posted by SaHiLzZ View Post
Use mobile odin and flash the old firmware. MobileOdin does not flash bootloaders. Also I have seen 4.3 bootloader mixed with 4.2.2 firmware disables wifi for some reason.

Let us know how it goes.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Add Swipe Utilities to Your App with SimpleFingerGestures Library

Gestures have become an increasingly important element in smartphone UI … more

Android App Review: Lock it Down with Lockdown Pro – XDA Developer TV

Our smartphones are our lives. They store our contacts, emails, … more

Get the AOSP Lock Screen on Your ICS-Powered Samsung Device

Android is the only popular mobile operating system that allows users, … more